Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
dkerber

Help save me from myself - exposure lengths

Question

I've been bitten by this before, but generally caught it. Last night I didn't, and lost an hour of data.

On my T3i (600D), if the settings wheel is set to Manual, BYE shows that, as it it should. But it also allows me to select Bulb mode in my Imaging settings, when that won't actually work. So what I ended up getting were 5 second exposures (the previous setting I had used on the camera), spaced 300 seconds apart (the setting I had set in the Imaging dialog). Not a very efficient way of gathering photons!! If I had caught it like I usually do, I could have switched to Bulb mode on the camera body and all would have been good. The reason I didn't catch it was that I was using a narrow band filter for the first time, and knew it would be darker than normal, so I just thought it was the filter that caused me to need such long exposures...

I realize this is just asking for an idiot check in the software, but if it's not too difficult to code, it would be a nice enhancement to either disallow bulb settings in the dialog when the dial is set to "M" on that model camera, or give a warning that my settings are contradictory...

 

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0
13 minutes ago, admin said:

As mentioned above, try 3.1.18 again... and disconnect the camera from BYE.... delete the cache (in advance settings) and close BYE.  Then open BYE again, make sure the camera dial is set to M and turned on, then connect the camera in BYE...now can you take bulb images?  You should. 

The correct drivers for the T3i is "Canon", not "Canon210".

Keep me posted.

Clearing the cache seems to have done the trick! I can switch back and forth from bulb to presets, and all works as expected. Thanks!

Share this post


Link to post
Share on other sites
  • 0

Different Canon DSLRs treat the "M"anual/"B"ulb distinction differently, but generally, you use "M" for Exposures of 30 sec or less (because Timing Control for the Exposure is provided by the Camera CPU - tighter control) and "B" for all longer Exposures (because DSLR treats these as the old "Bulb" Wired Remote where one Press of the Shutter starts the Exposure and the next Press stops it - less finite control especially when OS and USB and Driver timing delays are introduced).

As for your description of "Operator Error", the Canon SDK doesn't provide for Software Override of the Physical Buttons/Dials on most of their DSLRs.

Share this post


Link to post
Share on other sites
  • 0
57 minutes ago, s3igell said:

Different Canon DSLRs treat the "M"anual/"B"ulb distinction differently, but generally, you use "M" for Exposures of 30 sec or less (because Timing Control for the Exposure is provided by the Camera CPU - tighter control) and "B" for all longer Exposures (because DSLR treats these as the old "Bulb" Wired Remote where one Press of the Shutter starts the Exposure and the next Press stops it - less finite control especially when OS and USB and Driver timing delays are introduced).

As for your description of "Operator Error", the Canon SDK doesn't provide for Software Override of the Physical Buttons/Dials on most of their DSLRs.

Yup, I was just hoping for a warning that selecting Bulb in the imaging settings might not work with Manual selected on the camera's dial.

 

Share this post


Link to post
Share on other sites
  • 0
On 1/7/2020 at 5:03 PM, admin said:

There is such a warning already, I'm surprised the plan was allowed to start.

To be clear, I am running 3.1.18 (you'll see why that matters, below) with a T3i (600D). I went back and did some controlled testing, and now have the camera next to me, rather than working from memory, and it's not quite as I described in the OP.

There is no "B"ulb setting on the dial, only "M"anual and the other regular ones (including Tv, Av, P, etc). When I am in M, BYE does not appear to be able to set the exposure time to Bulb if the camera is not already set to B in the shutter speed settings, only to the various pre-set times that the camera times internally. If I manually (on the camera) select Bulb while the dial is on M, then Bulb times work as expected, but that's not an answer either, because if I then switch BYE to a preset Tv, (1/20, etc), it changes it on the camera, and then I can't get back to bulb settings from BYE. So BYE can override the camera when switching from Bulb to a preset speed, but not when trying to switch the other direction (from a preset to Bulb).

I had thought it used to work before you consolidated to just the two choices for Canon drivers (Canon, and Canon 210), so I went back and installed 3.1.16, which has Canon, Canon 210 and Canon 215 drivers as options, and when I select 215 when connecting, it now works as expected: with the dial on M, I can select the various shutter speeds, or Bulb, they all work as expected, and I can switch back and forth in either direction.

HTH!

Share this post


Link to post
Share on other sites
  • 0

<When I am in M, BYE does not appear to be able to set the exposure time to Bulb if the camera is not already set to B in the shutter speed settings, only to the various pre-set times that the camera times internally. >

Are you saying that BULB is not available in the Shutter dropdown in BYE's Capture Plan Center on the Imaging screen? If so, then does deleting the cache data on the Advanced Settings screen and restarting BYE with the camera in Manual mode fix it? I am not sure, but perhaps an old bug has crept back into the program.

 

 

Share this post


Link to post
Share on other sites
  • 0

As mentioned above, try 3.1.18 again... and disconnect the camera from BYE.... delete the cache (in advance settings) and close BYE.  Then open BYE again, make sure the camera dial is set to M and turned on, then connect the camera in BYE...now can you take bulb images?  You should. 

The correct drivers for the T3i is "Canon", not "Canon210".

Keep me posted.

Share this post


Link to post
Share on other sites
  • 0
20 minutes ago, astroman133 said:

<When I am in M, BYE does not appear to be able to set the exposure time to Bulb if the camera is not already set to B in the shutter speed settings, only to the various pre-set times that the camera times internally. >

Are you saying that BULB is not available in the Shutter dropdown in BYE's Capture Plan Center on the Imaging screen? If so, then does deleting the cache data on the Advanced Settings screen and restarting BYE with the camera in Manual mode fix it? I am not sure, but perhaps an old bug has crept back into the program.

 

 

"Bulb" is available in the drop-down, but it doesn't take control of the exposure time; the last non-bulb value on the camera is what it actually shoots. So if I had shot 5-sec ("5" selected in the drop-down) exposures on M42, then went to the Horsehead and changed the drop-down to Bulb and set the exposure length to 300, when I start the sequence, it was shooting one 5-second exposure, every 5 minutes. The count-up timer display went to 300, but the actual shutter time was 5 sec.

Share this post


Link to post
Share on other sites
  • 0

I had something similar happen with my T5i but I was using the SAM Mini from Skywatcher which has a bulb release cable.  I had it set to M but it was only giving me 2 second exposures even though the software was supposed to be 30 seconds.  I finally figured out that the jog dial for shutter speed was overriding the cable.  It was set at 2 seconds (must have hit it while setting up) but would only click every 30s or so when the software started the sequence.  I now have to make sure that the jog dial is set to bulb to run it by the Cable.  Didn't have this feature on my old T3 so makes me wonder if it is similar to the T3i.

Share this post


Link to post
Share on other sites
  • 0
47 minutes ago, dkerber said:

I wonder if this issue is related to switching between various cameras? I used to use a T1i (500D) with it, then got the T3i, but occasionally also use my 1DXMk2.

No, there is no conflict with connecting different camera.

Share this post


Link to post
Share on other sites
  • 0
49 minutes ago, dkerber said:

Clearing the cache seems to have done the trick! I can switch back and forth from bulb to presets, and all works as expected. Thanks!

Awesome!

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, AaronSmall said:

I had something similar happen with my T5i but I was using the SAM Mini from Skywatcher which has a bulb release cable.  I had it set to M but it was only giving me 2 second exposures even though the software was supposed to be 30 seconds.  I finally figured out that the jog dial for shutter speed was overriding the cable.  It was set at 2 seconds (must have hit it while setting up) but would only click every 30s or so when the software started the sequence.  I now have to make sure that the jog dial is set to bulb to run it by the Cable.  Didn't have this feature on my old T3 so makes me wonder if it is similar to the T3i.

What you're describing sounds exactly like what I was seeing until I cleared the cache (as Guylain described above).

 

Share this post


Link to post
Share on other sites
  • 0

Randall,

Your issue is different from the original poster of this thread. You should create a new thread in the BYE support forum. Please be sure to include the version (x.y.zz) of BYE and your camera model in your post.

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use