Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
magicmotorworks

Canon EOS Ra won't take bulb photo

Question

I'm trying to take bulb photos using my newly acquired Canon EOS Ra and BackyardEOS keeps telling me to switch camera to manual setting. If i do that then I'm limited to 30 sec exposures.      I have uninstalled the Backyard software and re-installed it to make sure I didn't have a bad program load.  Continued to have the same problem.  I own a Canon 5D MkII and when I use it I have no issues with camera setting to bulb and running Backyard EOS in bulb setting to take the photos.  Please advise what I need to do or check.

 

Thanks,

Gary

(I attached my EOS Ra  directly to my laptop and set the mode to bulb. Set Backyard to take i picture on bulb for 45s at 800 ISO.  Program starts and then stops showing abort button and locks up with only the event timer running.  I have to exit the program to stop it.   Even though the log shows the camera as an EOS R model mine is the Ra)

09:07:37  Licensed to magicmotorworks
09:07:37  BackyardEOS 3.1.18 Premium Edition
09:07:45  Attempting to connect camera...
09:07:46  Canon drivers 'Canon\' initialized.
09:07:50  EOS-R CONNECTED!
09:08:20  Imaging session started.
09:08:20  Imaging session cancelled
09:08:20  Make sure camera is set to MANUAL, turn dial to 'M'
09:08:44  Copy to clipboard

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Tested 3.2.0.RC5 that you posted on my EOS Ra and could use the bulb mode as intended so the fix works.  

One thing that I did notice was the following

 

Using Bulb mode on Canon Ra and BYE

If using bulb mode on BYE, the Canon EOS Ra needs to have the bulb timer option in the camera menu set to disable so that the BYE program sets and controls the bulb time.

If the EOS Ra bulb timer is enabled on the camera then whatever bulb time is set in the camera will be what is taken regardless what the setting is in BYE.

 

Examples:

Canon EOS Ra settings:  Bulb timer is disabled

BYE settings under Capture Plan Center (Shutter): Bulb  (Duration): 60

Outcome:  Ra takes a 60s image using bulb mode

 

Examples:

Canon EOS Ra settings:  Bulb timer is enabled  Expo. Time:  00:01:00

BYE settings under Capture Plan Center (Shutter): Bulb  (Duration): 120

Outcome:  Ra takes a 60s image using bulb mode instead of taking a 120s exposure as in BYE plan.  BYE thinks it took a 120s exposure when it didn't

 

Examples:

Canon EOS Ra settings:  Bulb timer is enabled  Expo. Time:  00:04:00

BYE settings under Capture Plan Center (Shutter): Bulb  (Duration): 120

Outcome:  Ra takes a 240s image using bulb mode instead of taking a 120s exposure as in BYE plan

 

For BYE to use the bulb mode correctly in the capture plan make sure the  EOS Ra in camera bulb timer is disabled.

 

Thanks for your quick attention to this.

Gary

Share this post


Link to post
Share on other sites
  • 0

What do you mean if you do that you are limited to 30 seconds?

I believe you are mistaken. The EOS Ra does not have a physical "B" dial mode like you r5D MkII.

The only way to take BULB with the EOS Ra *is* to set the dial to 'M'.  Did you try to take BULB images with the Ra and the dial set to "M"?

 

Share this post


Link to post
Share on other sites
  • 0

The Ra does have a bulb shooting mode.  Attached is a pic of the lcd screen showing the shooting modes available on the Ra.  If I place the Ra in manual mode and then  in BackyardEOS set bulb in shutter and 80s in duration the camera will close the shutter at about 31-32 seconds and then show downloading for the remainder of the time till 80s is reached.  On the Ra in maual mode 30s is the largest exposure you can have.  

20200607_095757-2.jpg

Share this post


Link to post
Share on other sites
  • 0

ummm.... so the R and Ra are not identical firmware wise.  I would not have suspected this.

EDIT: I looked at both online manuals for the EOS R and Ra and they both have BULB dial mode.  I'm somewhat confused.  I personally tested the EOS-R last year and looking at source control it has not changed since that time.  Anyway, looks like this is a bug.

Send me the log file.

 

 

Share this post


Link to post
Share on other sites
  • 0

@MagicMotorWorks - Please ensure that you are clear when you detail whether you are making changes using the Camera's Mode Dial or BYE's Image Plan Shutter Mode Selector.  Please be aware that for most DSLR's you have to operate the Mode Selector Wheel, as the SDK doesn't actually have the ability to override that Dial on those Models.

Your description sounds like what would happen when BYE "Requests" that the Camera take an 80-sec Exposure (which requires Bulb Mode on the Camera) but the Camera is actually still in Manual Mode (which for most Models has a 30 second Manual-mode Limit).  This means the Camera decides to Close the Shutter at the end of 30 seconds, while BYE thinks that it is waiting for 80 seconds for the Exposure to finish.

Hope this helps...

 

Share this post


Link to post
Share on other sites
  • 0

Yes I'm making the mode changes via the selector wheel on the Ra.  When Ra is set on bulb and BYE shows that bulb is selected once you start the snap capture process on BYE the log view window tells you to switch the camera to manual mode and the program goes into abort procees.

 

I sent the requested log file to support today.

Share this post


Link to post
Share on other sites
  • 0

I can confirm that is to 99% a bug.  I don't have the "B" dial mode registered as a valid mode for the R/Ra.  I'll need to upload a new version to test this.

As I said before, I personally tested the EOS-R last year and looking at source control it has not changed since that time. 

I'll post here when I fix it and upload a new version for testing.

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, magicmotorworks said:

Tested 3.2.0.RC5 that you posted on my EOS Ra and could use the bulb mode as intended so the fix works.  

One thing that I did notice was the following

 

Using Bulb mode on Canon Ra and BYE

If using bulb mode on BYE, the Canon EOS Ra needs to have the bulb timer option in the camera menu set to disable so that the BYE program sets and controls the bulb time.

If the EOS Ra bulb timer is enabled on the camera then whatever bulb time is set in the camera will be what is taken regardless what the setting is in BYE.

 

Examples:

Canon EOS Ra settings:  Bulb timer is disabled

BYE settings under Capture Plan Center (Shutter): Bulb  (Duration): 60

Outcome:  Ra takes a 60s image using bulb mode

 

Examples:

Canon EOS Ra settings:  Bulb timer is enabled  Expo. Time:  00:01:00

BYE settings under Capture Plan Center (Shutter): Bulb  (Duration): 120

Outcome:  Ra takes a 60s image using bulb mode instead of taking a 120s exposure as in BYE plan.  BYE thinks it took a 120s exposure when it didn't

 

Examples:

Canon EOS Ra settings:  Bulb timer is enabled  Expo. Time:  00:04:00

BYE settings under Capture Plan Center (Shutter): Bulb  (Duration): 120

Outcome:  Ra takes a 240s image using bulb mode instead of taking a 120s exposure as in BYE plan

 

For BYE to use the bulb mode correctly in the capture plan make sure the  EOS Ra in camera bulb timer is disabled.

 

Thanks for your quick attention to this.

Gary

Thanks for the feedback,

 

Share this post


Link to post
Share on other sites
  • 0

I believe this is the new "Built-In Intervalometer Function" that Canon added as part of the "a" Astro Camera Features of the Canon Ra.  The other highlighted Features were the Modified IR Filter which passes 100% of 656nm Ha Frequency; and enhancing the LiveView Zoom to "30x" ("allows for precise focusing").

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use