Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

BYN file saving, preview and capture mixed up ?


williR

Question

Hi Guylain

 

I am using the premium NIKON 1.0.3 version.

 

The program is very usefull since it helps me with manual focussing my Nikon equipment.

Only disadvantage is the missing support of the lens focussing as it works for Cannon.

I would appreciate very much, and most likely also the other NIKONIANS, that this feature will be implemented one time.

 

 

There is one issue I cannot fix with the settings.

 

In Imaging,

starting a PREVIEW, -----> saves the picture in the download directory  as PREVIEW_+filename templates.ext

starting a CAPTURE, -----> saves the picture in the BackyardTEMP/Download directory  as img_n.ext

 

How can I fix it? It seems that there is something mixed up.

 

Willi

Germany

post-10149-0-04840600-1450769754_thumb.jpg

Link to comment
Share on other sites

  • Answers 11
  • Created
  • Last Reply

11 answers to this question

Recommended Posts

Hi all

Today I have got my new field laptop.

There, the program is working correct; it stores all pictures (Previews and Captures) in the BackyardNikon + sub folder.

 

Now I understand, that the post process after first downloading the files into the BackyardTemp\download directory was not carried out for the Captures.

They stayed there and because of that I supposed, the storage directories were mixed up.

But it was exactly what Rick wrote on Dec. 22.

 

The reason is still not clarified, but it works fine for me on the laptop, I only use for the field.

 

Thanks again to all

and happy new year

Willi

Link to comment
Share on other sites

Willi,

 

When BYN downloads an image from the camera its first stop is in the BackyardTEMP\Download folder.  It should then be "processed" by BYN and the final image will be in the BackyardNikon folder tree with the exact location and file name according to your defined settings.

 

It seems that this processing is failing in some way.  As a test you could go to the Advanced Settings screen and check the Skip EXIF Read and Skip EXIF Write settings.  That minimizes the processing that BYN does on the downloaded image.  It may take a review of the log files for your session to find what is going wrong.

Link to comment
Share on other sites

As well, please ensure that your Destination Drive and Directory are Valid, and since it is specified as on "D:" Drive that drive needs to be permanently accessible to BYN.

 

Looking at your settings, it appears that you might be using the Program on a Laptop/Notebook (Notebook Resolution selected).  Is "D:" a Partition of the Drive in that Laptop, or a Network Share located on other Hardware??

Could you provide a few details about the PC and OS that you are running??

 

As another Test, can you change the "Download Folder" to "C:\Users\Willi\Pictures" (since we know that Directory Tree exists and has proper Rights - per Temp Directory)??

Shooting some Test Images should result in them ending up in "C:\Users\Willi\Pictures\target\yyyy-mm-dd\" per your settings...

 

Also please ensure that the "Target" specified in the Capture Center Image Plan doesn't include any Illegal Characters (":", "\", etc)...

 

And, yes:  If difficulties continue, posting the Logfiles for Guylain to inspect would be the next step:  How-to submit Logfiles for Troubleshooting

Link to comment
Share on other sites

Hi all,

many thanks for your suggesttions.

 

OP system is WIN 7 on PC (not Laptop)

Filenaming .ext extension was my place holder for .nef or jpg, no worries ;-)

 

trials:

1. skiped EXIF read and  write   ---> no change

 2. changed download drive from D: to C:    ---> stores in c: now but not solving the problem.

 

As requested I send the log files and settings by seperate mail

 

regards, Willi

Link to comment
Share on other sites

OP system is WIN 7 on PC (not Laptop)

Filenaming .ext extension was my place holder for .nef or jpg, no worries ;-)

 

 

Actually this seems to be the root cause.

 

A lot of the tools I use expect a normal file extension to function.  Since .ext is not a regular image file extension the background worker ignores as it thinks this is not an image file.

 

Please set it back to what it should be, .nef and .jgp and I'm pretty sure it will work.

 

Thanks for sending the log files. 

 

Keep us posted.

Link to comment
Share on other sites

Guylain,

 

Either I misunderstood the OP's comment or you have. I believe that he typed .ext to avoid typing .nef/.jpg.  He has not found a way to change the file extension of the image files, I was simply using .ext as a placeholder to mean "the raw or jpeg extension". If I am incorrect, hopefully he will let us know.

 

What I don't understand from his previous post is this comment

 

" 2. changed download drive from D: to C:    ---> stores in c: now but not solving the problem."

 

If BYN is now storiing images to the download directory on the C: drive, what problem is unsolved?

Link to comment
Share on other sites

changed download drive from D: to C:    ---> stores in c: now but not solving the problem.

 

If the Final Images successfully write to C: but not D:, then it sounds like your issue is with Permissions for the Directories on D:, or simply that those Subdirectories DON'T EXIST.

 

Check this latter case first, and Create the Subdirectory, if needed.  Then re-test.

 

It is quite possible, especially if this D: Drive is a 2nd HDD added in from a Previous PC, that the Permissions for User "Willi" are not correct within the "D:\Willi\Pictures" Subdirectory Tree.

Similar circumstances if this PC has 2-more Users, and another User setup the "D:\Willi\" Directories.

 

Open "D:\Willi\" in Windows Explorer, and Right-Click on the "Pictures" Directory in the Main Window, then select Properties.

Select the "Security" Tab, and in the "Group or User Names" Table select "Willi".  Now, in the "Permissions for Willi" Table, does "Full Control" have a Checkmark in the Allow Column??

 

If not, then your "Willi" User is lacking some of the Rights necessary to manipulate the Files which are to be placed in its Subdirectories.

 

A Fix for the Permissions Issue is Simple (but do it only if you feel Comfortable - as I will not be Supporting your PC).

 

Ensure that "Willi" is selected in the "Group or User Names" Table, and then press "Edit".  Click the "Full Control" Box in the Allow Column (it will populate the rest of the Boxes in that Column).  Then Click "Apply", "OK", "Apply", "OK".

Open the Properties Window again, if you wish to confirm your Change...

 

Now, Set your "Download Folder" to your selected "D:\Willi\Pictures\" Subdirectory again, and test whether you can now Capture Images to your selected destination.

(Remember:  You don't need to Mount your DSLR to your Scope in order to Test BYN.  Just the Camera with a Lens and the USB Cables setup on the Desk or Table will do fine...)

Link to comment
Share on other sites

Permission issues would be logged.  The log files are cleaned and show no evidence of permission issues.

 

The capture images are not being logged, or very little.  This is why I was thinking the .ext extension could be the issue.  But as Rick said I may have misunderstood the OP.

Link to comment
Share on other sites

Hi all,

thank you for your support so far.

 

Here my comments on your suggestions:

 

1. 

Rick wrote:   Either I misunderstood the OP's comment or you have. I believe that he typed .ext to avoid typing .nef/.jpg.  He has not found a way to change the file extension of the image files, I was simply using .ext as a placeholder to mean "the raw or jpeg extension". If I am incorrect, hopefully he will let us know.

----> You understand correct. Sorry for the confusion.

 

2. directory change from d: to c:

It iremains to the same behavior like from the beginning if I save either  on c: or on d:

---> the CAPTUREs will be stored in the BackyardTEMP directory

---> the PREVIEWs will be stored in the Download ans Sub-folder

(see also my screenshots in the file I have sent previously)

 

This remains unchanged also after setting the full permission to the subdirectory tree in the properties.

 

I believe the problem may have something to do with my PC.

Since I have ordered a new Lap Top for the field there is another chance to verify.

To date I have no notification of delivery time, but I would come back in this matter and inform you in any case.

For now, thanks to all for your efforts

and all the best for the new year.

 

Willi

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use