Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Is there a max image capture?


NightBikes
 Share

Question

I had BYN set to take 720 lights.  At 2:43:14 am, I have no more photos (roughly 370 photos in).  Nothing was frozen, it just looked like things were completed on the BYN screen. I noticed it around 4:30 am and clicked the button to start capturing images again. My computer never went to sleep, all programs were running fine.  Anything to check?  (Firewall was turned off) Thank you.

Logs were emailed since they were too big to attach. 

Link to comment
Share on other sites

  • Answers 18
  • Created
  • Last Reply

Top Posters For This Question

18 answers to this question

Recommended Posts

  • 0

NO, imaging will run until the plan is complete.

Something interesting in the log file this time around.

 

At 02:43:48,596 the camera sdk reported the camera dial to Manual as it should.

At 02:43:48,646, 50 millisecond later, the SDK reported the camera dial to "" (nothing/blank) ??? <== this cause the capture to error out.

At 02:43:48,963, some 300+ milliseconds later, the camera sdk reported the camera dial to Manual again, as it should.

 

2022-02-13 02:43:48,549 [CameraTakePictureOnMessageRecieved] INFO  - DOWNLOAD Camera Properties Completed
2022-02-13 02:43:48,596 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: AeMode               = 'MANUAL'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Tv                   = 'Bulb'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Av                   = '--'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Av                   = '--'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: BatteryLevel         = '100'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: CCDDataMode          = 'Not supported'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: CameraName           = 'D7200'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: DelayShutterMilliseconds = '500'
2022-02-13 02:43:48,597 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: ImageQuality         = 'RAW'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: ImageSize            = 'L(6000*4000)'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Iso                  = '320'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: LensStatus           = '0'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: LiveviewExposurePreview = 'Not supported'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: LiveviewImageSize    = '2'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: LiveviewImageZoomRate = '0'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: MirrorLock           = '0'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: ModelNumber          = 'Type0017'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: ModelxD              = 'D7200'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: SaveTo               = 'PC'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: SensorPixelSize      = '3.89'
2022-02-13 02:43:48,612 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Tv                   = 'Bulb'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'True'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'True'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'True'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'False'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: IsSupportFunction    = 'True'
2022-02-13 02:43:48,628 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: MirrorLock           = '0'
2022-02-13 02:43:48,645 [BackgroundWorkerPolling] INFO  - C:\Users\brett\Pictures\BackyardTEMP\BackgroundWorker\task-1447eaa0-95fc-4c4c-b385-eb4fce5aae39-callback.dat
2022-02-13 02:43:48,646 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: AeMode               = ''
2022-02-13 02:43:48,646 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Tv                   = 'Bulb'
2022-02-13 02:43:48,646 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Av                   = '--'
2022-02-13 02:43:48,657 [CameraTakePictureOnMessageRecieved] ERROR - Make sure camera is set to MANUAL, turn dial to 'M'
2022-02-13 02:43:48,657 [CameraTakePictureOnMessageRecieved] ERROR -    at BinaryRivers.Common.Model.CameraModelBase.SetDialManual()
   at BinaryRivers.Common.Model.CameraModelBase.SetDialBulb()
   at BinaryRivers.Common.Model.CameraModelBase.<>c__DisplayClass79_0.<CameraTakePictureOnMessageRecieved>b__0(Object state)
2022-02-13 02:43:48,657 [CameraTakePictureOnMessageRecieved] INFO  - Timespan 0.329
2022-02-13 02:43:48,665 [CameraTakePictureOnMessageRecieved] INFO  - Imaging session cancelled
2022-02-13 02:43:48,665 [CameraTakePictureOnMessageRecieved] INFO  - Make sure camera is set to MANUAL, turn dial to 'M'
2022-02-13 02:43:48,665 [CameraTakePictureOnMessageRecieved] ERROR - Make sure camera is set to MANUAL, turn dial to 'M'
2022-02-13 02:43:48,665 [CameraTakePictureOnMessageRecieved] ERROR -    at BinaryRivers.Common.Model.CameraModelBase.SetDialManual()
   at BinaryRivers.Common.Model.CameraModelBase.SetDialBulb()
   at BinaryRivers.Common.Model.CameraModelBase.<>c__DisplayClass79_0.<CameraTakePictureOnMessageRecieved>b__0(Object state)
2022-02-13 02:43:48,709 [PropertyGet] ERROR - LiveviewExposurePreview
2022-02-13 02:43:48,709 [PropertyGet] ERROR -    at BinaryRivers.Camera.Nikon.PropertyBaseStringEnum.DownloadPropertyFromCamera(String& value, List`1& values)
2022-02-13 02:43:48,915 [PropertyGet] INFO  - DOWNLOAD Camera Properties Completed
2022-02-13 02:43:48,930 [Main] INFO  - -----------------------------------
2022-02-13 02:43:48,930 [Main] INFO  - Application state changed: 'ImageCapture'
2022-02-13 02:43:48,946 [Main] INFO  - Imaging session cancelled
2022-02-13 02:43:48,963 [Main] INFO  - CameraPropertyChangedArgs fired: ImageQuality         = 'RAW'
2022-02-13 02:43:48,963 [Main] INFO  - CameraPropertyChangedArgs fired: MirrorLock           = '0'
2022-02-13 02:43:48,963 [PropertyGet] INFO  - CameraPropertyChangedArgs fired: AeMode               = 'MANUAL'
 

 

Link to comment
Share on other sites

  • 0
45 minutes ago, NightBikes said:

Looks like I'll be able to image again tonight.  I'll see if it happens again. Maybe my dial was somehow loose?  Thanks for looking through the log!

Remember that almost all testing of BYN can be done at the Kitchen Table / Desk with just the DSLR and Lens and PC.

This means that you don't need to use precious Dark Skies to test / debug...

Link to comment
Share on other sites

  • 0
21 hours ago, admin said:

Please try this download. I added a try loop (only for the Nikon D7200).  If it encounters this error again, it will try 3 times with a 1-second pause in between tries before throwing an error.

https://1drv.ms/u/s!AlkpoKUiQwwzmeMv46gviZ118d7-0g?e=MPhSge

Any news testing this pre-release / possible fix?

Link to comment
Share on other sites

  • 0
10 minutes ago, admin said:

Any news testing this pre-release / possible fix?

Hi, I did not have a chance to install the test software before imaging last night.  I am downloading it now and will let it run. 

I did run into issues last night. Not sure if this helps, but I wonder if it has anything to do with the delay in between captures?  I usually give it 1 second, which is where I would discover it stopped taking pictures without any errors and could just hit capture again (but as noted above there was an error thrown with the camera's mode).  I tried no delay, and when I checked on it, it was frozen and forced me to restart the program (similar to when the firewall settings were causing issues).  I switched it to 2 second delay and it ran just fine the rest of the night.

I'll get the test going now and report back soon.  

Thank you!

Link to comment
Share on other sites

  • 0

Where are you saving your images? If saving them to the PC then no delay is necessary. If saving to both the PC and the camera's SD card, try saving to the PC only with no delay. If you are saving to the camera's SD card only, then I would ask why? By doing that you do not get to review the images as they download, which is a huge advantage for preventing wasted imaging time because you took images incorrectly, like with tracking accidentally turned off or some other cause.

If you are trying to save to both locations then be aware that this has caused problems for others. The issue may be that BYN does not know when the save to the memory card has completed and may be trying to start the next exposure too soon. In that case, adding a delay may be a workaround.

Link to comment
Share on other sites

  • 0
2 minutes ago, astroman133 said:

Where are you saving your images? If saving them to the PC then no delay is necessary. If saving to both the PC and the camera's SD card, try saving to the PC only with no delay. If you are saving to the camera's SD card only, then I would ask why? By doing that you do not get to review the images as they download, which is a huge advantage for preventing wasted imaging time because you took images incorrectly, like with tracking accidentally turned off or some other cause.

If you are trying to save to both locations then be aware that this has caused problems for others. The issue may be that BYN does not know when the save to the memory card has completed and may be trying to start the next exposure too soon. In that case, adding a delay may be a workaround.

I'm only saving to the PC. Yes- love the ability to review!

I ran a test of 80 captures (no delay) and it worked just fine with the RC3 version.  Looking at the forecast, next chance for all night shooting will be Thursday or Friday.  Let me know if you want any of the log files from last night or prefer to see if this fixed it.  

Thank you.

Link to comment
Share on other sites

  • 0

Hi, unfortunately this problem is still occurring.  Happened twice last night.  Lost about an hour or so before I realize it wasn't taking pictures.  Please let me know what else to try. I can email the logs if you want the full version to review.  Thanks!

2022-02-28 21:58:50,249 [PropertyGet] ERROR - LiveviewExposurePreview
2022-02-28 21:58:50,249 [PropertyGet] ERROR -    at BinaryRivers.Camera.Nikon.PropertyBaseStringEnum.DownloadPropertyFromCamera(String& value, List`1& values)

022-02-28 21:58:50,426 [CameraTakePictureOnMessageRecieved] ERROR - Make sure camera is set to BULB, turn dial to 'B'
2022-02-28 21:58:50,426 [CameraTakePictureOnMessageRecieved] ERROR -    at BinaryRivers.Common.Model.CameraModelBase.TakePictureBulb(Single durationseconds, Single mirrorlockseconds, String progresstext)
   at BinaryRivers.Common.Model.CameraModelBase.<>c__DisplayClass79_0.<CameraTakePictureOnMessageRecieved>b__0(Object state)

 

Link to comment
Share on other sites

  • 0

The fragments are not useful. The first one is a LiveView error, so not from the Imaging tab. The second error is what you got before, where the camera's mode appeared to change from BULB to something else without being physically changed. I wonder if the camera is flaky, somehow.

Link to comment
Share on other sites

  • 0

Is there a work-around to start the imaging process over or go to the next line?  When I discover it's not taking pictures, the only thing I do is click start capture again.  Nothing else. I don't have another DSLR I can use.  

Link to comment
Share on other sites

  • 0

If you want to try to continue, then you should figure out how many images you have shot and edit the capture plan to remove that number of shots. Then restart the plan.

I would see if anyone you know has a compatible camera and try to shoot with that.

Link to comment
Share on other sites

  • 0
9 hours ago, NightBikes said:

Is there a work-around to start the imaging process over or go to the next line?  When I discover it's not taking pictures, the only thing I do is click start capture again.  Nothing else. I don't have another DSLR I can use.  

That is precisely what the fix I did in RC3 does.... it tries 3 times with a 1-second pause. Send me the new log file of the new failure, I want to see if it's the same error.

 

 
 

 

Link to comment
Share on other sites

  • 0

I've been shooting a lot in darker sky locations and had no issues with longer exposures.  Last night, back in the light polluted city, I was back under 60 second exposures and it stopped taking pictures again. Bumped it back over 60 seconds, and it ran the rest of the night.  So it appears to be an issue with shorter exposures less than 60 seconds.  Passing along in case it helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use