Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0
BrendanC

Connecting EOS1000D via hub

Question

Hi,

Everything works perfectly when I connect the camera directly to BYEOS. However, run it through a hub and it doesn't connect.

Totally understand that hubs can be unpredictable, and it's listed as a possible issue in the error message, but every other package I've got works fine, camera connects via hub no problem.

I need the camera to go through a hub because I don't have enough USB ports on my laptop.

Is there any workaround to this problem at all?

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Does windows see the camera when connecting via the hub?  Is this a powered hub? 

How long is the USB cable for the computer to the hub and how long is the cable fro the hub to the camera?

How many other devices you have connected into the hub?  What are they.

BYE does not really care if you are using a hub or not, but the Canon SDK does.

Regards,

 

Share this post


Link to post
Share on other sites
  • 0

Hi, thanks for the reply!

Windows does see the camera, and in fact my other astro software does too. It's a 10m long hub which is admittedly quite long, but it contains a signal booster (it's actually this one: https://www.amazon.co.uk/dp/B00A30FOD0/ref=pe_3187911_185740111_TE_item) which I use to control the mount and camera from indoors. The only other device connected is the mount, which is a Skywatcher AZ GOTO mount, so nothing special or esoteric.

Like I say, BYEOS is the only software that doesn't seem to see the camera through the hub. It's fine connected directly, but not via the hub.

Share this post


Link to post
Share on other sites
  • 0

What is the other software connecting?  Just want to confirm that it is using the Canon SDK.

That cable is not according to USB specs IMO.  The maximum length for a USB2 cable is 15 feet (about 4.5 meter).  The active repeater module should be in the middle of that cable (at the 5m point), not at the end.  I suspect the signal being amplified at the end of the cable is already too week.

The Canon SDK is very sensitive to data signal.  Have you tried EOS Utility (the Canon software) to see if it connects to the camera using the active cable?  BYE uses the same SDK that the Canon EOS Utility software uses so this should be an good test.

EDIT:  The cable link you provided seems to also be a powered hub, is it connected to a power source as well?

Regards

Share this post


Link to post
Share on other sites
  • 0

I've just tested with both Canon EOS Utility and (a-hem) APT, and they both detect and can fully use the camera attached via the hub.

I also put in a fully charged camera battery to make sure. BYEOS still does not detect the camera via the hub, it just gives an error message suggesting reasons it can't see it, and in the logs I can see that it's saying it can't find the camera.

The hub is not connected to a power source, it just goes between the laptop USB socket and the devices.

It seems the only workaround might be to get a dedicated USB cable for the camera (I do have one other USB socket that isn't currently being used but I was hoping to keep it free for future devices), or invest in the wifi controller for the scope so that it really is just one lead to the laptop.

Thanks for your help with this.

Share this post


Link to post
Share on other sites
  • 0

BYE uses the same mechanism as the Canon EOS Utility to communicate with the camera. That is, the Canon EOS SDK. In 99+% of the time, if the EOS Utility is able to communicate with the camera then so will BYE. There are 3 notable exceptions to this.

1) BYE checks to see if the Canon EOS Utility is running. If so, then BYE's default behavior is to fail to connect since both programs cannot be connected at the same time. The default behavior of the EOS Utility is to automatically connect with the camera when you plug the camera USB cable into the PC's USB port and power on the camera. This will prevent BYE from trying to connect. The fix is to find the menu option in the EOS Utility and change it so that it is not launched automatically when Windows sees the camera. If this doesn't work then you will need to uninstall the EOS Utility.

2) BYE offers an option to "Select your camera driver" when you click on the connect button. For the 1000D (Rebel XSi) you need to select the Canon driver option. This is for DIGIC III and later cameras. The Canon210 option is for DIGIC II cameras that are no longer supported by the current Canon SDK. If you select the Canon210 option then BYE will not connect since version 2.10 of the Canon SDK predates the release of the 1000D.

3) For cameras that support WiFi tethering, this option must be disabled in the camera since the Canon SDK does not support a WiFi connection and enabling WiFi automatically disables the USB port. This is not an option with the 1000D since it predates Canon's support for WiFi connections so it cannot be causing your issue.

I would also say that you should only connect your astronomy instruments directly to the PC or indirectly through a powered hub. A typical USB port can provide 500 milliamps to power any connected devices. With an unpowered hub that 500 milliamps is shared by all devices that are connected to the hub. Depending on the power requirements of the connected devices, 500 ma may be insufficient. With a powered hub, the hub usually provides 500 ma for each device. You should also not extend the length of your USB cabling beyond 5 meters without using an Active Extension cable. The Active Extension cable is essentially a signal booster that allows transmission over a longer distance (the length of the active extension cable). In any case you should keep your cables as short as you can.

Share this post


Link to post
Share on other sites
  • 0

Hi Guylain,

You've been very helpful, thank you. I didn't expect such a comprehensive support.

Going through your options above:

1) I uninstalled the EOS Utility completely, and got the same result.

2) I already selected the correct camera type when starting up - the camera does work, as I say, when connected directly, just not via the hub. I would normally just shrug my shoulders and assume it's the hub at fault, except that the other software works.

3) As you say, wifi is not an issue here.

I will get the log file through to you as per your link.

At the end of the day it really could just be this unique instance of the hub and BYEOS not playing nicely.

Thanks again,

Brendan

Share this post


Link to post
Share on other sites
  • 0

Got the log file.

You are NOT choosing the correct Canon drivers in BYE.  You need to choose the default one, "Canon", not "Canon210" for the 1000D.

2019-12-15 20:39:09,254 [Main] INFO  - Canon drivers 'Canon210\' initialized.

Regards,

Share this post


Link to post
Share on other sites
  • 0

OK, I'm really confused now.

i just bypassed the hub, connected the camera directly, everything is fine. Rock solid, stable, fine. How could that happen if I've selected the wrong camera?

Given that I made that choice a while back, I don't get the option now. I can't find where to choose the camera type. Please could you remind me where to find that option, so that I can change it and see what happens?

I just found that option to change the camera and will try it again.

Thanks.

Share this post


Link to post
Share on other sites
  • 0

Holy crapola. You were right. How on earth did I do that? Also, the camera does actually work with the other camera option when I connect it directly, just not via the hub. So, I could have just continued without realising.

So, now I've selected the right camera, it works with the hub. 

Sorry I've wasted your time here! But thank you so much for the support, it's really great to have such a responsive service. :)

Thanks, Brendan

Share this post


Link to post
Share on other sites
  • 0

Brendan,

Thanks for letting us know that your issue is resolved.

The Canon210 version of the SDK is for DIGIC II cameras that are not supported by the current Canon SDK. However it is possible that version 2.10 of the SDK does/did support the 1000D which was released in 2008. It may have a problem today with your camera if the camera's firmware has been updated. The 1000D is supported by the current version of the SDK this is the version that you should use since it would support later firmware versions.

I am glad that you are working.

Share this post


Link to post
Share on other sites
  • 0

Even though you've solved the initial problem, you will really want to invest in a Powered Hub (and the connections necessary to power it).  As Astroman133 stated:

18 hours ago, astroman133 said:

I would also say that you should only connect your astronomy instruments directly to the PC or indirectly through a powered hub. A typical USB port can provide 500 milliamps to power any connected devices. With an unpowered hub that 500 milliamps is shared by all devices that are connected to the hub. Depending on the power requirements of the connected devices, 500 ma may be insufficient. With a powered hub, the hub usually provides 500 ma for each device. You should also not extend the length of your USB cabling beyond 5 meters without using an Active Extension cable. The Active Extension cable is essentially a signal booster that allows transmission over a longer distance (the length of the active extension cable). In any case you should keep your cables as short as you can.

Laptops are notorious for supplying only the Minimum Power to most USB Ports, and Active USB Cables often Draw only sufficient power to feed the internal circuitry, and (barely) feed the data signal to the far end.  In AP Imaging, you will quickly add additional USB-powered equipment (Guide Camera, Focuser, Filter Wheel, etc) which will also require more than the "minimum 500mA - so adding a quality Powered Hub is important.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use