Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Connect via WiFi with 70D



I was reading a thread that stated that the Canon 6D can connect via wifi to BackyardEOS by first connecting the camera to EOS Utility, closing EOS Utility, and then connecting in BackyardEOS.

Here is the thread...

I am trying to make this work with my new 70D, but BackyardEOS can't find it using the method described above.  Help! :-)

Link to comment
Share on other sites

Recommended Posts

  • 0

After a fair bit of configuration changes, and trial and error, I was able to pair my 70D and to be able to control it wirelessly from my PC with BYE (3.1.6 Premium)...once!  I've not been able, after several days of attempts, to repeat this magical feat.  I can readily and repeatedly connect the camera via EOS Utility, but nothing more from BYE.  Now that I KNOW it's possible to control the camera wirelessly, it's frustrating not being able to take that one last step.

I'm running Windows 10 and have Avast installed.  I've tried disabling both the Avast and Windows Defender firewalls, thinking maybe there was a settings issue there, but no luck.  After pairing the camera with EOS Utility, I quit the that app and make sure there's nothing EOS related running in the background.  But for some reason BYE just doesn't see the camera on the network.  I keep getting the "Make sure EOS Utility isn't running, Make sure the camera is turned on xxx..." window after selecting the camera type (Digic 5).  However if i turn back on EOS Utility, it picks up the camera immediately.

Does anyone have any suggestions to what I might look at to get it working?  I know, I know...BYE isn't "officially" designed to run wirelessly, but i don't want that to stop me!  thanks for any help I can get.

Link to comment
Share on other sites

  • 0

Well, did you check if EOS Utility still has a process running?  Sounds like EOS Still has a connection (or handle) on the camera once you close it.


BYE uses the same SDK as EOS Utility so if it works with EOS Utility and not BYE look at task manager and confirm EOS Utility is not running anymore.


Keep us posted,

Link to comment
Share on other sites

  • 0

Just wanted to chime in on this thread, because WiFi is a feature that I am wanting to use badly. I am on the trial still and I am doing a trial of another piece of software (SGP) and WiFi is where that software fell on its face. Backyard EOS works flawlessly on my 6D with WiFi. If you are having problems connecting be 100% sure you are closing the EOS Utility that pops up when the camera connects to your network, as stated by Guylain. If you do not do that, you cannot connect to the camera over WiFi as the EOS Utility has a handle open on it.

Considering Nebulosity also has major problems with WiFi, I am guessing that BYE's usage of the Canon SDK is why it works so well with WiFi.

A few other points of interest about WiFi:

1. You do not need to install anything other than the EOS Utility, the sticky post here with a solution is wrong about the need for the CD set in full.

2. You must pair your Camera to your computer via the EOS Utility in order to use WiFi.

3. If you switch back to USB, you may need to rebuild the Camera's WiFi config in order to resume using WiFi. I have found that switching does require this. Keep this in mind if you want to use WiFi and USB in alteration.

4. You must ensure that the EOS Utility and any of its child processes have ended (or that you have forcefully done so in task manager) before you can connect the camera to BYE or other programs. For computer savvy folks this may seem silly, but for those less inclined a handle (think of that as a lock) is made on the camera in the OS that will prevent other applications (like BYE) from gaining access to it.

5.   Note the ability for BYE to switch from processing captures, to Live View, and back, and forth.... No other capture software can do this. I am quite sure that the design of BYE using the Canon SDK is why BYE is the only capture software that can do this.

Hope this helps. Clear skies all!


Link to comment
Share on other sites

  • 0

RE Guylain...A Eureka moment that I want to share.  First off, yes I was very certain that EOS wasn't running at all in the background.  But today I re-read through this thread extremely carefully...literally word-by-word to be sure I understood everyone's perspectives.  Something you wrote back on 25 September ("Just do the pairing with EOS Utility, do not connect the camera...") caught my eye and it occurred to me that each time I connected my camera through EOS Utility, I would always open the utility itself and take a couple of shots to make sure things were working correctly before attempting to connect BYE.  And, of course, it failed each time.

Well after reading your comment, I reset the wireless settings on my 70D, then re-configured and re-paired the camera as I had been doing all along.  But this time I DIDN'T open the utility to be sure I was connected.  I simply shut down EOS Utility and started BYE.  And lo-and-behold everything worked fine.

It's a small difference, but apparently an important one.  Over the next several days I'm going to keep experimenting to see how far I can push the connection, check performance over wifi comparing file transfer vs keeping the pictures on the camera, etc.  But the bottom line is that YES, as others here have validated, it does work!


EDIT: To Bill's point (varying levels of expertise who may be reading this thread), there may be some confusion between the use of the terms "Pairing" and "Connecting."  If you've used EOS Utility, you may have noticed that after clicking on "Pairing over WIFI/LAN," the window that opens has a "Connect" button, which you need to click after selecting your camera.  What I've done is to click on Connect, select "Connect to xxxx" on the camera to complete the pairing, then immediately close the EOS Utility window.  It appears that there is a fine point within this sequence when it works and when it doesn't work.  Hopefully, I can narrow this down further in the days ahead and will post an update when I have something more definitive.

Link to comment
Share on other sites

  • 0

I am currently trying to get this working with my 1dx2 and wireless adapter. The judge is still out but i thought i would chime in and say for repeatability it is better to pair the camera with your PC or access point in manual network mode. Inadvertantly disconnecting will otherwise force the camera to reset its encrpytion key and you have start from square one again. Ive learned in the field to try and keep things as simple as possible. :)

Link to comment
Share on other sites

  • 0

Just a dabber!

I have a 'cheap' but actually decent-for-its-price 100D and I need to connect wirelessly too, as I currently have a 10m [unpowered!] extension + 2m Canon cable [which I actually replaced with a better on as original was cWap]

Does anybody know if it will work with 100D?

I was thinking to get this WiFi adapter https://www.ebay.co.uk/itm/CamFi-CF02-Wireless-Wifi-DSLR-Remote-Controller-Capture-for-Nikon-Canon-SONY-a7/302558932359?hash=item4671eaed87:g:63QAAOSwOgdYyOlD
as with all my efforts I still seem to have problems with it!

A little repeating story:
It is 'not' the 10m length of cable really, I tested it several times - it does work fine and it is well shielded too and cable itself is slightly thicker and that counts too.

I do also have ONE 'very good' Powered Lindy 10m extension I use on an Astro camera [which needs it powered to get the full USB3 speed] and I have tested it with the 100D - no change.

I get this problem once in a while, it suddenly loose contact and I waste between 30m to 2h before I can make it work again - 'no', there are no false contacts - believe me.

I tested all cables in all manners and I also checked all 10m extensions PCB and they are all fine - the only thing I did was to resolder the same bit of the USB metal chassis that was only soldered in production on ONE side - just to make it solider and help 'possibly' with interferences.

The strange thing is that 'every time' I have this problem, I start the usual routine of changing cables / Canon cable and so on and I do not believe it is anything to do with the cables, with the exception of the original Canon cWap one which was causing all the problems I had a long time ago and not the 10m extension!!!!!

In my view it is a combination cables + BYEOS with the 100D - anyone had the same with the 100D and 10m extension?

I finally seem to have solve all my troubles but this one and I am a careful owner, I like to keep my gadgets/gear in good working order and I do not like to mishandle them - never pull cables, as I learned to STOP at the moment of connecting/disconnecting a cable to avoid COSTLY repairs!

Hope you can illuminate me and I will buy the Wireless adapter/adaptor and get on with my life!!


Clear skies - well they are in UK at present [very shortly !!]

Link to comment
Share on other sites

  • 0

Problems might also be the type of Chip used within the non-Lindy 10m extensions.

It seems there have been problems with EQ6 to Ascom connections due to bad quality or simply 'copied' Chip that do not Tx-Rx as it should and drop signal and this happens!

Whose Nose !

Link to comment
Share on other sites

  • 0

You added your posts to an old thread for an issue that is unrelated to your issue. That confuses the post for anyone reading it. When you have a new issue, please create a new thread.

1) The camera may be malfunctioning, but I doubt that it is "bad firmware". I have just never seen that as a cause.

2) The USB 2.0 standard specifies a max cable length of 5 meters (16 feet). Any cable length longer than that could be causing your issue. Try to re-create your issue with a single short USB cable.

3) The wireless device will only work with BYE and the Canon SDK if it operates transparently. In other words, it must appear that the camera is directly wired to a USB port. I do not believe that anyone has posted on this forum that they are using that device or a similar device.

4) Even a momentary loss of contact between the camera and the PC will cause a failure in the Canon SDK which will cause BYE to fail.

5) An underpowered PC (a netbook, for example) can contain internal USB ports that are unable to handle the load of BYE downloading a DSLR image and a guide camera downloading a guiding image at the same time. Try testing BYE by itself, directly-connected, with a short cable that is known to be good.

Link to comment
Share on other sites

  • 0

Thank you for your reply.
Sorry, I thought it was the one the same subject 'asking if wireless would work on 100D' and then 'explained my reasons to try wireless', but OK.

2. Yes, I do know that, 'but' you can add as much cable as you need [theoretically and depending on device needs] as long as signal is kept up ... [for example using active extensions] Done the short cable bit too - obviously and with different cables, better than the original.

3. No, me too - that is why I asked, just in case someone did it, but did not post it.

4. There isn't any - tried that from camera to computers [two of them win7 64bit] and one of them with USB 3 which is normally up to 900mA [if I remember well]

5. Same as above - also used on a computer with USB 3 which is higher by default anyway [original power supplies used] - although I 'suspect' the USB 2 Computer might actually have a bad internal USB 2 hub - which I did replace with a 'second-hand' hub from an almost new 'same' computer - no change.

Yes, the short cable bit has been done quite a few times and using different cables too [i.e. the original WAS faulty and cheap thin cable - but that was a long time ago!] and 99% of the time it works fine or so it seems!

This morning again I connected it using 3x different short cables - even added a short 3m USB 2 'cheap' and thin cable extension [on purpose] + tried on other computer as well on USB 3 ports - all worked fine for 2-3 hours I left it on the 10m USB 2 extension [on purpose] to try and see what would happen and while connected I did nag cables everywhere from camera to computer - perfect for 2 hours - in fact I had the 100D perfect whole nights in a raw and then it just happens - not even the  short cable works when this happens and usually by switching 100D off + disconnect power [I use a Power supply .... that is fine as I also tested it with battery = same fault] and by reconnecting power switching on, it usually connected fine, but sometimes it just does not - last night for 2 hours!
Last night I also tried the 10m USB 3 Lindy powered cable used with a CCD Altair camera I never had any problems. Just the same.

Getting back to this morning. I had lunch [camera was left off] and then re-tried it with short cable and there you go, it does not work any more - it had started again even after I used all 3x cables + switched on-off to let computer detect it [and changed ports as well] !
Then installed BYEOS on the other computer to see what happened and worked fine - back to other computer, it works fine there too [with all 3x cables]
I had to play with cables + 100D just switched on with switched on in Camcorder mode.
They did both work and like the other computer - one thing I always noticed since used BYEOS, that if I choose just ON [100D] if I get to Focus or Planet mode [LIVE] - if camera is set to Camcorder mode, I cannot choose ISO lower than 6400 1/30 - if I switch 100D just to ON position I am free to chose settings - this has always happened.

I think this problem will remain and the thing I noticed is when it works well, BYEOS actually connects very fast indeed and you can switch mode fast too, when near naughty 100D situation, connects in 4-5 seconds and takes about 30 seconds to change to focus or planet mode!

I think it probably is RxTx handshake connection problem, not the USB ports.

I found somewhere stating the 100D has its moments of disconnection.

I wonder what other 100D users had similar problems.

iI really like this camera when it works and all other cameras I used all worked fine all the time - even a non-modified Nikon with the 10x cables!

Sorry for long message - I had to explain.


PS I am a technician and fault finding is my normal job - this one has stuck me!

Link to comment
Share on other sites

  • 0

Well, it seems as though the camera is the culprit. You have done a pretty thorough job of troubleshooting and the one common point is the camera. Also, nobody else is reporting ongoing issues with similar errors.

BTW, BYE does not work with Canon video modes (what I assume you are calling camcorder mode). So leave the camera in still image/LiveView mode (the ON position).

I will also say that plugging a USB 2 cable into a USB 3 port can be problematic. I would suggest using USB 2 devices, ports, and cables only.

Link to comment
Share on other sites

  • 0


IT IS, but it is not faulty !
Well, tonight [UK] tested 100D and was working fine.

Done focusing of telescope + guider and guess? Problems started!

But, after wasting 1H 30m [again] I replaced power lead with battery [just charged this afternoon] and worked fine for 5 minutes and I noticed it was intermittently going on-off  [I had left the LCD screen on to see from a distance if it was going on for a split second.] and it was.
I went there and re-fit power lead again touched it and was going off - never happened or noticed before - then taken power lead off and placed battery in again and was doing it with battery too!
I have taken 100D off and fit an Altair camera to do 'something. then went in searching the internet about it.

One guy mentioned 'the usual' battery door micro-switch and I thought to check it out.  
Since I did not open the battery door much in a year - maybe 5-6 times - I almost only use it for astronomy and with power lead and opening the battery door I found the memory OFF its slot!

I guess it was not clicked in all the time and by closing battery door it pushed it enough to make contact, and intermittently causing all these problems - well I hope!

The memory card slot is placed in the wrong place in my view - it is on the external edge, rather than internal [near the door hinge - i.e. safer - and when you press the battery or the power adapter in, you can easily push the memory off the slot spring - in the dark - as we do!

THAT was the problem!

I will try it tomorrow night as it seems still clear for tomorrow and Monday too!

The 10m extension I use with 100D etc.are USB2 [as you say - I do agree on that] while one is USB3 powered [the Lindy one] for the Altair to get faster and better signal.

Finger and legs crossed!


Link to comment
Share on other sites

  • 0

The End !

100D started again with problems [as expected], then went dead - not coming on at all.

Had a good dismounting this morning and I could not find anything 'visible' wrong - done usual basic PSU checks - switch too - all OK - I am guessing it probably is the power-up controller chip.

Time to get a CCD and forget DSLR - I will probably sell this program too - pity!


Link to comment
Share on other sites

  • 0

Before you try to sell your BYE license, you need to read the end user license agreement. Basically, you cannot re-sell it...Sorry.

In my experience there is room in your toolbox for both a DSLR and a purpose-built astronomy camera for astroimaging. You might consider using a different Canon DSLR.

Link to comment
Share on other sites

  • 0
5 hours ago, Oright said:

1. I personally still like DSLR more and one thought is to get another DSLR - maybe used!




Because you said you your going to sell your copy of the software and this is a clear violation of the EULA.  Keys are not transferable, full stop.

The activation server will see this as someone sharing their key and it will be deactivated over time.

End User License Agreement - paragraph 2.


2. You may install and use the software on another computer, but the software should not be in use on more than one computer at a time unless you purchase additional licenses. You may make back-up copies of the software for archival purposes. You may not transfer your license to use the software to another party.


Link to comment
Share on other sites

  • 0

1. 99% of people do not read the EULA!
2. Also, I did not expect I could not transfer the software - which I like very much and there was no need to shout, but simply and politely point it out.
3. I have NOT sold it, by the way
4. I fixed 3 problems since I got this camera

Lats fix - well 2 of them seem to work - let';s see what happens, as I still prefer a DSLR especially when the weather is 'worse' a slow acquisition gets better results than a CCD camera like the Zwo/Altair/etc. - in my non-expert view.

Happy nights [one can only hope]

Link to comment
Share on other sites

  • 0

I would imaging that it is because most people don't read the EULA that the authors are trying to forcefully tell others who may read this post that selling or otherwise transferring the license is not allowed. Imagine if you did sell your license (even though that is not allowed, but you did not read the EULA) then the software quit working for the buyer. It would cause everyone a lot of grief. It is for this reason that the authors proactively work to protect their intellectual property and to make sure that everyone understands the ground rules.

You said that you fixed 3 problems since you got the 100D. Just to confirm these were camera issues, not BYE issues. Is that correct?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use