Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
c22sail

Calibration Frames Rotated 90 Degrees from Light Frames

Question

When I photograph an object in the sky my camera is orientated on the telescope such that it is viewing the object in landscape mode. As BYN goes through the set the light frames all show up in the thumbnails and on the screen in landscape mode.

Following the light frames I immediately and without changing anything record flats, bias, and dark frames. They also appear in the thumbnails and preview screen in landscape mode.

When I close BYN and go to the directory to load the images to PixInSight the lights are still in landscape mode but every calibration frame (flats, bias, darks) is in portrait mode. They have all been rotated 90 degrees clockwise. I figured out the rotation was clockwise by looking at the dust  bunnies on the flat frames.

This occurs in every set I have taken and I haven't been able to work out the answer. It is easy enough to rotate the master calibration frames counter clockwise before stacking them with the light frames but there should be a reason this is happening. Any ideas?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I believe I have finally came across the solution. In this instance it is two fold. In my D810 I had "Rotate Tall" turned off. It turns out this is only for display. Another setting "Auto Rotation" was turned on and as the telescope tracked throughout the night the camera was interpreting even a slight shift as a rotation. The second problem was occurring in PixInSight, as suggested by Ron. When trying to stack images PixInSight was rotating again some photos and not others. Again, the solution to this problem came from Ron in the form of telling PixInSight to ignore rotation information in the RAW file. Thanks all for your help.

Share this post


Link to post
Share on other sites
  • 0

What camera? Is there a camera setting that rotates an image according to the orientation of the camera? I do not believe that BYN does anything with image rotation, especially not for darks and flats, but not lights. It takes the image as it comes from the camera.

Share this post


Link to post
Share on other sites
  • 0
Just now, astroman133 said:

What camera? Is there a camera setting that rotates an image according to the orientation of the camera? I do not believe that BYN does anything with image rotation, especially not for darks and flats, but not lights. It takes the image as it comes from the camera.

D810. Yes, there is a rotate tall setting in the camera but it is turned off. Between the light frames and the calibration frames I didn't change anything. The camera and telescope were in the same orientation. It is odd, isn't it? I didn't see anything in BYN either. If I ever come up with a solution I will repost it here. It is minor, as I can simply rotate the calibration masters back in PixinSight. 

Share this post


Link to post
Share on other sites
  • 0

Seems odd if everything was in the same orientation.  However, it's a display thing only, the sensor is the sensor and I'm pretty sure it did not physically rotate inside the camera :)

Use them blindly.

Regards,

Share this post


Link to post
Share on other sites
  • 0

I had this problem with my Canon 60Da and other Canons in PixInsight.  The problem was a setting in PixInsite and is related to the Raw conversionsoftware used.  I don't remember the subject where the solution was given.  I will try to find either how to change the option of the post.

 

Ron

Share this post


Link to post
Share on other sites
  • 0

OK I found the post but forgot the title that helped me.  It is in the BYE Forum tthe title reads something like "Why are the images horizontal at times and vertical at times".  First, I only have Canon equipment and don't know anything about Nikon or BYN.

 

  This is for reading RAW files

  But go into PixInsight

Bring up the "Format Explorer"  (You may have to click on "View" on the top command line.)

Click on "DSLR RAW"

Click on "Edit Preferences" in the DSLR RAW box at the bottom

Put a check mark in the box in the box next to "No Image Flip"

  Click "OK"

  If you are using .jpeg I can't help.  No command to not flip .jpeg images.

 

  I use Canon CR2 files but there are several formats available including NEF.  PixInsigt uses DC-RAW to convert the images.

 

Ron

 

Share this post


Link to post
Share on other sites
  • 0
On 12/15/2017 at 5:56 PM, Ron Hillstromb said:

OK I found the post but forgot the title that helped me.  It is in the BYE Forum tthe title reads something like "Why are the images horizontal at times and vertical at times".  First, I only have Canon equipment and don't know anything about Nikon or BYN.

 

  This is for reading RAW files

  But go into PixInsight

Bring up the "Format Explorer"  (You may have to click on "View" on the top command line.)

Click on "DSLR RAW"

Click on "Edit Preferences" in the DSLR RAW box at the bottom

Put a check mark in the box in the box next to "No Image Flip"

  Click "OK"

  If you are using .jpeg I can't help.  No command to not flip .jpeg images.

 

  I use Canon CR2 files but there are several formats available including NEF.  PixInsigt uses DC-RAW to convert the images.

 

Ron

 

This has been plaguing me for a while but I've managed to work around it until now.  You just saved me hours of stumbling around.  I didn't even know these PixInsight settings existed.  Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use