Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

No AVI files



I am testing the BackyardEOS 3.1.6 TriaL Edition with a Canon Rebel T3i camera (2015). Everything seems to be working except that I cannot find any AVI files when making a movie (100 frames) in planet mode. Only 100 jpg files. I use the AVI + JPG setting. I also downloaded the MOV to AVI software. No error messages.


Link to comment
Share on other sites

  • Answers 53
  • Created
  • Last Reply

Recommended Posts

This is now solved.


I did a remote session with Scott and the issue was McAfee... piece of !@#<$%.


Once we got rid of McAfee and activated Windows Defender on his brand new W10 PC everything worked as-is without any other intervention.



Link to comment
Share on other sites



 I have also seen this issue with several more symptoms. 


 First I have a Lenova laptop that has been running BYE for over a year with no issues. It is becoming some what erratic so I bought an Lenova desktop, also running Win 10 and cannot get BYE to run properly.

     Main symptom for me is when I do a capture , the camera is controlled properly but after the downloading and processing time, usually about 9 seconds I hear the sound but no image shows up in the main display area and no histogram shows up in the chart. Also no image has shown  up in the download file.

    I can do a preview and do get a normal image and histogram every time , but not if I select start capture. I have waited 20 minutes with no sign.

    As above , I can record videos as jpg but do not see a avi file anywhere. I have JPG and AVI selected.


    This is release 3.1.5 but I initially downloaded 3.1.6 but had these issues so tried deleting 3.1.6 and down loading 3.1.5 expecting it to work. but the symptoms were exactly what I saw with 3.1.6.

    If I now connect the camera to the laptop running 3.1.5 the camera works great.


    I don't know much about computers but have seen new computers fail to run proven software before because the new computer  did not have a file etc that the older one had because it was supplied by another program downloaded and run in the past.


 Hope this sheds more light on the issue.


 Scott Jamieson


Link to comment
Share on other sites



Your issue may not be related to the issue of the original post, because some of your symptoms are different.  This should probably be a new thread.


What camera??? What SDK (Canon, Canon215 or Canon210) did you choose at connect time? Was Windows 10 pre-installed on the PC or was it upgraded from an earlier version?


When you deleted 3.1.6 and installed 3.1.5, did you use the Control Panel to delete it?  Were all your installs to the default (or the same) folder?


It could be due to a problem with the low-level camera driver or the version of the SDK that you chose.

Link to comment
Share on other sites

Hello Rick,


   I am using a Canon 60D and chosen the top selection( Digic 5 and 6) to start.


The computer came with Win 10 already installed. The laptop was upgraded from an earlier version before 8.



I selcted EOS and selected uninstall and it seemed to  work but then came up with a message could not delete 3 files that it needed to update. I powewred the machine down and reloaded 3.1.5 BYE again with no errors but had the same symptoms with BYE.


That may be significant but it had already failed with the same symptoms as 3.1.6.


Another data point. I just tried downloading 3.1.5 to my other telescope computer as a test. It is about 2 years old and was recently updated to Win 10.


This computer is another Lenova machine and BYE works completely.


Sure seems like there is something not on the new Win 10 machine that the older machines already have.



Link to comment
Share on other sites

BTW, I chose this thread because my first symptom was when trying to do a video of Jupiter, I got the JPG files but never got the AVI, even after waiting 20 minutes for a 500 frame movie. 100 frames was no better.

I love the program but my other machines are running SBIG cameras so I need the new machine to work with BYE if possible.


Link to comment
Share on other sites

With a 60D, I would suggest using the Canon215 version of the SDK.  The version that you were choosing is newer, but has shown to have some problems that did not exist with the previous version.


There have been problems in the past with some of BYE's configuration files becoming corrupted.  These files are not removed when BYE is uninstalled AND re-installing or upgrading to the same folder does not repair the files.  The solution for this issue has been to install BYE to a different folder.  You might try installing 3.1.6 to a different folder to see if this fixes your issues.


Oh, and by the way, you should wait for 15 minutes after exiting from BYE before trying to upgrade.  This gives the Background Worker process a chance to shut down.


You are an experienced user, but your issue with the image not displaying is normal if you choose to save the image only on the camera's memory card.  Does it matter if you choose JPG, instead of RAW?

Link to comment
Share on other sites

Have used both digic 5 versions of the sdk with no difference.


Am not saving to the camera card. Just the computer.


All the settings for both computers are the same. The older machine works and the new one doesn't.

Am using RAW + JPG . Chosing just JPG makes no difference . There is still no image displayed and no histogram with it.




Link to comment
Share on other sites

Am curious if the originator of this thread BBennekers has ever tried his with Start Capture. If he is not interested in stills perhaps he hasn't tried that. Would be interested to know if it works (displays image and histogram) on capture.



Link to comment
Share on other sites



It is a good thought about the OP seeing if he has a similar issue with still images.  Your problems may be related after all.


You say that the Preview button works and displays the image, but that shooting JPG-only via the Capture Plan does not.  That is very strange.  I don't recall anyone ever reporting similar symptoms.


Do you see the downloaded image files in the BackyardTEMP\Download folder? These files would have the generic IMG_nnnn.CR2 file name.


It may take a dissection of the log files to see what is going on. If you decide to submit the log files you should follow the instructions here --> https://www.otelesco...ssue/#entry6045

Link to comment
Share on other sites


      I am happy to report that my problems are all solved.

    To reiterate , With a brand new Win 10 computer, I could not get images when using capture. Nothing showed up on the main display window or the histogram window.

        I could see images when I just used preview

        When I tried movie mode I could get the jpg frames but not the actual avi.


     When I decided to upload the log files I found many log files and decided to delete them and start over so I would send the latest files. I discovered that 2/3 of them would delete but about 12 would not with a note appearing that could not delete because they were actually being used. This was after a 20 minute shutdown and restart of the program. I decided to force the issue by re starting the computer. In the process of shutting down I got an update to windows that took over and had to wait until it re booted to start up the computer. I went directly to the log files and found I could delete them with no problem. 

     I then started BYE and now Everything is running normally!!!  Both Capture and the Movies.

     I don't know if deleting the files fixed it or the Win 10 update installed something that fixed it but I have shut down and restarted several times and all is well.

    I had looked at the files and found lots of mention of background processes starting and stopping before this happened. But that is gone now.

So thanks for all the clues in getting this wonderful program running.!! Wish I knew how.



Scott Jamieson

Link to comment
Share on other sites

Drat!!  Spoke too soon. The same set of symptoms is back.


I restarted the program and both the image capture and movie avi problem are back. They are definitely related and It sure seems that my computer is having problems with the background processing.


   If all I do is start BYE on the good computer I see the main program and one instance of the O'Telescope.BackgroundWorker start in the TaSK mAster window.


    On the bad machine I see the main program and two instances of the Background program. 


    This is just starting the program, not connecting the camera..


If I then stop the program on the good computer the Task Manager shows the program stopping immediately and the Background process disappears about 30 seconds later.


   If I do the same thing to the bad machine the program line disappears immediately but the two Background processes never disappear from the task manager. If I then start up the program. two more instances of the Background process appear so there are four open now. If I stop and restart BYE , two more instances show up in Task Manager for a total of 6 of the same program trying to run at the same time.

   Whatever the cause this must be related to my problem as the good machine never opens more than one instance of the Background process. 


   Clearly there is a major problem with this machine trying to run this background process and I guess I have to give up until I can afford to get another machine.


Sorry ,



Link to comment
Share on other sites

No. It is not an old machine with one processor.


    My whole problem is that my two old Lenova computers running Win10 work great but this new Quad processor 1.6 Ghz Lenova machine with 4 g of ram will not work capture properly and it appears to me that is not running the background processes properly. This machine came with Win 10 installed . The other 2 computers were Win 7 until converted to Win 10 successfully.

    I chose this thread because he had the same other symptom that I have, that the avi files were not being generated after the movie frames were recorded as jpg frames.   When I had it working for a short time both the capture and avi generation worked but now neither of them work. These symptoms are related , apparently through the failure of the background process.

      I have cleared out the temp file and started from power up to generate the log file . The sequence was ;


open BYE

connect to Cannon 60 D

try a capture of 1 second. No image appears even though the sequence appears to be right. ( camera opens etc)


try another capture 1 second. This one also fails to get an image to the screen or to file.

try a one second preview. This works fine with both an image on the screen and a histogram.

try another one second preview. This one also works.

try a third capture. Again no new image.

try a forth capture. Same result.


   I will send the three log files shortly. I will also send an image of the sequence log from the program display. This shows no image transferred when capture is used, and a image file when the preview is used. On a good machine , each capture generated an image file.


   If it appears this cant be resolved please let me know.


Link to comment
Share on other sites



I believe that your symptoms are unique, and I have exhausted almost all of the suggestions that I usually make.


The only thing that I can think of is to send the log files from the date of your testing above to Guylain by following the instructions in this thread ==> https://www.otelescope.com/index.php?/topic/893-how-to-submit-log-files-for-troubleshooting-an-issue/#entry10186


One other step that Guylain may propose is for you to allow him to remote into your system to see, first hand, what is going on.  That is usually not necessary since the logs are very extensive.

Link to comment
Share on other sites

If your Issues are only on the PC which you Upgraded from Win7 to Win10, then you may actually be tangled up in a Problem with the User under which the Foreground and Background Apps are running.

You may have to Run As Administrator.


To test this out:

Disconnect the DSLR

Reboot the PC

Open the Start Menu

Right-Click on the BYE Start Icon

Select "Run As Administrator"

Connect the DSLR

In BYE attempt to Connect the Camera - selecting the proper SDK version

Test your Capture Plan and Planetary Imaging functions

See if the Background Worker is able to Process the Images and Videos


If this Works, then you'll want to Permanently Set the "Run As Administrator" setting for that BYE Start Icon (and other BYE Icons on the Desktop or within Start Menus) by Right-Clicking on each Icon and selecting Properties and then setting the "Run As Administrator" permanent setting.

Link to comment
Share on other sites

Okay, lets start from scratch!


You have been sending me print screens and irrelevant log files sadly.  All log files I have received so far DO NOT contain planetary recordings so I can not verify anything :(


Please delete your log folder to make sure you do not have old logfiles without planetary recording.


Then perform a planetary recording and send me those log files only.



Link to comment
Share on other sites



Scott (telescott) is not the original poster of this thread. One of his symptoms seems similar (no AVI file from Planetary Capture), but he has a more serious symptom.


Preview images display on the screen and save to his download folder but images captured via a capture plan are not downloaded or displayed.  It may be worth re-reading his posts to get the evolution and to see what he has tried.


I agree that he should delete any existing log files and then use BYE to re-create his issue by executing a capture plan for some still images and then follow the How-To Instructions to send you the detailed log files for that session.


In hindsight Scott should have created a new thread, but his evaluation at the time was that he was seeing the same symptom (no AVI) as the OP.  This may or may not be the case since the OP has no problem with still images being downloaded or displayed.  Scott may have 2 independent issues.


I hope this helps.

Link to comment
Share on other sites

Thank you Rick,


   I have sent the proper log files for the capture failures and point out again that the problem I am having is with a brand new Win 10 quad processor 1.6 ghz Lenova computer. I only pointed out that I currently can run BYE on my older computers that were converted to Win 10 from Win 7. I am an experienced user.


    The log files I sent were for the following very simple sequence.


Start BYE 

connect with the 60D

take a one second normal exposure - no image

take another one second exposure - no image

take a preview exposure-  displayed and saved image

take a preview exposure again - displayed and saved image

take a one second normal exposure - no image

take another one second exposure - no image 

disconnect 60 D.


    I avoided the avi process issue  because the problem is obvious with this simple sequence, I dont want to complicate the evaluation  and I have reason to believe the two issues are related but thats' for greater minds than mine.


I have also pointed out that the program is trying to start the background process twice before any image is taken. Apparently this is not working correctly because the old computers never open more than one background process with this sequence.


   I would like to get my files evaluated in the context of the simple sequence I used because the problem is there.


Thanks again,


 Scott Jamieson

Link to comment
Share on other sites

Best to keep in mind that I am a retired microwave engineer, not a computer type. I can run most programs well but networking issues are beyond me.



I just sent the files.




Well, as long as you do not put your computer in the microwave you should be fine :)



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use