Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Having trouble connecting Canon 90D to BYEOS


Apollo52
 Share

Question

I have been working on this for a day and still no luck.

I called Canon support as Canon utility isn't working either at least as far as I can tell.

I have two icons on my desktop for BYEOS one message says cannot recognize the camera the other gets me closer as far as trying to connect. Then I get the message saying EOS utility is running and to turn it off and restart BYEOS.

We have deleted all of the canon utility for everything canon I have and when I try to connect the camera  to BYEOS I still get the message that utility is running, How could it be running its not even installed.

I deleted ASCOM thinking this might have something to do with it no luck there.

Help...lol well if anyone has any advise I am all ears.

Thank you 

 

 

Link to comment
Share on other sites

28 answers to this question

Recommended Posts

  • 0

What are the 2 icons that you mentioned? If they are for Camera1 and Camera2, they are provided to allow you to control 2 cameras at the same time. They are the same code, so should both give the same result.

It is not really a problem if the EOS Utility is running, just that it cannot be connected to the camera.

If you have removed the EOS Utility, then just reboot. You can also bypass the EOS Utility check by BYE in the Advanced Settings screen.

ASCOM has never interfered with BYE ever. Deleting it was not necessary, as you discovered.

Link to comment
Share on other sites

  • 0
8 hours ago, admin said:

Nothing will work until you get at least the Canon software to see the camera.  Looks to me like Windows is not even seeing the camera as an imaging device.

We did see the camera in the device manager as well as pics on the card in the camera.

Link to comment
Share on other sites

  • 0
24 minutes ago, admin said:

That is your issue, if you can see pictures on the card the camera is seen in Windows as a storage device.  It must be seen as an imaging device.

I did just check again and in the device manager it says portable device.

Could you suggest the best way for me to proceed??

Thank you 

Link to comment
Share on other sites

  • 0
9 minutes ago, admin said:

camera factory reset?

Ok ill try that I have only had the camera for a few months and have only used it a handful of times.

I guess the fact that it is Digic 8 does not mater for BYEOS as I am sure there are plenty of people using other canon products with Digic 8 on BYEOS.

Thank you!

 

Link to comment
Share on other sites

  • 0

When EOS Utility is Loaded, does it successfully connect to your Camera??  And allow you to do a simple action like taking a Picture??

 

EOS Utility uses the sane Drivers and SDK as BYE, so 1) it helps determine if Windows is REALLY seeing the Camera; and 2) really doesn't work when BYE is loaded (and vice versa).

So, to test, completely shutdown BYE (reboot if you want to).  Then Start-up EOS Utility and test with that Program.  When done, terminate EOS Utility (including remembering to Uncheck "Load at Startup" or "Run in Background" - whatever the current version says).  Then do a reboot.

Let us know the results...

Link to comment
Share on other sites

  • 0

Thank you for the help!

I have tried everything you said multiple times and  I keep getting a pop up that says camera not recognized.

This is even after windows says found new device loaded and ready to use.

I have tried 4 different cables and no  difference.

When eos utility did launch it didn't recognize the camera and the only thing highlighted was the bottom was the file manager portion of eos utility.

Thank you very much for helping me I also did a re set of the camera as  mentioned above.

 

Link to comment
Share on other sites

  • 0

Is there anything special about the PC that you are using??  Laptop??  Tablet PC??  USB3.2 or 3.1 Ports only...

Every indication is that the PC is NOT seeing the Camera as an Imaging Device, but rather as a Storage Device.

I downloaded the Canon 90D User Manual while letting my Coffee soak-in this AM.  Wow, over 600 pages!!

(Actually there are 2x versions - 1 for Original Firmware and 1 for Firmware 1.10 and above)

In the entire 600 pages of either version, it only mentions USB 3-times but the Index dedicates a whole page-length column to WiFi connections.

Suggestions:

1) After the Factory Reset, go to the WiFi/Bluetooth Menu and set both WiFi and Bluetooth to "DISABLE".

2) Have an SD Card in the Camera with at least one Image recorded by the Camera (shouldn't matter, but Manual insisted on this for a few of the PC Utilities)

3) Determine which version of Firmware your 90D is running 

Link to comment
Share on other sites

  • 0
15 hours ago, s3igell said:

Is there anything special about the PC that you are using??  Laptop??  Tablet PC??  USB3.2 or 3.1 Ports only...

Every indication is that the PC is NOT seeing the Camera as an Imaging Device, but rather as a Storage Device.

I downloaded the Canon 90D User Manual while letting my Coffee soak-in this AM.  Wow, over 600 pages!!

(Actually there are 2x versions - 1 for Original Firmware and 1 for Firmware 1.10 and above)

In the entire 600 pages of either version, it only mentions USB 3-times but the Index dedicates a whole page-length column to WiFi connections.

Suggestions:

1) After the Factory Reset, go to the WiFi/Bluetooth Menu and set both WiFi and Bluetooth to "DISABLE".

2) Have an SD Card in the Camera with at least one Image recorded by the Camera (shouldn't matter, but Manual insisted on this for a few of the PC Utilities)

3) Determine which version of Firmware your 90D is running 

Well I am running version 1.1.1 as says in camera firmware description

Have SD card with photos I took of ISS last night.

Did the factory reset>

Disabled the wfi for both Wifi and Bluetooth.

Still cannot connect to BYE or no change to the canon utility software.

 

Kind of sad I used to be a good computer guy but im struggling hard on this one.

I moved recently and I cant find my T5I otherwise id try that.

I appreciated the help and advise.

thank you

 

 

Link to comment
Share on other sites

  • 0

That's a decent Laptop.  Modern, well provisioned...

A quick Google shows the new ones are coming with ONLY USB 3.2 Ports.

What type of USB Ports does your Model have??  Can you find a "standard" USB 3.0 Port on your Machine??  Or any "legacy USB 2 port"??  Try that...

Also, you say that Windows offers to download Images when you connect it to the PC.  Can you be very attentive and record exactly what the Dialog says, and what action you take??  Let us know.

Link to comment
Share on other sites

  • 0
12 minutes ago, s3igell said:

That's a decent Laptop.  Modern, well provisioned...

A quick Google shows the new ones are coming with ONLY USB 3.2 Ports.

What type of USB Ports does your Model have??  Can you find a "standard" USB 3.0 Port on your Machine??  Or any "legacy USB 2 port"??  Try that...

Also, you say that Windows offers to download Images when you connect it to the PC.  Can you be very attentive and record exactly what the Dialog says, and what action you take??  Let us know.

4 SuperSpeed USB 3.0, 1 supporting USB Boost

above is from hp website

When plugged in windows says( canon 90D you have new choices for this device)

Than you pop up opens with Canon 90D eos

Then from there I am able to open folders with pictures so I am connected to camera thru the cable I would assume?

Link to comment
Share on other sites

  • 0
2 minutes ago, s3igell said:

Not understanding...  "Canon 90D eos" what??  Is Windows File Explorer opening??  Or is some Image Display App opening?? or...

It is the file extension 

the pop up when I plug the camera in opens in the lower right

Link to comment
Share on other sites

  • 0
On ‎7‎/‎17‎/‎2020 at 5:26 AM, astroman133 said:

Can you provide a screenshot of the popup that you are seeing?

Thank you for all the help!

I was finally able to get back to this project of fixing the camera settings and trying to get BYE functioning 

So I broke out the RCA laptop/workpad 99$ Walmart special downloaded canon utility and wala I can control the camera through canon utility.

I would assume from what everyone has told me I would be able to control BYE from this same machine.

I am not sure how to fix the HP laptop possibly a garbage bin might be a good start or a trip to best buy to purchase a new astronomy/astrophotography computer.

This unit I am using with good results is only purposed for RC helicopter Stuff.

If anyone has any ideas about a possible fix for the HP laptop i'm open to suggestions.

Thank you for all the help.

 

 

 

Link to comment
Share on other sites

  • 0

I have had success connecting the camera to EOS utility and taking photos. It is  connected thru the EOS Utility version 3 and all camera functions are working remotely.

When I open BYE now it is not recognizing the camera.

Or one scenario is it asks me to close Utility and retry to run BYE

I go to task manger and make sure all EOS Utility's are not running, I got to BYE try to connect then I get a message that  it does not recognize the camera.

Thanks for all the advice!

Link to comment
Share on other sites

  • 0

I wish it were so but it is what is happening, I was so sure once I got EOS Utility connectivity BYE would function but it is not happening at the moment.

I have version 3.1.17 version of BYE

I have tried both connection tabs on BYE but primarily I am using the top Digic 3-7.

12:51:27  Attempting to connect camera...
12:51:27  Canon drivers 'Canon\' initialized.
12:51:28  DEVICEINFO DESCRIPTION IS Canon EOS 90D
12:51:28  DEVICEINFO NUMBER IS 3470492101.
12:51:28  YOUR *REAL* MODEL NUMBER IS 4294967294(FFFFFFFE)
12:51:28  YOUR camera is not currently supported by the Canon SDK available at the time of this software release.
12:51:28  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

 

Before I got this I went to task manager and made sure no EOS Utility's were running.  It is connected and turned on and right after I received this message I went  to EOS Utility  and it opened

 

It is an odd issue but I am confident the issue will be resolved and its probably one click away 🙂 

Link to comment
Share on other sites

  • 0

Thanks for message entries... I can confirm that it will not work.  the number 4294967294(FFFFFFFE) confirms that it is not supported with the SDK version in 3.1.17.

BYE 3.1.17 was released in February 2019.  You camera was not even released when 3.1.17 was released.  The 90D was released in September 2019.

In the future please always try the latest release, which is currently 3.1.18.

Please try 3.1.18 (or 3.2.0.RC in the pre-release section).

Regards,

 

 

Link to comment
Share on other sites

  • 0

I am glad that your issue is resolved. It is too bad that you did not follow the instructions at the top of this page to  "Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*"

If you had reported your error in your original post your issue would likely have been solved that day.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use