Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
djgage@comcast.net

Can't connect Canon T7I

Question

I have read through the forums and tried the fixes offered and I still can't connect to my T7i. I tried with 3 different versions of BYE, 3.1.17, 3.1.18, and 3.2.0. I disabled wi-fi. I tried all my cords. One cord I tried is currently in use with a Huion tablet and it's working with the tablet but not with the camera. I just downloaded the trial version and would like to demo the software. I had the USB plugged into my docking station and tried it in several ports on my lap top also. My lap-top recognizes my camera when I plug in the USB, it shows Canon Digital Camera in the devices and Printers tab until the camera automatically shuts off. Any help would be appreciated.

 

Thanks!

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I was cleaning off an older Windows 10 Home lap top to use as a remote AP setup. When I plugged in the T7i it immediately recognized it and I am able to use it in BYE now as well as access the SD card inside the camera. The cords were not the issue but I don't know what the actual issue was. The lap top I was trying it on before is a newer Windows 10 Pro laptop I had built for 3D CAD. Would it be some setting I have to change in order to use the T7i on the newer lap top? Anyway, I'm good for now. I plan on setting the older lap top outside and accessing it using Any Desk or Team viewer. Thanks for all the suggestions. Hopefully this will help someone in the future.

Share this post


Link to post
Share on other sites
  • 0

After I posted this I found a post from September 27, 2015 by BlueFang that outlined how to connect to BYE by WiFi. I followed the post and it worked for me. I'm pasting it here, maybe it will help someone else like it did for me.

Thanks!

 

Ok... so this is what I have figured out so far... BYEOS works over wifi as long as you do the following:

1) Download and install the Canon Digital Solution Disk software (i.e., the software that came with your camera)

2) Update to the latest version of EOS Utility (not sure if this is necessary, but it is what I did)

3) Pair your Camera with the EOS Utility (I think this only has to be done once as long as your network doesn't change)

4) This pairing procedure by default automatically opens EOS Utility. You can quit this.

5) Open up BackYard EOS and hit connect. The connection should succeed.

I also performed a reboot after step 5 and also shutdown my camera. After rebooting, when I turned on my camera (with wifi enabled), it automatically brought up the Canon EOS Utility selection screen menu (but I didn't choose the option for remote control). I simply just quit.

I then started up BYEOS and hit connect and it worked perfectly.

So, my takeaway is that Backyard EOS does indeed work with WIFI cameras, but only after you have performed a "pairing" of the camera with your computer using the Canon EOS Utility. You only have to do this once - or whenever your network or router changes. After that, BYEOS seems to be able to connect just fine with the camera.

Below are screenshots of "Frame and Focus" mode as well as a captured image - both of which were completed without any USB cable attached! (sorry for lack of planetary objects)

 

 

 

When I first tried BYEOS, I had not installed the Canon software on Windows, and was using BYEOS through a VM, and I had obviously not paired my camera with Windows

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, djgage@comcast.net said:

until the camera automatically shuts off

This is a Camera Setting on your T7i (check the manual for Auto-Power Off).  It's likely that the WiFi connection defaults to a longer delay than stand-alone...

It's good that you figured out WiFi, as we normally can't/don't provide much guidance for that, as WiFi connectivity has it's own set of Issues for AP Imaging (Lower Throughput, More Likely to Disconnect, etc).

As for USB Cords, your T7i should have come with a 3ft USB2 A-MiniB cable.  You can find these on Amazon or most Electronics Shelves...  As you are attempting to connect through a Docking Station, you may need to first try it directly to the PC USB Port (even though Windows sees the Camera as a Device - you may have some other issues with the ports on the Dock).

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, djgage@comcast.net said:

I was cleaning off an older Windows 10 Home lap top to use as a remote AP setup. When I plugged in the T7i it immediately recognized it and I am able to use it in BYE now as well as access the SD card inside the camera. The cords were not the issue but I don't know what the actual issue was. The lap top I was trying it on before is a newer Windows 10 Pro laptop I had built for 3D CAD. Would it be some setting I have to change in order to use the T7i on the newer lap top? Anyway, I'm good for now. I plan on setting the older lap top outside and accessing it using Any Desk or Team viewer. Thanks for all the suggestions. Hopefully this will help someone in the future.

glad you got it to work.

Share this post


Link to post
Share on other sites
  • 0

You should not have to install the any software from the Canon Solutions disk to get BYE to connect with your camera. The only software outside of a good BYE install is the low-level Canon driver which is part of Windows. If the camera and cable are working properly then the issue could be a bad USB port or some other software that automatically connects with the camera when Windows detects that the camera is plugged in and powered on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use