Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Camera not found message


The Possum

Question

I have a problem in that i am now getting camera not found message every time i try to connect my 5D MKii.

My computer is seeing the camera as normal. I have purchased a new usb cable but this did not solve the connection problem.

I would be most grateful for any help to resolve this annoying problem.

Many Thanks, John

Link to comment
Share on other sites

  • Answers 29
  • Created
  • Last Reply

29 answers to this question

Recommended Posts

Just in case it might be of help to others i have resolved this issue by going to the Device Manager  and uninstalled the drivers for the 5DMKii and then did a scan for hardware changes. Hey Presto everything works again.

Thanks to all for your suggestions.

 

John

Link to comment
Share on other sites

Many thanks Rick.

 

To the best of my knowledge the 5D MKii goes not have any wi fi function.

Historically i had no problems but recently i now recall that in Planitory Mode it did not generate the AVI file and only the Jpegs were downloaded.

Now over the past few nights it will not connect to the camera.Not sure what to try next

 

Regards, John

Link to comment
Share on other sites

There is an accessory that can be used to enable wireless communication with your camera.  Newer cameras have that built in and it must be disabled for wired use as required by BYE and the Canon SDK.

 

Failure to combine JPG files into an AVI could be due to a couple of things.

 

1) settings in the Planetary Capture Plan could be to skip the creation of the AVI.

2) a bug in BYE, or an installation-related issue...What version of BYE are you using?

3) creation of the AVI file takes some time, perhaps a couple of minutes.  If you are patient they may eventually show up.

 

To my knowledge, none of these can cause subsequent connection failures.

 

Things that can cause connection failures, assuming that the camera is in manual mode, is physically connected to the PC and is powered on are:

 

1)  Windows does not recognize the camera and load the low-level driver. Bad cable or connections.  No Windows driver (sometimes happens after an upgrade to Win 10).

2) EOS Utility is running (perhaps in the background). Stop the EOS Utility and use its menus to prevent it from being started every time you connect the camera

3) insufficient disk space (I believe that the threshold is 10 GB). Disable this check in BYE Settings or free up some space

4) Wrong SDK selected.  You should select Canon or Canon215 at connection time for the 5D Mk ii.

 

I hope these suggestions help.  If not, you may need to send some recent log files to Guylain. Read the instructions here. You may also get additional suggestions by browsing back through archived posts in the BackyardEOS Forum.

 

I would also suggest that in the future if your issue is specific to BYE that you post your issue to the BackyardEOS forum, rather than the General forum. This helps to keep Canon-related issues separate from Nikon-related issues or other issues, like Licensing which could affect both applications.

 

Thanks,

Link to comment
Share on other sites

As I indicated in my first reply, did you try EOS Utility?

 

This is your first test to run.  If it does not with EOS Utility either your issues are unrelated to BYE.  If it does connect to EOS Utility but not BYE then the issue is related to BYE.  

 

EDIT:  Forget my comment, I see you have tried it.

 

Does the 5D Mk II has a communication menu?  If yes make sure it is not set to PTP.

Link to comment
Share on other sites

Hi, All

 

I am running BYE 3.1.6 Premium on a Windows XP Laptop and have been using this same gear in my observatory for the past couple of years. My 5DMKii is my imaging camera on my Telescope and controlled by BYE.

I have just borrowed a EOS 7D from a friend and attached it to my set up as a test to find that it works fine, which would suggest that other softwares in the system are ok.

Sadly when i replace my 5D i get the camera not found message again.

The 5D MKii does not have a communication menu that i can find.

There is loads of free HDD space as i only use this computer to capture images and run the telescope, all files are then removed to another machine for processing.

Cheers and Thanks

Link to comment
Share on other sites

It sounds like you are missing the low-level Windows driver for your 5D Mk II on your Windows XP system. Missing this driver would prevent both the EOS Utility and BYE from connecting when other cameras would connect.

 

At this point I would suggest that you install that driver from the CD that came with the camera or to go the Canon Support web site and download the latest version of the software (EOS Digital Solution Disk Software 29.0A for Windows).

Link to comment
Share on other sites

Hello All

 

I have today tried my 5DMKii connected to 2 No. other computers and it works fine on both. That seems to point in the direction that in some way the laptop has lost its communication with the camera or some sort of driver error.

How to resolve this issue is now the problem'

 

Regards

John

Link to comment
Share on other sites

As long as BYE/BYN does not target .NET 4.5 or later, you should be fine running on XP.  Of course it may be difficult to forego enhancements like LINQ and asynchronous programming that are only available in .NET 4.5 and later.

 

If you plan to do that I would suggest getting feedback from the user base.  Some folks spend thousands on astronomy equipment and then expect to be able to control it all with an Centrino-based Netbook running a 10 year old version of Windows. Setting their expectations will help to reinforce that XP is dead and that they should plan to upgrade if they want to use your software.

Link to comment
Share on other sites

YES, unfortunately lots of Astro Photographers are planning to remain on WinXP until they Die...

 

Some have cause - they may be using an old Parallel-Port Camera for their AutoGuider or some Old Mount that never saw 32-bit Drivers or they may be nursing an old Pentium-based Observatory Automation / Imaging PC.

 

Too many others, however - they are nursing WinXP simply because they subscribe to a self-perpetuating "Common Knowledge" that states the "New Windows Systems are Buggy and Incompatible and Difficult-to-Learn" even though all of these are demonstrably untrue.

Link to comment
Share on other sites

In case it helps others, I encountered the Camera Not Found issue after a friend's Canon (a 5D I think) was used instead of my regular 20D.

 

Even though I uninstalled the T3i's adaptors (i.e, for the 20D) I still had the problem. 

 

However, in the Windows Device Drivers list, under 'Portable Devices,' in addition to the T3i device being listed, there was a generic entry called 'G' and after deleting/uninstalling both, the T3i device was re-installed after doing a Serarch for New Hardware, at which point everything started working again.

Link to comment
Share on other sites

If the "Friends DSLR" was actually a 5D, which is a DigicII that only comes with Old Drivers that only work under 32-bit Windows, it could be that Windows goofed and loaded such Drivers onto the 64-bit Windows PC.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use