Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

BYEOS & Astrotortilla


NW_Sky

Question

Since updating to BYEOS 3.1.5, AT and BYEOS are "out of sync".  AT is able to connect to BYEOS and the first image from BYEOS is plate solved, the mount then syncs and re-centers. (I have "sync scope", "re-center", and "repeat until  within" . . . all check marked it AT)  This is where things go astray.  AT isn't waiting long enough for BYEOS to take the next image.  It appears AT tells BYEOS to take the next image but before the image can download, it starts plate solving the first image again.  While it is performing this second plate solve, BYEOS downloads the second image. Since AT thinks the mount is still where it was to begin with, it syncs and re-centers, and then starts plate solving the second image, (which is not where the mount is really pointing).

 

When I updated to the new BYEOS version, I did not delete the old version (I have since uninstalled the old version).  Could there be an old config file somewhere I need to delete?  Or is there something else I need to do to get AT and BYEOS to communicate correctly?  I've tried changing the port number but get the same behavior.  Thanks in advance for assistance.

Link to comment
Share on other sites

  • Answers 20
  • Created
  • Last Reply

20 answers to this question

Recommended Posts

Nothing aside that you found a bug in 3.1.5.

 

Use 3.1.4 where you indicated it working properly.  3.1.5 was the first time I changed the API since the first integration with AT so stick with what works, 3.1.4 :)

 

Regards,

Link to comment
Share on other sites

Astro Tortilla supports the Open File Dialog option which is more manual, but works just fine.  Here is how it works.

 

Choose the Open File Dialog as your camera.

Start the plate solve. AT will pop up a Windows Open File dialog. Browse to your BYE Download folder.

Now in BYE confirm that the 'Save Snap Images' option on the Settings dialog is checked.

Now in BYE go to Frame & Focus and set the shooting parameters (shutter, ISO, etc.).

Click on 'Snap Image'. BYE will snap a picture and put it into the download folder or a subfolder.

Make sure that AT's Open File Dialog is looking at the same folder and select the image file.

 

It is not as convenient as the use of interprocess communication to automate it, but it does work.

Link to comment
Share on other sites

I am not sure but I also have versión 3.1.5 installed.

Last time I went out I used AT and it worked.

Sometimes it just drops out but that behaviour I have seen with

all versions of BYE so that belongs to AT.

Now I am not sure if I worked with 3.1.5 or with 3.1.4 but after

Reading this thread I tried to open versión 3.1.4 and it asked to

confirm my fingerprint, whereas versión 3.1.5 just started as always.

 

Would that imply that I used versión 3.1.5 with AT and/or how can I check.

In the fits header there is no reference to the versión of BYE used.

 

Best regards,

Mert

Link to comment
Share on other sites

The fingerprint thingy is because I have made a minor change to the trial verification keys and that change required than all keys be revalidated in 3.1.5 and in 3.1.4 if you start it after 3.1.5 has been installed.  No harm done, just revalidated your key and you're back in the saddle.

 

Thanks. 

Link to comment
Share on other sites

Absolutely no changes are made in image files provided via the AT integration.  These image files are as-is coming out of the camera.

 

This integration aims at providing images for the purpose of plate solving without any overburden on the BYE side... so the exif data (it is not called fits header in the dslr world) is not read and is not modified at all.

 

Regards,

Link to comment
Share on other sites

Ok I'm sorry for my mistake.

So if I understand all this correctly, in the exif data would be some

sort of identification of the imaging program, BYE in this case

 

How can I read this data to check with which versión of BYE I as working.

Ok, justsaw how to read this, with Canon Digital Photo Professional.

Unfortunately, here is only info on the image, not on the capture program.

Thanks for shining light on my doubts, was just trying to help a bit

Mert

Link to comment
Share on other sites

In BYE you need to click the "rubik's cube" icon while your image is displayed.

 

The information about the capture program is something BYE does, not all program does it.  For BYE to add this data you need the "SKIP Exif Write" setting in BYE's Advance settings windows to be unckeck at time of acquisition.

 

Regards, 

Link to comment
Share on other sites

FWIW - I have been running 3.1.5 for a while (with Canon 6D). Integration with AT works same as before for me (most times works fine, occasionally there is a hiccup where it never seems to "get there" after many iterations of "Repeat until within").

 

Can't imagine being without either AT or BYEOS  :=)

 

 

Dave

Link to comment
Share on other sites

No need to delete the old version of BYE before installing.

 

Although your description is complete, we need to more information on your setup.

 

What version of BYE are you using?

What version of AT are you using?

What camera model do you have?

 

Did it work with a previous version of BYE?

 

Do you have mirror lock enabled on your camera?

Do you have in-camera noise reduction enabled?

 

Regards,

Link to comment
Share on other sites

I am not certain of the previous version, but it would have been what was current in September 2014. 

 

I just checked Windows Task Manager (Applications tab) and I have two instances of O'Telescope BackgroundWorker Console running.  Also, two O'Telescope BackgroundWorker.Start.exe listed on the Processes tab.  Is that normal?

Link to comment
Share on other sites

Try with 3.1.4 and/or 3.1.3.  I did change the API in 3.1.5 to support TheSkyX.

 

I wonder if I messed the STATUS command.  I don't think I did but if 3.1.4 or 3.1.3 do work then I did mess something up for sure :(

 

Please report your findings.

 

Regards,

Link to comment
Share on other sites

I installed 3.1.4.  I tried to connect to the camera and nothing happened.  I clicked on Settings and now get "Unhandled exception has occurred . . . object reference not set to an instance of an object" error.  I uninstalled BYE, and then deleted the Backyard EOSv3.1 folder under Program Files and installed 3.1.4 again.  I continue to get the Unhandled exception error.  

 

I also tried a new USB cable from the camera to the hub.  

 

Is it possible to start from scratch?  What do I have to uninstall/fix to start fresh?

Link to comment
Share on other sites

Guylain,  

 

BYE 3.1.4 and AT play nice with each other.  AT waits for the second image to download before starting its next plate solve.

 

Would you like me to test 3.1.5 again? or do you have enough info to proceed?

 

Thanks again for your help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use