Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Not downloading photos



Just purchased 3.1.2 EOS

It connects to my T2i, and so far as I can tell, all control functions are working, but I can't get it to download the photos to the PC.

Save To is set to Camera and PC.


This laptop is Win10.


The Canon EOS app downloads photos fine using the same cable.


Input would be greatly appreciated.


Thank you,


Link to comment
Share on other sites

  • Answers 17
  • Created
  • Last Reply

17 answers to this question

Recommended Posts

No error message, nor does the image does show in the display.

The progress monitor cycles through "downloading", but again, nothing shows up.

I've searched the entire hard drive for both the target name I entered, as well as the frame number from the camera.


I do get live video from the focus mode, as well as drift align.


I just uninstalled 3.1.2 and installed 3.1.5 and still the same thing. 

Link to comment
Share on other sites

BYE v3.1.5 is the current Version, and you might want to upgrade to it (on the Downloads page in the Forum Header).


I have a T2i, and used it with BYE v2 and v3 and v3.1, and in all versions the Save to PC has worked successfully.


Most likely, there is some issue with the Directory that you've set the Files to be saved IN.  Make sure that Directory isn't something "unusual" but rather perhaps you should use the default "My Pictures".

Win10 has even stronger File Security than Win8 or Win7 and doesn't allow User Files in "Program Files" or "Windows" or other non-User Directories...

Link to comment
Share on other sites

I just reset the destination to be the "pictures" folder and same issue, didn't download the photo.

My previous destinations were the default folder for BYE; User-BYE, the desktop, and a folder on the desktop. 


Thank you to all who are helping with this issue. 

Link to comment
Share on other sites

Do you have all the images in the BackyardTEMP folder or one of its subfolders?  It could be that there is a problem in your system with updating the EXIF data, so the images are never making it into the BackyardEOS folder. If so, you could try checking the "Skip EXIF Write" option on the Advanced Settings screen.


Link to comment
Share on other sites

Still don't see downloaded photos.

As requested, I will send the log files in just a few minutes. 


To bring this thread up to date, here is the summary of what I have done. 



Windows 10 professional laptop

Canon T2i

USB cable

BYE 3.1.5 classic (also had issue on BYE 3.1.2 classic)



Not downloading photos (or maybe not able to see downloaded photos)

All functions within BYE seem to be operational, except I cannot get it to download the photos to the PC.




The Download Folder has been set to the BYE default, the desktop, a folder on the desktop, and Users->Pictures

Tried with and without Sub-folder

Tried with and without Write EXIF data

Tried with Advanced Setting = Maximum Statbility



When I initiate a photo, the progress indicator goes through all the steps, including downloading, and I get a "ding" at the end and the progress log shows session complete.

However, nowhere on my laptop can I find the downloaded photo.  I have looked in the download folder I set, every folder listed on the downloads page, searched the entire computer for the target name I set (including making weird target names to be easier to find), and searched the entire computer for the file number of the photo from the camera.

The image does write to the camera card.  I've also tried setting it to save to PC only.


I do not receive an error message (again the session log says complete).

The image does not display in EOS.

Frame and Focus does display the image and allows for a snap photo.

Drift align also shows the image.

The Canon EOS utility does allow me to download photos to the PC. (I've made sure all EOS utility functions are turned off before launching BYE)


Thank you for helping with this. 


Link to comment
Share on other sites

Sorry, but it is not clear what you mean by "uninstall all components".  Do you mean wipe the hard drive and install Windows 10 and all other applications? or just uninstall and reinstall BYE?


There is only one situation that I can recall where any issue has been solved by re-installing BYE.  It is due to corruption of the configuration files that are in the same folder where BYE itself is installed.  The fix is to install BYE to a different folder.  However, since your symptoms are not at all similar, I do not expect that re-installing BYE will fix anything.


Have you tried running BYE "as Administrator".  If your issue is related to security/permissions this may be a workaround. You should not need to do that, but if it works it could provide both a workaround and a hint about what is different on your system.


Another thing to try is to temporarily disable your virus protection and then try running BYE.


Are you shooting RAW or JPG?


Are you running BYE from the same account that you used to install it?


Just to be clear, do you experience your issue when your Download Folder (as specified on the BYE Settings dialog) is set to a local non-removable hard drive with a path similar to this : C:\Users\<username>\Pictures\BackyardEOS? And this folder actually exists?  and you can read and write files to the folder via Windows Explorer?


The BackyardTEMP folder should also be pointed at a local, non-removable hard drive with a path similar to C:\Users\<username>\Pictures\BackyardTEMP", and that folder should exist and you should have read and write access to it.  This folder cannot be on an external hard drive or thumb drive.


Do you have at least 10 gigabytes of free space on the hard drive where the Download folder and BackyardTEMP folder are pointing?


In any case, your best shot, before reinstalling anything, is to send Guylain your log files!

Link to comment
Share on other sites

Run as Administrator was the trick.

Thank you for reminding me of that.  As soon as you said that, I said to myself it would work because Adobe Lightroom did the exact same thing when I upgraded to Win10.


To help close this out, I uninstalled BYE only, all of my save locations were the internal HD, I was running the app from the user it was installed under (which is the admin), and I have plenty of drive space.


I'll provide the log files for reference.


Thank you all for your input. 



Link to comment
Share on other sites

Well, according to the log files you sent all images are downloaded in C:\Users\User\Pictures\BackyardEOS\.


2015-10-18 11:05:32,704 [MoveFile(Normal)] INFO  - MoveFile START!
2015-10-18 11:05:32,708 [MoveFile(Normal)] INFO  - move: C:\Users\User\Pictures\BackyardTEMP\Download\IMG_0001.CR2
2015-10-18 11:05:32,708 [MoveFile(Normal)] INFO  -   to: C:\Users\User\Pictures\BackyardEOS\LIGHT_1s_100iso_f20_+23c_20151018-11h05m30s731ms.CR2
2015-10-18 11:05:32,708 [MoveFile(Normal)] INFO  - Try move C:\Users\User\Pictures\BackyardTEMP\Download\IMG_0001.CR2
2015-10-18 11:05:32,718 [MoveFile(Normal)] INFO  - moved to C:\Users\User\Pictures\BackyardEOS\LIGHT_1s_100iso_f20_+23c_20151018-11h05m30s731ms.CR2
2015-10-18 11:05:32,718 [MoveFile(Normal)] INFO  - MoveFile total execution time 0.014 seconds.
There were no errors at all in the log files.
Link to comment
Share on other sites

The fact that the path is C:\Users\User... seems unusual.  With my Windows 7 system my Users subfolder is the name of the account that I log in to. 


You should not have to run BYE "As Administrator".  It is not recommended that you routinely run from the Administrator account.  I run under a Rick account which I have added to the Administrators group.  However, I am  able to log in under the Administrator account should I ever do something dumb that locks me out of the Rick account.


I would make sure that you have full access to the C:\Users\User folder and sub-folders. Solving this may fix your issue with Lightroom, as well.

Link to comment
Share on other sites


The log files I sent were generated after I had uninstalled (including removing old log files) and reinstalling the app.  Which I think we all agree had no impact on the outcome.


Also, please recall that I indicated I never actually received an error, it simply would not download the files.  The progress indicate and log script on the imaging that it had successfully completed the session, but again, no download.   The only difference between the working and not-working scripts (run as admin vs run as user) that I can see is that when run as administrator the last log entry shows the file, i.e. lights_1s_1600iso etc., while the non-working method ends with session completed, but no file info. 


It is very easy to replicate the issue now.  Run the app as administrator and everything works great; run it as standard user and the script says it completes but nothing shows up in the folder.  If the log files are not capturing this, I would by happy to do a short video showing what I am describing.


Since I can run as administrator and have full functionality, I consider the matter solved for me.  However, as I mentioned in an earlier post, a very similar thing happened with Adobe Lightroom when I upgraded to Win10.  In that case there was an existing forum indicating Win10 has some different permission sets and may require Win7 apps to be run as administrator.  So, my guess is this will pop up again for someone else as more people migrate to Win10.


Thank you for all your help.



Link to comment
Share on other sites



You are not the first person to run BYE on a Wondows 10 computer.  However you are the first that has reported trying to run it from the Administrator account.  Perhaps you should try to install and run it from another account, even if it is a member of the Administrators group.

Link to comment
Share on other sites

Not receiving and error in the UI and having a logfile without errors are not the same.  I log a lot more stuff in the actual log files and yours were clean... albeit you're running as admin now.


Thanks for confirming it is now working with admin rights.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use