Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Cannot connect with Cannon 6d



Hello together,


I do not get it to connect with BYE to my new Canon 6D.

I am running Win 7, 64bit. According the compatibility list this should work.


After connecting the camera by LAN cable the EOS 6D is shown in the Windows Device Manager under USB devices (working correctly).


EOS Utility is NOT running. I even uninstalled EOS Utility and restarted the Computer - also without success.


On the other hand the Software "qDSLRDashboard" can connect to the camera. (note: i do not to connect BYE to the 6D while qDSLRDashboard is running).


I have searched for a specific Driver on the Canon pages - but there is stated that the camera does not need a specifc driver. But after the Installation of qDSLRDashboard I was told to install a WINUSB driver.


I have following Information from the Device Manager


Driver Provider: libusb.info

Driver Date: 18.06.2013

Driver Version: 6.1.7600.16385


In driver Details following Information are shown:


Driver files:





Provider: Microsoft Corporation

File Version: 6.1.760.17514 (win7sp1_rtm.10119-1850)


Any idea what is going wrong?



Thanks in advance for your Support and best regards



Link to comment
Share on other sites

  • Answers 9
  • Created
  • Last Reply

9 answers to this question

Recommended Posts

Hello togehter,


one last additional information:


It was definetively the Zadig WINUSB driver (which I was told to install to get qDSLDashbaord running).


After installation of that driver it wasn't possible to connect BYE with my EOS 6d. Also EOS Utility did not work anymore (connected by USB).


After removal of the Zadig driver (which worked this time) BYE and EOS Utility worked again as expected.


Best regards



Link to comment
Share on other sites



You are correct.  The device driver for you camera is part of Windows, so there is no separate install from Canon.


I know that you have uninstalled the EOS Utility, but it will be helpful to see if that tool can successfully connect with the camera.  If EOS Utility can connect with the camera but BYE cannot, then it is likely that Guylain (support(at)otelescope.com) will want to see your log files.  If EOS Utility cannot connect either then either some other app (qDSLRDashboard, for example) has use of the camera that is preventing the EOS SDK from connecting with the camera, or there is some setting in the camera that is preventing the SDK from finding the camera.


In your note you said that you connected the camera to your PC via a LAN cable.  I would try disabling LAN and WiFi connections and try a USB 2.0 connection between the camera and PC.


Let us know what results you get.

Link to comment
Share on other sites

Hello Rick,


thank you for answering!


I reinstalled EOS Utility and then I saw it is not an issue with BYE. I cannot also not connect to EOS Utility anymore by USB. 

But I still could connect by WLAN to EOS Utility (I would laugh about that if I wouldn't be so frustrated - It took me a long time yesterday until I get WiFi connection to EOS working).


For sure the Wireless is deactivated, if i want to connect by USB cable. To be sure I reset the WLAN settings (and also all other settings) on my EOS.


I also uninstalled ALL EOS software from Canon, uninstalled the WINUSB driver I had to install for qDSLRDashboard, uninstalled qDSLRDashboard itself (every time with a restart of my computer) - without success.


Then I tried to reinstall the Canon EOS software from scratch: the same: also not possible to connect to EOS Utility.



The last thing I tried was to install a trial version of BYE on my desktop computer and it was possible to connect to the EOS 6D.

I compared the driver on my desktop and laptop:it is exactly the same dirver shown in the device manager (same date, same version number, same files listed in the details section, ...)


So it is for sure no BYE problem - but I hope nevertheless that somebody can help me here in this forum with my problem (I realy want to avoid to setup my computer from scratch).


Once again thanks for help and best regards



Link to comment
Share on other sites

Any chance that the USB Ports on your Laptop are USB3 ??

Unfortunately, many of the earlier adopters of USB3 used non-Intel Chipsets which were found to be only "somewhat compatible" (if you are using an AMD-based Laptop then I have no current experience).

This was especially true about Backwards Compatibility to USB2 Devices such as your 6D.


Try to use each of your Laptop USB Ports, to see if one of them is connected internally via the Intel Southbridge Chipset (the most-compatible USB connection on most Laptops).

Also compare the Laptop to the Desktop - CPU brand, Chipset Brand, USB Ports versions, etc...


Let us know...

Link to comment
Share on other sites

Hello togehter,


the USB Pots on my laptop are USB3 (that was one criterea for buying it, because I am planning to buy a very fast ASI planetary cam). It is a lenovo T450s on a LENOVO 20BX0011GE mainboard with a i7 5600 CPU


I have installed a hardware analysis tool and found following information (I am not very familiiar with hardware)::
- Chipset: Broadwell-U Host Brdige - OPI
IO Interfaces:
- Standard PCI-to-USB extended hostcontroller
- Intel® USB 3.0 eXtensible-hostcontroler
(I don't know how to find how the USB3 ports are connected internally, Are there other information I can provide, which might lead to a solution?)
I have tried every of the three available USB3 ports. For all the same result. The EOS 6D is available in the Device Manager and I can transfer images from the camera to the computer (from a window available in the task bar after connecting, which show me the remaining SD card space, battery status, an icon to import images, and a icon to launch EOS Utility). But I cannot start EOS Utility (v.3) and I cannot connect with BYE to the 6D (choosing DIGIC 3/4/5/6 driver).
Instead my old EOS 450D: It works on the lenovo laptop. With this camera I can start EOS Utility (v.2) and BYE is connecting to the camera (here choosing DIGIC II driver).
(an argument against USB3/USB2 incompatibility)
On the other hand: on my some years old desktop computer (also win7, 64bit but with USB2 ports). Here the EOS6D can be connected to BYE. (and the device manager shows exactly the same drivers as on the laptop).
(argument pro USB3/USB2 incompatiblity)
Note: on my laptop I am running BYE 3.1.3 Premium, on my desktop computer I installed a trial version of BYE (was not sure, and wanted to avoid licensing issues).
The wireless comunication for the 6D is for sure disabled (I even deleted all wifi settings on the camera). The strange thing is, the the EOS Utility launcher allways displays the dialog for pairing the camera by WIFI. Normally this window should be skipped, if the camera is connected by USB.
I have searched the internet for similar issues. On a Canon forum I found a very very big thread with complaints, that EOS Utility does not start, if the camera is connected by USB. The most posts applies to win 8 or win 8.1, but there were also some users who have the same problem with win 7. The EOS 6D was not mentioned, but very often the 5D, some 60D, 7D ...,
There were no solution provided (only workarounds how to transfer the images).
I think I will give a try reset to laptop to factory settings. Perhaps I messed something up by installing the WINUSB driver.
Thank you very much for your friendly support!
Link to comment
Share on other sites

Hello together,


the reset of the laptop to the factory settings helped.


After the recorvery the very first thing was to reinstall BYE and it was possible to connect!


So for me the only explanation is that the Zadig WINUSB Driver (resp. the obvious failed desinstallation) was the reason. I think I will not try it again to use this driver :).

If I get some other hints during reinstalling of my other software I will give a note here.


Perhaps I will post a feature proposal/request for BYE: Support for day/night transition on time lapse photography (for this purpose I wanted to use the other software.


Thanks to all how gave me hints and clear skies!



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use