Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Version 3.2.1 just hangs when taking darks


Virg75
 Share

Question

I noticed a weird bug this morning while imaging: if I set up Backyard EOS 3.2.1 to take a sequence of darks, it just hangs at 'busy' after taking the first one. I then tried taking darks, followed by dark flats - it gets to the end of the sequence, where it hangs again.

Didn't have this issue with 3.2.0: has anyone else encountered this?

Cheers,

Brian

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

I do not understand your description. You say that BYE hangs after you take the first dark frame. but in the next sentence you said that when you take darks followed by dark flats that it hangs at the end of the sequence. These two descriptions seem contradictory. If BYE "hangs" after the first dark frame how could it ever get to the end of a longer sequence that includes dark frames?

Also you have not mentioned what model of camera you are using. This could be important and should always be provided when asking for help.

AFAIK the code/logic used by BYE to capture dark frames is the same as the code to capture light frames. The only difference with darks is that any mirror lock logic is bypassed.

Do you have Long Exposure Noise Reduction, High ISO Noise Reduction, or Exposure Bracketing enabled in the camera??? These 3 items should all be disabled when you use the camera with BYE. Also, the dark frames should be taken with the same camera settings as the light frames, so LENR should be either on for all or off for all. This would mean that you experienced the same "hanging" with the light frames. For the vast majority of uses LENR should be off!

Two other causes of "hanging" can be due to your anti-virus software being overly protective and blocking new images from being downloaded. Avast anti-virus is a common culprit. Another cause could be saturation of the internal (to your PC) USB hub that the camera is connected to.

Link to comment
Share on other sites

  • 0

@astroman133Apologies, should have been clearer.

The issue was first noticed when I tried to take two dark frames (and nothing else - it was cloudy): it took the first OK, then just stuck on 'Busy'. I then tried a sequence of multiple darks, followed by dark flats - and it hung at the end of the capture of the dark flats. I'd have to quit BYE, and restart it. The lights sequence I did that night completed without a problem, which is weird.

I'm using a canon EOS 250D/SL3 - I'd been using v3.2 without any issue for the last few months and recently upgraded to 3.2.1. All of those settings are off, and the camera uses the same settings as for lights.

@admin - thanks, will send them to you now.

Link to comment
Share on other sites

  • 0

Again, dark/dark flats is irrelevant, that is just a label.

Usually, when BYE just hangs like this it means something on the computer side went to sleep due to inactivity.  Make sure computer / SSD / USB ports are not set up to sleep after a few minutes of inactivity.

 

Link to comment
Share on other sites

  • 0

When you say "it hung at the end of the capture of the dark flats" do you mean that BYE never completed the dark flat capture sequence? If you took 10 dark flats, you got 9 dark flat images successfully, but never got the 10th image and had to kill BYE to recover?

If so, intermittent hangs like that can be due to a flaky cable or hub. The hub can be an external hub or a hub that is internal to the PC. Try using shorter cables, different cables, different hubs. Try moving the camera USB to a USB jack on the opposite side of the PC. I would also suggest that if you are using a USB hub that you use only a powered hub, especially if you have multiple devices (imaging camera, guide camera, focuser, and mount) connected to the hub. Unpowered hubs can only provide limited current to be shared among all devices. A powered hub can provide max current (usually 500 ma) for each device.

It could also be due to the PC or USB port powering down after a perceived period of inactivity. So you should confirm the power saving settings in the camera and for the USB port on the PC.

Link to comment
Share on other sites

  • 0

You get this is your log files.

2020-12-20 07:43:52,686 [Main] ERROR - An error occurred loading a configuration file: Access to the path 'C:\Program Files (x86)\BackyardEOSv3.2\fja2m2fw.tmp' is denied. (C:\Program Files (x86)\BackyardEOSv3.2\BinaryRivers.BackyardEOS.Start.Camera1.exe.user.config)
2020-12-20 07:43:52,686 [Main] ERROR -    at System.Configuration.MgmtConfigurationRecord.SaveConfigSource(DefinitionUpdate update)
   at System.Configuration.MgmtConfigurationRecord.SaveAs(String filename, ConfigurationSaveMode saveMode, Boolean forceUpdateAll)
   at System.Configuration.Configuration.SaveAsImpl(String filename, ConfigurationSaveMode saveMode, Boolean forceSaveAll)
   at BinaryRivers.Basics.Configurations.SettingManager.SaveCache(Boolean force)
2020-12-20 07:43:52,686 [Main] ERROR - Access to the path 'C:\Program Files (x86)\BackyardEOSv3.2\fja2m2fw.tmp' is denied.
2020-12-20 07:43:52,686 [Main] ERROR -    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access)
   at System.CodeDom.Compiler.TempFileCollection.EnsureTempNameCreated()


Looks like Windows permissions are messed up.  Try the following steps in this post.

 

Try this....

 
 

 

 
 
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use