Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Question

15 answers to this question

Recommended Posts

  • 0

I think I figured it out, and it is a Windows problem, not a BYEOS problem. Apparently windows sorts based on non-obvious dates embedded in the files (as described in https://jakubmarian.com/windows-8-10-sort-by-date-slow-solution)

If I replace the "Date" column with "Date Created" everything is as I expect.

Thanks,

Bret

p.s. For posterity, here is an example of the explorer window that started this (notice the weird order):

image.thumb.png.cf4500639040fe47ef846cf5ae72320a.png

Share this post


Link to post
Share on other sites
  • 0

I did but there is nothing useful in them. 

You selected the "Canon210" drivers when trying to connect your camera; that is for cameras built BEFORE 2008.  You need to select the latest driver "Canon", not "Canon210" in BYE when trying to connect your 90D.  Then send me that file.

 

2019-10-20 13:52:21,406 [Main] DEBUG - ButtonPlus_MouseClick(btnCam2 = 'DIGIC 2 cameras generally manufactured before 2008 (5D, 20D, 20Da, 30D, 350D)')
2019-10-20 13:52:21,436 [Main] INFO  - Attempting to connect camera...

 

Regards.

Share this post


Link to post
Share on other sites
  • 0

I tried it last night, and it seemed to be working. There was one odd thing I noticed (but I want to double check, I was actually out under the stars) . I was shooting RAW+JPG, and it seemed to sometimes only download the .cr3 file -- not all images appeared in pairs. If that was really happening, I'll upload the logs.

But on the whole it could control the camera, take images and download them, so much progress for 1 day.

Bret

Share this post


Link to post
Share on other sites
  • 0

I had a chance to look over the images from last night, and it seems to be working on my 90D. If you sort the images by date, there are some weird skips that make me think that either the camera puts the wrong date on some images or that Backyard EOS is downloading the images out of order (taking 1 image, downloading the CR3, then taking another, downloading the CR3 and the 2 JPGs).

If that seems surprising enough to look at, let me know and I'll upload the logs.

Thanks,

Bret

Share this post


Link to post
Share on other sites
  • 0
12 minutes ago, bret.mckee@gmail.com said:

I had a chance to look over the images from last night, and it seems to be working on my 90D. If you sort the images by date, there are some weird skips that make me think that either the camera puts the wrong date on some images or that Backyard EOS is downloading the images out of order (taking 1 image, downloading the CR3, then taking another, downloading the CR3 and the 2 JPGs).

If that seems surprising enough to look at, let me know and I'll upload the logs.

Thanks,

Bret

Yes, I'd like to see those logs.  There is nothing special with the 90D and image download... in fact image download is generic and identical for all models.  Hopefully the log will shed some light.

If you use CR3 only... do they appear in the correct order?

Thanks

Share this post


Link to post
Share on other sites
  • 0

Bret,

How long are the exposures that are out of order? Where are you getting the time from? The image file name, the image metadata, or from the images file's Properties? Is the BYE Background Worker enabled (on the Advanced settings screen)?

I used BYE 3.1.18 RC11 with my T5i and was unable to recreate what you are reporting. I tried with a sequence 1 second exposures and a sequence of 10 second exposures. I  made two capture runs; one run did not use the Background Worker and the other did use the Background Worker.

In all cases the RAW and JPG images have the same name, including the timestamp portion of the file name. The only difference was with the file extension. This was all as expected.

None of the images appeared out of order when viewing the Download folder in Windows Explorer, either when sorted by File Name or by Date.

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, bret.mckee@gmail.com said:

I think I figured it out, and it is a Windows problem, not a BYEOS problem. Apparently windows sorts based on non-obvious dates embedded in the files (as described in https://jakubmarian.com/windows-8-10-sort-by-date-slow-solution)

If I replace the "Date" column with "Date Created" everything is as I expect.

Thanks,

Bret

p.s. For posterity, here is an example of the explorer window that started this (notice the weird order):

image.thumb.png.cf4500639040fe47ef846cf5ae72320a.png

Thanks for reporting back.  Glad you figured it out.

Regards,

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, astroman133 said:

I am not sure what you are using for your Filename Template, but if you add <timestamp> as the unique identifier portion, then sorting by file name is the same as sorting by the file creation time.

<timestamp> is there by default.  Looks like he removed <timestamp> and only added <time> towards the end of the template.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use