Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0
Sign in to follow this  
G400

Canon 5D Mark II

Question

Hi there,

I was offered a modded 5D Mark II and today we tested to connect to BYEOS but it did fail.

Any idea why we were unable to connect the camera to BYEOS?

Thanks & Regards,

Andreas

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

You do not provide much information to help narrow down the causes so here goes:

1- you were already running the Canon EOS Utility
2- the camera was powered off or the battery was dead
3- the camera is broken
4- the USB cable is faulty
5- the USB cable was not fully seated at both ends
6- the USB port on the PC is not working
7- you chose the wrong SDK when you tried to connect. Depending on which version of BYE you are using, there are either 2 or 3 SDK choices (Canon210, Canon215, Canon). You must choose Canon!
8- Windows does not have the correct low-level driver for your camera (not likely, but possible).

If you provide more information, we can provide a more targeted reply. You should always provide the camera model (as you did), and also the BYE version number and your license as well as the steps to re-create your issue.

Thanks!

Share this post


Link to post
Share on other sites
  • 0

Hi astroman133,

thanks for your reply.

1 - EOS Utility was not running and did not start to do so after powering on the camera after being connected via USB cable

2 - camera was running on battery

3 - camera was working properly stand alone

4- maybe -

5 - was plugged on both ends properly

6 - usb port is working on my laptop as I use this for mobile astrophotography

7 - I am running BYEOS v3.1 under Windows 7 Professional V 6.1, SP1 -> there was nothing to chose from -- it was simply not possilbe to connect to the camera

8 - ?

Thanks & Regards,

Andreas

Share this post


Link to post
Share on other sites
  • 0

EOS Utility might start automatically when you connect your camera.  Look in task manager and make sure it is not running.

Does Windows even the the camera in device manager?

 

Share this post


Link to post
Share on other sites
  • 0

Also, there are several released versions of BYE 3.1 all the way up through 3.1.17. Please provide the complete version number.

Start BYE and go to Settings and Advanced Settings. Make sure that "Ask for camera drivers" is checked. Save the settings and restart BYE. Be sure to select Canon driver/SDK when prompted at connect time.
 

 

Share this post


Link to post
Share on other sites
  • 0

Good evening ... I'm a very experienced photographer although a complete newbie relative to BYE and astrophotography in general and trying to transition from wide field astro and begin learning the tools for astro imaging such as BYE

I too am having connectivity issues with my Canon 5D Mark IV and I've run thru the 1 - 8 checklist

I've just downloaded the latest n greatest BYE v3.1.17 Premium Edition

WiFi is disabled

No EOS Utility is running

Cables and USB are good...based on the live view display the camera thinks its connected to the laptop

I have definitely chosen Canon on the SDK (and just for giggles also tried Canon 210 -- this version does not show Canon 215)

I made sure the "Ask for camera drivers" box was checked in the Advanced settings

17:20:06  Licensed to photographybywam@gmail.com
17:20:20  Attempting to connect camera...
17:20:20  Canon drivers 'Canon\' initialized.
17:20:20  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Any other thoughts/suggestions would be greatly appreciated!

Cheers!

Bill

logfile-[20191107-17h20m02s083]-[11368]-2019-11-07.txt

Share this post


Link to post
Share on other sites
  • 0

The original poster of this thread stopped replying several months ago. AFAIK his problem was never solved. He never told us what version of BYE he was using...It could have been an old version that did not support the 5D Mk II.

The Canon215 SDK version was dropped since the Canon version supports all the same cameras plus newer models.

It appears that the Canon SDK does not see the camera.

After the camera has been plugged into the PC and powered on, you should see the camera in the Windows Device Manager. This means that Windows has recognized the new USB device and loaded the low level driver. The low level driver is usually part of Windows. Do you see the camera listed in the Device Manager when it is plugged in and powered on? If not, this is either a bad USB cable or a malfunctioning camera, given that you have made sure that the camera's WiFi capability has been turned off.

You could try connecting to the camera from the EOS Utility, but if Windows does not see the camera then the EOS Utility will fail as well. Canon should be able to help you get the camera recognized by Windows and to connect with the EOS Utility.

Share this post


Link to post
Share on other sites
  • 0

Please start a new thread.  You appear to have the 5D Mk IV and this thread is about a much older camera, the 5D Mk II.  There are not even close.

Regards,

Share this post


Link to post
Share on other sites
  • 0

Hi guys...yes I know the MkII and MkIV are very different cameras...but just to finish this I was looking at every thread related to connectivity and THIS particular thread had the most useful checklist of things to check

and Astroman133 was correct...the laptop was NOT recognizing the camera until I restarted that laptop with it attached...then I definitely saw the camera on the list of active devices and connectivity to the BYE was simple and straightforward.

as is many times the case, the main culprit is not the software but user error and/or something related to the user's system...I acknowledge that and appreciate the clue/thought provided by Astroman133 earlier in the evening.

thanks so much!!!

Bill

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use