Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

D40x Not Connecting


deansj
 Share

Question

Condition: Camera not connecting:

  • Nikon D40x, fully charged, few file on SD card
  • Direct USB cable connection to PC working – indicated by other capture software
  • USB mode set to MTP/PTP (not mass storage)
  • Windows 10 on ASUS running on AMD chipset
  • Connection attempt times out (never ends – need to kill BYN)
  • Other compatibility options tested and failed.  Elevated privileges used, same result.

 Sample Log using XP SP3 compatibility test mode:

 Nikon 2015 selected, followed by D40x selection

 11:25:55  Licensed to deansj

11:27:05  Attempting to connect camera...

11:27:05  Nikon2015/D40X drivers initialized.

11:27:12  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

 

Following one test where the connection attempt just kept going, I killed the BYN and had this error:

(Screeny attached)

 

 

C++ Error.docx

Link to comment
Share on other sites

  • Answers 7
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

7 answers to this question

Recommended Posts

  • 0

C++ redistributable was installed, but required a repair.  

Repair completed.  PC restarted.  BYN restarted.  

Connection failed under Vista compatibility setting with this log:

12:41:44  Licensed to deansj
12:42:38  Attempting to connect camera...
12:42:38  Nikon2015/D40X drivers initialized.
12:42:46  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

No C++ errors.

Are there further troubleshooting options?

 

Regards.

Link to comment
Share on other sites

  • 0

BYN 2.0.9 Trial version is being used.

For the D40x model (a great vintage :)) USB only two options.  The other is mass storage.  My understanding of that option is for access to SD card.

"When the camera is in the PTP (Picture Transfer Protocol) mode, it appears to the computer as a camera. As such, aside from basic file transfer tasks it allows you to remotely control the camera (fire the shutter, change exposure, etc.) as well as use various advanced features (custom curves, additional settings, etc.). Generally speaking most PTP drivers will also mount the camera's memory card, so you'll have all the functionality of MSC as well."

The above comment seems supported by my experience using DigiCameraContol.  No communications is possible to that software using Mass Storage" mode.

 

Regards

Link to comment
Share on other sites

  • 0

Trial complete.  Same result:

15:46:59  Licensed to deansj
15:47:26  Attempting to connect camera...
15:47:26  Nikon2015/D40X drivers initialized.
15:47:34  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

I verified that the SD in the camera is indeed readable and therefore that I had a good cable connection.

 

HOWEVER!!  I have installed the same version on an old Intel CPU PC and have been able to connect.  I can verify that MTP/PTP is the correct USB mode - not Mass Storage.

That leaves me to attempt to find out what is different in PC's operating environment.  This may prove impossible of course.  If you have any areas for me to investigate, please share those.

I have a plan for evaluating the software now. If I like the software, I will buy a full license and a new Nikon D5300 with LiveView.

I appreciate your assistance.

 

 

I will try an install of the software onto another computer, to rule out any PC local issues.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use