Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Capture shutter speed settings not working Nikon 7100


dbrodersen
 Share

Question

Hello, 

I’m looking into purchasing your software. I’m using a MacBook Pro (Retina, 15-inch, Mid 2015) with 2.8 GHz Intel Core i7 / 16 GB 1600 MHz DDR3 ram. 

I’m using Parallels 13 and have installed windows 10. My camera is a Nikon 7100. I’ve set it to manual (M) and the viewfinder presents “PC” suggesting that the camera is communicating with my computer.

BackyardNikon connects to my camera and I am able to obtain a live view to frame and focus. When I try to capture, the shutter speed doesn’t change to reflect my settings in the software. Bulb doesn’t work at all. When I do use Bulb, I get about a 30 mSec abort message. 

On a couple of occasions, the software seemed to lock up ~ however, the spinner in the upper righthand corner continued to function. After a while I closed the application and restarted it. 

I’ve included all my log files in an enclosed zip file.

 I also tried contacting the sales folks using the web form and uploading the zip file. Thanks for any assistance you can offer.

Best Regards, 

Dave

Logs.zip

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The first thing i would recommend is probably to a factory reset on the camera.  This seems to solve some issues with Nikon mostly as some settings may have inadvertently be changed over the years the may prevent proper operation when tethered to a PC.

Also, make sure the camera is set to Manual where bulb is possible.  As mentioned above, all you need with he D7100 is the regular USB cable.

If you are using a hub you may want to consider plugging the camera directly in a computer usb port, no hubs.

Keep us posted.

 

Link to comment
Share on other sites

  • 0

Dave,

First, when you start a new thread it is a good idea to state which version of BYN you are using. That way when somebody reads the thread a year from now they know what the version is.

The factory reset suggestion is a good one. Based on the error (below) in one of the logs the camera is not responding normally. Cabling is also important. For testing, you should use a single, short cable that you know is good. You might also just try saving only RAW images to the PC to see if that makes any difference..

2017-11-02 22:06:15,900 [CameraTakePictureOnMessageRecieved] DEBUG - TAKE PICTURE ::: Shutter(MANUAL) Cable(CameraUSB) Av(--) Duration(1.0) Iso(1600) Quality(RAW + JPEG Fine) Mirror(0) SaveTo(PC)
2017-11-02 22:06:16,447 [CameraTakePictureOnMessageRecieved] DEBUG - Device Busy trying to start BULB sequence
2017-11-02 22:06:16,531 [CameraTakePictureOnMessageRecieved] ERROR - [kNkMAIDResult_NotSupported] (kNkMAIDCommand_CapSet, 33042, kNkMAIDDataType_EnumPtr, 421913288)
2017-11-02 22:06:16,531 [CameraTakePictureOnMessageRecieved] ERROR -    at BinaryRivers.Camera.Nikon.Wrapper.NikonTaskQueue.Invoke(Delegate d, Object[] args)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonBase.Set(eNkMAIDCapability cap, Object value)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonDevice.StartBulbCapture()
   at BinaryRivers.Camera.Nikon.CameraModel.<>c__DisplayClass26_0.<DoTakePictureBulb>b__0()
   at BinaryRivers.Common.ProviderInterfaces.Camera.CameraControllerBase.DoWithCameraLocked(Action action)
   at BinaryRivers.Camera.Nikon.CameraModel.DoTakePictureBulb(Boolean start, Single mirrorlockseconds)
   at BinaryRivers.Common.Model.CameraModelBase.TakePictureBulb(Single durationseconds, Single mirrorlockseconds, String progresstext)
   at BinaryRivers.Common.Model.CameraModelBase.<>c__DisplayClass77_0.<CameraTakePictureOnMessageRecieved>b__0(Object state)
 

Link to comment
Share on other sites

  • 0

Thanks, everyone, your suggestions were very helpful. A new problem has emerged.

I Reset my camera as suggested. All the shutter speeds now work with BYN 2.0. 

However, here is another problem. Sometimes I mount my camera on the telescope with its own lense. Connection works fine as before. I go into frame and focus and focus the subject (In this case, it's the block wall in my backyard.) 

When I go to capture the image, the camera refocuses leaving the target subject completely out of focus. Near-field subjects are brought completely into focus (rather than the target), which suggests that BYN is leaving it to the camera to determine the best focus point. 

logfile-[20171108-15h33m57s503]-[5868]-2017-11-08.txt

Link to comment
Share on other sites

  • 0

That is just the camera trying to do what it is configured to do. Nikon options for autofocus are different from my Canon. You need to get advice from another Nikon user or read the camera's manual about how to take exposures without re-focusing. Of course You could focus the lens with BYN, tape the lens so that it doesn't shift the focus and then put the lens into manual focus mode; there is probably a better way.

Link to comment
Share on other sites

  • 0

Set the camera either to manual focus or set the camera to use the ae-l /af/l  button for focusing rather than using a half press of the shutter release button to focus the camera.  That way the focusing operation of the camera is entirely separate from the shutter release.  Once you get used to it it is the most logical way to autofocus a camera.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use