Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

USB works for Frame and Focus but not Imaging


foremans
 Share

Question

I have just starting using BYE 3.2.2 Premium (Canon 70D) and spent some time using Frame and Focus to help setup the telescope.  I was able to do an eight minute bulb exposure.  (file not saved)

It was working fine via USB.  I have successfully used Canon Utility (2) and BYE was recommended by another Backyard user.  

I have ensured that Canon Utility was closed before connecting to camera with BYE.

Connection works as I have said, using Frame & Focus but when I try to preview on Imaging I get the Error, "Your camera requires a configured serial cable for BULB and Mirror Lock."

I have tried another shorter cable (1.5m)

I tested turning the Mirror Lockup function on using the camera settings.  When I attempt a preview now I note that the Mirror Lockup reverts to off on the BYE screen and in the camera.  The system is talking to the camera.

I have successfully used this on another computer.  The difference.  Windows 10 vs Windows 11.  I will see if it is a Canon driver issue (Canon Utility does work though) - if not then I would be happy to beta test any work you are doing towards getting this working on Windows 11.

 

Solution

Run BYE as Administrator on Windows 11! 😜.  

Edited by foremans
More information from testing.
Link to comment
Share on other sites

  • Answers 6
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

6 answers to this question

Recommended Posts

  • 0

W11 or i9 are inconsequential, they don't play a role here.

Go to Settings -> Advance Settings and...

  1. make sure "Camera force serial cable" is turned off
  2. make sure "mirror lock" is turned off.

Alternatively, click the "Reset Default", and try again.

 

Link to comment
Share on other sites

  • 0

If you are able to connect BYE to the camera and the Camera Information Center is populated with the current in-camera settings then it proves that the necessary drivers are installed, that the EOS Utility is not connected to the camera, that the USB cable is good, and that BYE is talking to the camera.

I very strongly suggest that you NOT run BYE "As Administrator". This is not necessary for a correctly configured computer and it will negatively affect the ASCOM telescope, focuser, and filter wheel connectivity that BYE supports in the Trial and Premium licenses.

Now what to do about the "Your camera requires a configured serial cable for BULB and Mirror Lock."  message. Only the very old Canons needed a serial cable for BULB exposures. This is not the case with your 70D which is new enough to support BULB exposures over USB. That leaves Mirror Lock as the reason that BYE is complaining. The vast majority of users will not benefit from enabling Mirror Lock, so first you need to disable Mirror Lock in BYE. You can do that by starting BYE, enabling Mirror lock in the Experimental Settings area of the Advanced Settings dialog. Then Save the Advanced Settings and the Settings. Connect to the camera and go to the Imaging screen. Verify that the Mirror Lock interval in the Capture Plan Center is set to 0. Then go back into the Advanced Settings and uncheck both the Mirror lock and the Virtual Mirror Lock settings.

Test by taking pictures from the Imaging screen. Make sure that Save To is set to PC and that Cable Support is set to Camera USB. Try both short exposures (less than 1 second) and long exposures (greater than 30 seconds). Do they work? Are the images downloaded and displayed on the computer screen? If not what error do you get?

You might also try temporarily disabling any Anti-virus software. Some, like Avast, block the image download from the camera to BYE.

Let us know how it goes.

Link to comment
Share on other sites

  • 0

I have done the steps as requested.

The mirror lock zeroed and setting is turned off in advance menu.  Antivirus has been temporarily disabled.

Issue remains.

As indicated I am running windows 11.  I also should note this laptop has an i9-9980 processor.  (Dell XPS 15 7590)

To reiterate.  Frame & Focus shots work.  EOS utility (when run separately) works and can take bulb shots.  Still getting error "Your camera requires a configured serial cable for BULB and Mirror Lock."

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use