Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

I can't control telescope through ZWO ASI ASCOM ST4 driver


fjcaballero
 Share

Question

Good afternoon:

I've just buy a Zwo ASI 224 camera and install all the drivers, ASCOM drivers included (for the camara and for the mount ST4). I have also installed ASCOM platform. PHD2 can control the mount both directly (PHD2 setting 'on-camara') and through ASCOM (ZWO ASCOM ST4 driver). In Backyard EOS I have included the setting for the telescope (ZWO ASCOM ST4 driver), and when opening the ASCOM setting menu, I've setted it (I've just to select the camara). But I can't control the telescope through BYE. What is the problem? Must I do anything else? My BYE is BackyardEOS 3.2.2

Thanks

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

On the ZWO web site, the USBST4 adapter is a discontinued device. Also, it does not provide complete control of a telescope. It can only do short guiding movements and does not support slewing to targets. As such, it would only be useful for PHD2 and not BYE. Contact ZWO for more information about how to use this product.

You did not say what telescope you have, but there are two hardware configurations that can work with many mounts. Both require that the telescope and the camera be connected to the PC, that the ASCOM Platform be installed, and that the ASCOM driver for the telescope and the camera both be installed.

Configuration 1) The telescope mount does not have an ST4 autoguide port, or you decide not to use it.

  • Configure PHD2 to autoguide through the ASCOM telescope driver and to use the ASI224 as the guide camera. The telescope driver must support Pulse Guide commands
  • Configure BYE to control the telescope through the ASCOM telescope driver. The telescope driver must support Move Axis commands.

Configuration 2) The telescope mount has an ST4 autoguide port.

  • Use the ST4 cable that came with the ASI224 to connect between the 224's ST4 guide port and the mount's autoguide port.
  • Configure PHD2 to autoguide through the "on-camera" telescope.
  • Configure BYE to control the telescope through the ASCOM telescope driver. The telescope driver must support Move Axis commands.

If your equipment supports both configurations then it becomes your choice. Some people prefer one and some the other. You should be able to switch between them by simply changing the PHD2 telescope configuration. I would also say that if you want to use PHD2 for polar alignment and are using Configuration 2) that you would typically define the ASCOM Telescope driver as your AUX Telescope in PHD2. This allows PHD's polar alignment logic to slew the telescope and report its position during polar alignment.

Neither of the above configurations use the USBST4 adapter or the USBST4 ASCOM driver. It can be removed if you opt for either one. I believe that the USBST4 driver was originally provided to support ST4 autoguiding for cameras that do not have an ST4 port and your mount has an ST4 port but does not support Pulse Guide commands. Since the 224 does have an autoguide port, use of the adapter is not necessary.

BYE also has a requirement that your telescope must support and accept MoveAxis commands from BYE or any connected ASCOM client. If it connects but does not move the telescope with the chevron buttons, then you may need to use a different app for that purpose. BYE should still work for plate solving, if the telescope driver is fully compliant with the ASCOM interface specification.

If you want to figure out how to use the USBST4 adapter, the following configuration may work. If you want to try it but cannot get it to work then you should ask ZWO for support.

Configuration 3) Autoguide via the USBST4 adapter

  • Connect the USBST4 adapter to the PC and the telescope (via the Autoguide port).
  • Configure PHD2 to autoguide through the ASCOM USBST4 telescope.
  • Configure BYE to control the telescope through the mount's ASCOM telescope driver.
  • Configure PHD2 to specify the ASCOM Telescope driver as the AUX telescope (optional).

Of course Configuration 3) requires additional cabling since you are autoguiding through the USBST4 adapter instead of directly through the telescope (Configuration 1) or through the camera (Configuration 2).

I hope this helps.

Link to comment
Share on other sites

  • 0

Thanks a lot for your answer. I've got the second configuration since I've got a ST4 port. PHD2 goes well, but BYE isn't able to control the mount through ASCOM telescope driver provided by Zwo (although this driver also goes well when using in PHD2). I think there is some problem between BYE and the driver. Although it is true that I can take photos with BYE and control the mount with PHD2, I'd like to have some control from BYE.

I did not understand very well the option to put ASCOM ST driver as auxiliar mount to polar alignment. Do you say I put in PHD2 setting as main telescope 'on camara' and as aux telescope 'ASCOM ST4 driver' from ASI? If so, what is the adventage?

Thanks

Link to comment
Share on other sites

  • 0

If there were a problem between BYE and the ZWO Telescope there would also be problems with other telescopes and all other users would be complaining here.

I would suggest removing the ZWO ASCOM software and re-installing it, but only install the camera driver, not the ST4 telescope drivers.

This is really a PHD2 question, but I will answer it here. When you select the "on-camera" telescope in PHD2 (as per Configuration 2 in my previous post) autoguide commands are sent to the mount through the camera. In order to do additional telescope control from PHD2 you must define your mount's driver as the AUX telescope.

Note: This is NOT the ZWO USBST4 driver which I strongly recommend that you remove by re-installing the ZWO setup program again and only selecting the camera driver. The selected telescope must be the driver for your mount. If you tell us the make of your mount I may be able to suggest where to download it.

See the following screenshot from PHD2 where I have configured the "On-camera" mount but defined the Astro-Physics GTO V2 driver for the Aux Mount.

image.png.3168d8932be0aa40bcaf0e118c578e97.png

This tells PHD2 to send autoguide commands to the camera, but all other commands go to the mount's (telescope's) ASCOM driver.

I hope this resolves your confusion.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use