Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Power Surge


MilesvanYperen
 Share

Question

I have a Canon T3i and I'm having a problem connecting to my Panasonic CF-53 Toughbook laptop.

I get the following error:

Power surge on the USB port
Unknown USB Device needs more power then the port can supply

I looked online and every so called fix doesn't change anything. I've had BYE work with this set up but it's unstable and eventually I get the error and loose connection to the camera.

Is there a solution?

Link to comment
Share on other sites

  • Answers 4
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

4 answers to this question

Recommended Posts

  • 0

Well, "Power surge on the USB port" is not an error to be taken lightly.

USB ports do have power in them to power small devices.... and from this error it looks like yours is faulty and may be providing more power than it should.

If this were me I would get this fixed immediately BEFORE it starts to fry your devices.    I WOULD NOT CONNECT ANY CAMERAS OR ANY OTHER DEVICES INTO THAT LAPTOP IF THIS WERE ME.  

Link to comment
Share on other sites

  • 0

Try a different USB Cable, and a different Laptop USB Port.

The T3i does NOT perform ANY Charging via the USB Port Connection, so the Laptop is either sensing a Power Drop along a Long Cable or a Partial Short between Wires or Connectors.

You other option would be to place a Powered Hub between Laptop and T3i.

 

Link to comment
Share on other sites

  • 0

Thanks for everyone's response. I believe I've solved the issue before reading your replies.

I downloaded/updated the latest EOS Utility. After launching EOS Utility 2 and then closing the app I tried plugging in the USB from the Canon T3i. I've been actively testing it this morning and everything is working just fine. BYE connects instantly and no power surge warnings. Why this fix appears to work... I have no idea. I suspect the EOS software installed some magic voodoo.

I found this by trying to connect the camera to my Windows workstation... I got a different error, something about  a malfunction with the USB device. I did the above install and the error was gone and I could control my Canon from the workstation.

I would love to get your input or theory on what is going on.

Thanks again for responding!

Miles van Yperen

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use