Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

BackyardNIKON v1 BETA 02 is ready for download


admin

Question

YEAH... a step closer :)

 

*** DOWNLOAD BackyardNIKON v1 BETA 02 ***

http://www.binaryrivers.com/download/setup-BackyardNIKON-v100-BETA02.exe

 

Quote:
*** CHANGE LOG ***

- Quick image preview in image capture when RAW+JPG or JPG Only is selected as image format.
- Added box grid in Drift Align Mode.
- Crosshair rotation issue in Drift Align is fixed(decimal was truncated on some computer).
- Weather Center was reporting false temperature when no provider was selected.
- Connection helper when camera does not connect.
- Extra logging on BackgroundWorker thread for debugging.
- User Guide update.  Click the ' ? ' icon in the upper right corner.

- A new beta license key good for another 30 days.

 

 

You can refer to this grid for a quick overview.

http://forum.otelescope.com/post/backyardnikon-v1-beta-progress-grid-6857530?pid=1282424740

 

Please report your findings using this thread.

 

As with other beta releases, the setup.exe is pre-packaged with its own tester license.

 

BETA 02 will install side-by-side to other betas, it will not overwrite BETA 01d.

 

Thank you for all your support in getting this to a production quality.

 

Guylain & Chris.

Link to comment
Share on other sites

  • Answers 30
  • Created
  • Last Reply

30 answers to this question

Recommended Posts

Guylain, with the Nikon I don't think it's possible to use Av mode unless a camera lens is fitted?

 

For flats, simply use M mode, set your shutter speed to an exposure that will give exactly one half full histograms (using the same ISO as the lights).

 

I use my iPad on otas 6" in diameter and smaller.  Download the free App 'Digital Grey Kard', I use the neutral grey.   Works perfectly.   Just adjust shutter length until the histogram is where you want it and click away. 

 

Cheers...Paul

Link to comment
Share on other sites

Guylain, I have added a screenshot by way of an attachment (you'll need to click on it) of something that might be worthy of addressing before you release this as a finished product. 

On the right side of the screen in Planetary mode, there is a reference to BackyardEOS in BackyardNIKON, and there's also several references to EOS in a few screens within the  'Settings' dialog that pops up. 

I've also highlighted a small UI change that might be worth addressing. The "Connect" thumbnail at the top illustrates a Canon. I am thinking it might be wise to have a Nikon depicted there! :) 

I should report that I have had no issues thus far with the latest BETA version, and I have managed to capture quite a bit of data with it.

 

post-3105676-141893876972_thumb.jpg 

Link to comment
Share on other sites

Guylain, I have added a screenshot by way of an attachment (you'll need to click on it) of something that might be worthy of addressing before you release this as a finished product. 

On the right side of the screen in Planetary mode, there is a reference to BackyardEOS in BackyardNIKON, and there's also several references to EOS in a few screens within the  'Settings' dialog that pops up. 

I've also highlighted a small UI change that might be worth addressing. The "Connect" thumbnail at the top illustrates a Canon. I am thinking it might be wise to have a Nikon depicted there! :) 

I should report that I have had no issues thus far with the latest BETA version, and I have managed to capture quite a bit of data with it.

 

Thanks Steve, I'll look and the them.

 

 

Link to comment
Share on other sites

The program starts Nikon drivers initialized attemting to

connect to camera....

Camera Not Found!

 

My camera is D7000, I have tried several times with different

USB-cables restarted my computer but no success...

Log file:

 

2014-06-22 20:39:47,958 [1] INFO  - BinaryRivers Dependencies Registration.
2014-06-22 20:39:48,255 [1] INFO  - Registration of BackyardEOS.ASCOM.Platform55 Implementations
2014-06-22 20:39:48,255 [1] INFO  - ASCOM platform version 5.5 not found.
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers.ASCOM.Platform60 Implementations
2014-06-22 20:39:48,255 [1] INFO  - ASCOM platform version 6.0 not found.
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers IAutofocusProvider Implementations
2014-06-22 20:39:48,255 [1] INFO  - --> BinaryRivers.IAutofocusProvider.Beginner was registered
2014-06-22 20:39:48,255 [1] INFO  - --> BinaryRivers.IAutofocusProvider.Advance was registered
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers IAviEncoder Implementations
2014-06-22 20:39:48,255 [1] INFO  - --> ByteScout was registered
2014-06-22 20:39:48,255 [1] INFO  - --> VirtualDub was registered
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers IBackgroundTask Implementations
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers ICableProvider Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> DSUSB
2014-06-22 20:39:48,270 [1] INFO  - --> DSUSB2
2014-06-22 20:39:48,270 [1] INFO  - --> COM1
2014-06-22 20:39:48,270 [1] INFO  - --> COM2
2014-06-22 20:39:48,270 [1] INFO  - --> COM3
2014-06-22 20:39:48,270 [1] INFO  - --> COM4
2014-06-22 20:39:48,270 [1] INFO  - --> COM5
2014-06-22 20:39:48,270 [1] INFO  - --> COM6
2014-06-22 20:39:48,270 [1] INFO  - --> COM7
2014-06-22 20:39:48,270 [1] INFO  - --> COM8
2014-06-22 20:39:48,270 [1] INFO  - --> COM9
2014-06-22 20:39:48,270 [1] INFO  - --> COM10
2014-06-22 20:39:48,270 [1] INFO  - --> COM11
2014-06-22 20:39:48,270 [1] INFO  - --> COM12
2014-06-22 20:39:48,270 [1] INFO  - Registration of Nikon Camera Controller Classes
2014-06-22 20:39:48,270 [1] INFO  - Nikon Camera Controller was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of BackyardEOS Simulator Camera Controller Classes
2014-06-22 20:39:48,270 [1] INFO  - Simulator Camera Controller was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of Image Loader Classes
2014-06-22 20:39:48,270 [1] INFO  - --> [CameraRawImageProvider] image loader provider was registered
2014-06-22 20:39:48,270 [1] INFO  - --> [JpgProvider] image loader provider was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of BinaryRivers.ISkinPlus Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> Red (default)
2014-06-22 20:39:48,270 [1] INFO  - --> White
2014-06-22 20:39:48,270 [1] INFO  - --> Green
2014-06-22 20:39:48,270 [1] INFO  - --> Aquamarine
2014-06-22 20:39:48,270 [1] INFO  - --> Silver
2014-06-22 20:39:48,270 [1] INFO  - --> Khaki
2014-06-22 20:39:48,270 [1] INFO  - --> LightSteelBlue
2014-06-22 20:39:48,270 [1] INFO  - --> Yellow
2014-06-22 20:39:48,270 [1] INFO  - --> LightPink
2014-06-22 20:39:48,270 [1] INFO  - --> Pink
2014-06-22 20:39:48,270 [1] INFO  - Registration of BinaryRivers IDitherProvider Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> PHD
2014-06-22 20:39:48,270 [1] INFO  - Registration of Focus Metric Algorithm Classes
2014-06-22 20:39:48,270 [1] INFO  - --> Full Width Half Maximum was registered
2014-06-22 20:39:48,270 [1] INFO  - --> Half Flux Diameter was registered
2014-06-22 20:39:48,270 [1] INFO  - --> Standard Deviation was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of Image Converter Classes
2014-06-22 20:39:48,270 [1] INFO  - --> ConvertToTIFF was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of BinaryRivers IWeatherProvider Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> TEMPerHUMv1
2014-06-22 20:39:48,270 [1] INFO  - --> TEMPerHUMv2
2014-06-22 20:39:48,270 [1] INFO  - --> TextFile
2014-06-22 20:39:48,270 [1] INFO  - --> Yahoo
2014-06-22 20:39:48,286 [backgroundWorker(Normal)] INFO  - Background Worker Server 96fc056e-1bc0-4c1b-a740-5f19fb27c2d1 Normal is running.
2014-06-22 20:39:48,317 [setting] INFO  - ==================================================
2014-06-22 20:39:48,317 [setting] INFO  - Setting START!
2014-06-22 20:39:48,317 [setting] INFO  - Setting total execution time 0,000 seconds.
2014-06-22 20:39:48,317 [setting] INFO  - --------------------------------------------------
2014-06-22 20:39:48,317 [Queue] INFO  - BackyardTEMP = C:\Users\Goran\Pictures\BackyardTEMP
2014-06-22 20:39:48,333 [ReadWeather] INFO  - ==================================================
2014-06-22 20:39:48,333 [ReadWeather] INFO  - ReadWeather START!
2014-06-22 20:39:48,364 [ReadWeather] DEBUG - No weather provider configured.
2014-06-22 20:39:48,364 [ReadWeather] INFO  - ReadWeather total execution time 0,031 seconds.
2014-06-22 20:39:48,364 [ReadWeather] INFO  - --------------------------------------------------
2014-06-22 20:39:53,331 [backgroundWorker(Normal)] INFO  - Background Worker Server Normal is waiting for a command to process...
 
Link to comment
Share on other sites

The program starts Nikon drivers initialized attemting to

connect to camera....

Camera Not Found!

 

My camera is D7000, I have tried several times with different

USB-cables restarted my computer but no success...

Log file:

 

2014-06-22 20:39:47,958 [1] INFO  - BinaryRivers Dependencies Registration.
2014-06-22 20:39:48,255 [1] INFO  - Registration of BackyardEOS.ASCOM.Platform55 Implementations
2014-06-22 20:39:48,255 [1] INFO  - ASCOM platform version 5.5 not found.
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers.ASCOM.Platform60 Implementations
2014-06-22 20:39:48,255 [1] INFO  - ASCOM platform version 6.0 not found.
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers IAutofocusProvider Implementations
2014-06-22 20:39:48,255 [1] INFO  - --> BinaryRivers.IAutofocusProvider.Beginner was registered
2014-06-22 20:39:48,255 [1] INFO  - --> BinaryRivers.IAutofocusProvider.Advance was registered
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers IAviEncoder Implementations
2014-06-22 20:39:48,255 [1] INFO  - --> ByteScout was registered
2014-06-22 20:39:48,255 [1] INFO  - --> VirtualDub was registered
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers IBackgroundTask Implementations
2014-06-22 20:39:48,255 [1] INFO  - Registration of BinaryRivers ICableProvider Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> DSUSB
2014-06-22 20:39:48,270 [1] INFO  - --> DSUSB2
2014-06-22 20:39:48,270 [1] INFO  - --> COM1
2014-06-22 20:39:48,270 [1] INFO  - --> COM2
2014-06-22 20:39:48,270 [1] INFO  - --> COM3
2014-06-22 20:39:48,270 [1] INFO  - --> COM4
2014-06-22 20:39:48,270 [1] INFO  - --> COM5
2014-06-22 20:39:48,270 [1] INFO  - --> COM6
2014-06-22 20:39:48,270 [1] INFO  - --> COM7
2014-06-22 20:39:48,270 [1] INFO  - --> COM8
2014-06-22 20:39:48,270 [1] INFO  - --> COM9
2014-06-22 20:39:48,270 [1] INFO  - --> COM10
2014-06-22 20:39:48,270 [1] INFO  - --> COM11
2014-06-22 20:39:48,270 [1] INFO  - --> COM12
2014-06-22 20:39:48,270 [1] INFO  - Registration of Nikon Camera Controller Classes
2014-06-22 20:39:48,270 [1] INFO  - Nikon Camera Controller was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of BackyardEOS Simulator Camera Controller Classes
2014-06-22 20:39:48,270 [1] INFO  - Simulator Camera Controller was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of Image Loader Classes
2014-06-22 20:39:48,270 [1] INFO  - --> [CameraRawImageProvider] image loader provider was registered
2014-06-22 20:39:48,270 [1] INFO  - --> [JpgProvider] image loader provider was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of BinaryRivers.ISkinPlus Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> Red (default)
2014-06-22 20:39:48,270 [1] INFO  - --> White
2014-06-22 20:39:48,270 [1] INFO  - --> Green
2014-06-22 20:39:48,270 [1] INFO  - --> Aquamarine
2014-06-22 20:39:48,270 [1] INFO  - --> Silver
2014-06-22 20:39:48,270 [1] INFO  - --> Khaki
2014-06-22 20:39:48,270 [1] INFO  - --> LightSteelBlue
2014-06-22 20:39:48,270 [1] INFO  - --> Yellow
2014-06-22 20:39:48,270 [1] INFO  - --> LightPink
2014-06-22 20:39:48,270 [1] INFO  - --> Pink
2014-06-22 20:39:48,270 [1] INFO  - Registration of BinaryRivers IDitherProvider Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> PHD
2014-06-22 20:39:48,270 [1] INFO  - Registration of Focus Metric Algorithm Classes
2014-06-22 20:39:48,270 [1] INFO  - --> Full Width Half Maximum was registered
2014-06-22 20:39:48,270 [1] INFO  - --> Half Flux Diameter was registered
2014-06-22 20:39:48,270 [1] INFO  - --> Standard Deviation was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of Image Converter Classes
2014-06-22 20:39:48,270 [1] INFO  - --> ConvertToTIFF was registered
2014-06-22 20:39:48,270 [1] INFO  - Registration of BinaryRivers IWeatherProvider Implementations
2014-06-22 20:39:48,270 [1] INFO  - --> TEMPerHUMv1
2014-06-22 20:39:48,270 [1] INFO  - --> TEMPerHUMv2
2014-06-22 20:39:48,270 [1] INFO  - --> TextFile
2014-06-22 20:39:48,270 [1] INFO  - --> Yahoo
2014-06-22 20:39:48,286 [backgroundWorker(Normal)] INFO  - Background Worker Server 96fc056e-1bc0-4c1b-a740-5f19fb27c2d1 Normal is running.
2014-06-22 20:39:48,317 [setting] INFO  - ==================================================
2014-06-22 20:39:48,317 [setting] INFO  - Setting START!
2014-06-22 20:39:48,317 [setting] INFO  - Setting total execution time 0,000 seconds.
2014-06-22 20:39:48,317 [setting] INFO  - --------------------------------------------------
2014-06-22 20:39:48,317 [Queue] INFO  - BackyardTEMP = C:\Users\Goran\Pictures\BackyardTEMP
2014-06-22 20:39:48,333 [ReadWeather] INFO  - ==================================================
2014-06-22 20:39:48,333 [ReadWeather] INFO  - ReadWeather START!
2014-06-22 20:39:48,364 [ReadWeather] DEBUG - No weather provider configured.
2014-06-22 20:39:48,364 [ReadWeather] INFO  - ReadWeather total execution time 0,031 seconds.
2014-06-22 20:39:48,364 [ReadWeather] INFO  - --------------------------------------------------
2014-06-22 20:39:53,331 [backgroundWorker(Normal)] INFO  - Background Worker Server Normal is waiting for a command to process...
 

 

Reboot your computer and try again.  If BackyardNIKON says camera not found it means your computer is not seeing the camera.

 

Also, you should remove your SD and see if it works without.

 

 

 

 

Link to comment
Share on other sites

Hi,

 

The problem on D800 seems even larger in beta 02.

Previously Bulb is fine, but it doesn't take multiple Bulbs in beta 01c and 01d.

(D610 seems to have this problem too.)

Now in beta 02, even just taking one bulb is not possible.

 

The logs are attached.

 

Cheers,

Wei-Hao

 

Thanks Wei-Hao.

 

I have not addressed any bulb issues for the D610 and D800 in BETA 02...  In fact there is no difference between BETA 01d and BETA 02 for these models.  Which has me wonder why you get to different behavior <_>

 

Regards,

 

 

Link to comment
Share on other sites

Hi Guylain,

I tested the BETA 02 on my D5100 last night and ran into one issue - once an exposure is completed (regardless of exposure length), the image goes into a processing "queue" and for the image to be downloaded and displayed from the queue it takes almost a full minute. During this time my processor utilization is at 100%. I use an old netbook for image capture and this might be part of the problem, but I never had performance issues with BYE (in fact I dont think BYE even has a queing feature). Is there any option I can turn off to make this go faster? Yesterday, it took more than 10 mins to capture 20 bias frames. 

 

Thanks.

Link to comment
Share on other sites

Hi Guylain,

I tested the BETA 02 on my D5100 last night and ran into one issue - once an exposure is completed (regardless of exposure length), the image goes into a processing "queue" and for the image to be downloaded and displayed from the queue it takes almost a full minute. During this time my processor utilization is at 100%. I use an old netbook for image capture and this might be part of the problem, but I never had performance issues with BYE (in fact I dont think BYE even has a queing feature). Is there any option I can turn off to make this go faster? Yesterday, it took more than 10 mins to capture 20 bias frames. 

 

Thanks.

 

Would you happen to have AVG anti-virus or McAfee BTW?

 

This looks like the anti-virus software acting up.  Disable your antivirus and try again to confirm (or not) that this issue is your antivirus software.

 

Regards,

 

 

Link to comment
Share on other sites

Hi Guylain,

I don't have any anti-virus software installed on this netbook. No firewall active either. Let me know if you want me to send you the logs. 

 

 

Yes, send me the logs at support@binaryrivers.com or post them here.

 

Regards,

Link to comment
Share on other sites

I had an issue installing it at first, but I uninstalled 01b and tht solved the problem, but when I started it, it said that I only have 10 days left until the license expires. Any ideas?

 

I package each BETA with a 30-day license.  I'll update the BETA download before it expires :)

 

Regards,

Link to comment
Share on other sites

Hi,

Here are the logs from last evening. Let me know if there is a specific action you'd like me to execute and capture a log. Thanks for looking into this.

 

 

Okay, so I have looked at your log files and now know what is happening :)

 

1) The 100% utilization is not a major issue because it is the background worker process that was using it... and it runs in a very low priority thread... meaning that if your computers needs more power it will take it.  This is okay.

 

2) The 100% utilization is caused by reading the enormous .NEF file.  This takes about 28 seconds on average on your computer according to the log files.  I'm using GdPicture, a commercial library, to read the NEF files.  It is a bit slow, okay very slow, on your computer for sure.  In comparison it takes about 4 seconds on my computer.

 

This is typically not an issue doing long exposure photography because we take pictures > 60 seconds 99% of the time.  Which means all that work is done in a very low priority thread while the UI is running in a normal/high priority thread taking the next picture.

 

I see you have selected NEF only image format.  If you select NEF + JPG you will get the impression that things are going much, much faster.  This is because when a JPG is taken I actually load the JPG immediately after download and display it right then and now... then I send the NEF file to the background worker to process it.

 

To confirm this, take a preview picture (which is JPG only) and notice how faster it is.  The same can be said for snapping a picture in Frame&Focus.

 

I will continue to look at GdPicture to see if there is a parameter somewhere that I can use to make it faster.  But like I said, it's all done in a low priority background thread and if you take NEF + JPG images you will get the illusion that everything is much faster.

 

Does this make sense?

 

 

EDIT: I see you have a dual core computer.  To mitigate the 100% CPU utilization a little bit, you can go to Settings -> Advance Settings and enable the "Processor Affinity" option, then restart BYE.  This will instruct BYE user interface to run on a single CPU core and force the the Background Worker Process to run on another CPU core.

 

 

Link to comment
Share on other sites

Hi Guylain,

Thanks, yes, that makes sense. Like you said this is not an issue when one is shooting lights or darks - I only found out about this when I was shooting bias frames and that too when the queue reached 3 and the program does not proceed with the next exposure until one of the files is processed. 

 

I guess one solution would be for me to upgrade my netbook :). Or I could use a different program to acquire bias frames, since I have not seen this behavior elsewhere. But thanks for the detailed explanation, I will try the processor affinity option. 

Link to comment
Share on other sites

Hi Guylain,

Thanks, yes, that makes sense. Like you said this is not an issue when one is shooting lights or darks - I only found out about this when I was shooting bias frames and that too when the queue reached 3 and the program does not proceed with the next exposure until one of the files is processed. 

 

I guess one solution would be for me to upgrade my netbook :). Or I could use a different program to acquire bias frames, since I have not seen this behavior elsewhere. But thanks for the detailed explanation, I will try the processor affinity option. 

 

Hi there,

 

BackyardNIKON should absolutely proceed to the next exposure regardless of how many images are in the queue... if not this is a bug.

 

Can you please confirm that that is the case, or not?  With and without processor affinity.  Remember that you must restart BYN when you change the processor affinity setting for it to take effect.

 

Regards,

Link to comment
Share on other sites

1) The 100% utilization is not a major issue because it is the background worker process that was using it... and it runs in a very low priority thread... meaning that if your computers needs more power it will take it.  This is okay.

 

Just to let you know that I'm running some intensive test here tonight and I'm getting the same thing on 1 computer only.  I'll try to see what is causing the 100% CPU usage and fix it.

 

Thank you,

Link to comment
Share on other sites

Hi Guylain,

Sorry for the delay in updating. I ran the test again and you are correct - the queue keeps going and does not max out at 3. Not sure why I saw that happen the first time. 

 

Thanks for taking a look at the 100% utilization issue, I'm sure it will be helpful for many users. But for me, I ordered a beefier laptop a few days ago. :)

Link to comment
Share on other sites

Everything worked well with my D5100 last night. The one issue I had was taking Flats using Av mode. I selected Av as the exposure time in BackyardNik and turned the dial on my camera to Av mode but when I tried to start the capture I get the following error. Not sure if it is the software or a setting in the camera maybe.

 

2014-06-20 07:23:00,409 [CameraTakePictureOnMessageRecieved] INFO  - CameraPropertyChangedArgs fired: Av                   = '--'
2014-06-20 07:23:00,419 [CameraTakePictureOnMessageRecieved] DEBUG - TAKE PICUTRE ::: Shutter(AV) Av(--) Duration(1.0) Iso(100) Quality(JPEG Fine) Mirror(0) SaveTo(PC)
2014-06-20 07:23:02,690 [CameraTakePictureOnMessageRecieved] DEBUG - Device Busy trying to start picture sequence
2014-06-20 07:23:02,853 [CameraTakePictureOnMessageRecieved] ERROR - [kNkMAIDResult_DeviceBusy] (kNkMAIDCommand_CapStart, 17, kNkMAIDDataType_Null, 0)
2014-06-20 07:23:02,853 [CameraTakePictureOnMessageRecieved] ERROR -    at BinaryRivers.Camera.Nikon.Wrapper.NikonTaskQueue.Invoke(Delegate d, Object[] args)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonBase.Start(eNkMAIDCapability cap, eNkMAIDDataType dataType, Int32 data)
   at BinaryRivers.Camera.Nikon.CameraModel.<>c__DisplayClasse.<DoTakePicture>b__d()
   at BinaryRivers.Common.ProviderInterfaces.Camera.CameraControllerBase.DoWithCameraLocked(Action action)
   at BinaryRivers.Camera.Nikon.CameraModel.DoTakePicture(Single mirrorLockSeconds)
   at BinaryRivers.Common.Model.CameraModelBase.TakePicture(Single mirrorlockseconds, String progresstext)
   at BinaryRivers.Common.Model.CameraModelBase.<>c__DisplayClass1.<CameraTakePictureOnMessageRecieved>b__0()
2014-06-20 07:23:02,856 [CameraTakePictureOnMessageRecieved] INFO  - Imaging session cancelled
2014-06-20 07:23:02,863 [CameraTakePictureOnMessageRecieved] INFO  - [kNkMAIDResult_DeviceBusy] (kNkMAIDCommand_CapStart, 17, kNkMAIDDataType_Null, 0)
2014-06-20 07:23:02,863 [CameraTakePictureOnMessageRecieved] ERROR - [kNkMAIDResult_DeviceBusy] (kNkMAIDCommand_CapStart, 17, kNkMAIDDataType_Null, 0)
2014-06-20 07:23:02,864 [CameraTakePictureOnMessageRecieved] ERROR -    at BinaryRivers.Camera.Nikon.Wrapper.NikonTaskQueue.Invoke(Delegate d, Object[] args)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonBase.Start(eNkMAIDCapability cap, eNkMAIDDataType dataType, Int32 data)
   at BinaryRivers.Camera.Nikon.CameraModel.<>c__DisplayClasse.<DoTakePicture>b__d()
   at BinaryRivers.Common.ProviderInterfaces.Camera.CameraControllerBase.DoWithCameraLocked(Action action)
   at BinaryRivers.Camera.Nikon.CameraModel.DoTakePicture(Single mirrorLockSeconds)
   at BinaryRivers.Common.Model.CameraModelBase.TakePicture(Single mirrorlockseconds, String progresstext)
   at BinaryRivers.Common.Model.CameraModelBase.<>c__DisplayClass1.<CameraTakePictureOnMessageRecieved>b__0()
Link to comment
Share on other sites

Everything worked well with my D5100 last night. The one issue I had was taking Flats using Av mode. I selected Av as the exposure time in BackyardNik and turned the dial on my camera to Av mode but when I tried to start the capture I get the following error. Not sure if it is the software or a setting in the camera maybe.

 

You need to leave the dial to "M" always on Nikons... they can not to tethered shooting in any other dial mode.

 

Av and TV are achievable in M mode.

 

Hope this helps,

 

 

Link to comment
Share on other sites

Ok thanks Guylain. I had a feeling it was something like that since even if I tried pushing the shutter release on the camera itself it wouldn't go.

 

Forgot I had one more issue. The default in the settings to talk to PHD is "localhost:4300" I had to change it to just "localhost" like BYE has and then it could talk to PHD and dither properly.

 

 

On a nontechnical note here is 30x300sec on M51 I got last night. No darks used just flats/bias. Thanks a lot for getting this software working because the sensor in the D5100 seems to be just plain amazing noise wise

 

[zemf5iT] 

Link to comment
Share on other sites

Everything worked well with my D5100 last night. The one issue I had was taking Flats using Av mode. I selected Av as the exposure time in BackyardNik and turned the dial on my camera to Av mode but when I tried to start the capture I get the following error. Not sure if it is the software or a setting in the camera maybe.

 

You need to leave the dial to "M" always on Nikons... they can not to tethered shooting in any other dial mode.

 

Av and TV are achievable in M mode.

 

Hope this helps,

 

 

How can you do Av? When I set the Dial to M and select AV under Shutter I get "Make sure camera is set to AV, turn dial to 'AV'"

Link to comment
Share on other sites

How can you do Av? When I set the Dial to M and select AV under Shutter I get "Make sure camera is set to AV, turn dial to 'AV'"

 

Oh... I need to take a look at that.  It's is bug.  Both AV and TV should be possible in M dial mode.

 

Thanks for reporting it.

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use