Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
Sign in to follow this  
RayM0506

Canon EOS Rebel T7

Question

Hi there,
 
I've used your software for years but have taken a break from astrophotography for a few years.  Did the free upgrade to your latest version.  I have a newer camera.  I DID reinstall the latest version of the software.  Here is how it is listed in the software:
 
19:47:38  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T7
19:47:38  DEVICEINFO NUMBER IS 3470492101.
19:47:38  YOUR *REAL* MODEL NUMBER IS 4294967294(FFFFFFFE)
19:47:38  Generic model 153 assumed!
19:47:43  Attempting to connect camera...
19:47:43  Canon drivers 'Canon\' initialized.
19:47:45  1200D-T7 CONNECTED!
19:47:46  EdsInitializeSDK() ERROR!
 
As you can see it connects then disconnects due to the error on the last line.  Tried a new usb chord but got the same results.  Can you give me ANY help with this?  I absolutely love your software and want to continue using it.  ANY help is appreciated. 
 
Thank you.
Ray Morris

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Ray,

By "the latest", I assume you mean 3.1.18. This is important since versions of BYE that were released before the camera was supported in Canon's SDK will not be supported by BYE.

There are two banner lines at the top of this page. One asks you to always include the Camera model and version number of BYE with each new question or issue. The second banner line asks you to re-install BYE if you get the EDSInitializeSDK error, which you can see is in the last line of the reported log entries.

Please re-install 3.1.18. If that doesn't work, please install version 3.2.0 Release Candidate from the Pre-releases menu at the right of the Downloads page

Share this post


Link to post
Share on other sites
  • 0
On ‎7‎/‎26‎/‎2020 at 3:16 PM, astroman133 said:

Ray,

By "the latest", I assume you mean 3.1.18. This is important since versions of BYE that were released before the camera was supported in Canon's SDK will not be supported by BYE.

There are two banner lines at the top of this page. One asks you to always include the Camera model and version number of BYE with each new question or issue. The second banner line asks you to re-install BYE if you get the EDSInitializeSDK error, which you can see is in the last line of the reported log entries.

Please re-install 3.1.18. If that doesn't work, please install version 3.2.0 Release Candidate from the Pre-releases menu at the right of the Downloads page

Thank you SO Much!  It works great now.  3.2 that is.  Will I have to re-purchase this now?  If so How much when it is released?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use