Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

The Canon 600d doesn't ,but the 450d does !



I've spent a week now trying to get my Canon 600d to work with backyard.  I've tried the classic version and the 3.1.3 version.  I was hoping to solve this problem and so help others with a

problematic 600d. 


I have two old Dell Latitude 610's, running XP, SP3,  and have and tried both. 

Also tried a W8 laptop.


I've tried with battery and with power pack adaptor.  I've tried various USB leads (up to 2M long),

the latest a Belkin Pro.


BUT the 600d continues to play up, in spite it being new.

It's very erratic and unpredictable, although the 600d works OK with an Intervalometer.


Most times the camera is either not recognised, or if it is, it will not download images. It goes through the imaging section then freezes at DOWNLOAD,


 At other times backyard displays without the 3 bottom right buttons showing !  (Capture, Loop, Preview).   Sometimes even the actual laptop doesn't show the 600d !!


NOW for the good news........ I also have a Canon 450d, not new, but it works OK

 on both laptops with backyard without any problems at all and is now installed on my rig.


If anyone else has a 600d and it runs OK I would be interested to hear what it is running on etc.


Finally, I consider that backyard is the very best imaging app for the DSLR on the market.......

So well laid out, ergonomically sound as one might say.

Link to comment
Share on other sites

  • Answers 19
  • Created
  • Last Reply

19 answers to this question

Recommended Posts

Well guys, I've had enough of frigging with the 600d for present as last night the 450d worked a treat. So I am not going to disturb it and its wiring just in case something else goes amiss !


By the way, the same USB leads were used on both cameras during testing. I don't have Canon EOS.


I didn't mention that the 600d Does work on a very short lead ( 1/4 metre) but that's not long enough for my rig

which requires 2M. (My rig is bolted to a south facing wall of the house and is controlled from inside, the wiring going through the house wall !)


It would seem that my 600d just doesn't like long leads. As I said, even the laptop itself doesn't always recognise the 600d but always the 450d.


Anyway, thanks for your input.

Link to comment
Share on other sites

Does Windows recognize that the 600D is connected?  If Windows doesn't see the camera then the driver will not be installed and neither BYE nor the EOS Utility will be able to connect to it.


If Windows does recognize the camera then you can download the EOS Utility from the Canon web site.  Just look for software for your model of camera and Windows version.


Given your setup and what you have tried, it may be that the camera's USB connect is somehow broken.


I am glad that you have the 450D.


Rick B

Link to comment
Share on other sites

Oh, I just thought of something else.... are you selecting DIGIC II or DIGIC 3/4/5/6 when connecting the camera?


The 600D should only work with DIGIC 3/4/5/6 while the 450D will work with both.


Keep us posted,




Link to comment
Share on other sites

Yes I've tried both DIGITs. That was one of the very first things I tried.


It cannot be the 600d internal connector faulty as it works OK on a SHORT USB lead. (about 1/4 metre).

Anyway the camera is new so that is unlikely I would think.


It only gets flaky when the USB lead is 2M long, which the 450d works with OK.


As I said, I've had enough struggling with the 600 and now and wish to spend my time doing some

imaging instead with the 450. :-)


I would like to hear though, if anyone out there uses a 600d without any problems.


Thanks again guys.

Link to comment
Share on other sites

There are quite a number of BYE Users who successfully use the 600D (T3i).  It is probably the currently most popular Canon DSLR for Modding, given it's Price and Features...


The following assertion is rather suspect:


It cannot be the 600d internal connector faulty as it works OK on a SHORT USB lead. (about 1/4 metre).

Anyway the camera is new so that is unlikely I would think.

The USB Connectors require Both the Socket and the Cable to be in equally Good Condition in order to work well together.  And the Electronics driving the USB needs to be Properly Tuned in order Drive the Signal along a Longer Length. Of course, it could also be the 2M USB Cord or even the USB Port on the Laptop...

Link to comment
Share on other sites

Here's is my solution at last, although I don't understand why it works........


Neither of the Dell laptops ( XP) would work reliably with the 600d with any type/length of USB leads.


I got myself a small Samsung NC10 (XP too)  and the 600d runs well on it with any of my USB leads. :)


So problem solved in this work around.  Something about the Dell's that the 600d didn't like I guess.

Link to comment
Share on other sites

Why oh why would you run XP?

Many folks in Amateur Astronomy have Older Equipment within their Rigs - Equipment for which the Drivers weren't made available with Win7 / 64-bit Updates.  Others have Software which uses the older style of Win16/Win32 Drivers and Executables which aren't supported by any version of Windows beyond XP.  And then, there are those who have become Comfortable with the WinXP GUI, and aren't that Eager to need to Learn the few Win7 Changes...

Link to comment
Share on other sites

Well as a (hobby) developer of software (audio related, not astro) I recently gave up on keeping any XP systems alive and stopped worrying about supporting them, and I would imagine that as time goes on fewer and fewer programs will support XP (although they may still work).


I "live" in windows 7 (laptops) and windows 8.1 (made to act like windows 7) on my main desktop at home. I also have a mac mini, for OSX porting. but don't boot it up very often.


My personal experience with XP is probably colored by the slow boot up speed on laptops with slow hard disks. At work when we went to windows 7 we also switched to SSDs in the laptops and difference was like night and day (XP on 5400rpm drives vs. Win 7 on SSDs).


Anyway, sorry for the thread jack but it just seemed like sticking to XP is only going to cause increasing trouble, as time goes on.

Link to comment
Share on other sites

I hate W8. That charm pop up on the RH side just drives me nuts.

XP is just charming in its simplicity without any damn charms. :)

Windows 8 (well, 8.1) is here to stay.  And it has numerous improved elements "under the skin" which are important or even CRITICAL for today's Hardware...


The Good News is that Microsoft learned several lessons from Win Vista, including the need to allow users more abilities to customize their Configurations.


First, do yourself a favor and perform the "Win8 to Win8.1 Update" downloadable from the Windows Store.


If you dislike the Charms, then search Google for any of the many Instructions and Videos for "Disable Win8 Charms".

If you dislike the Metro Start Screen, then Google for "Win8.1 Start Menu".

If there are other Features or Elements that you dislike, chances are you can find alternatives via Google, too...




You announced that you now have your 600D working with BYE!!  Let us know how you like it - the new DSLR and the integration with BYE!!

Link to comment
Share on other sites


You announced that you now have your 600D working with BYE!!  Let us know how you like it - the new DSLR and the integration with BYE!!


Works well now. Excellent BYE layout on the screen.

 It does every thing that it says on the tin.......and on the box too.


My only problem at present is getting stars to show up when trying to focus in the older Classic version I am using.

 I must try the contrast slider and have to learn all about BYE's bells and whistles I guess.


BYE for now. :)

Link to comment
Share on other sites

The version of BYE older or newer, Classic or Premium should not impact the ability to use LiveView for Frame & Focus. 


The LiveView frame rate is probably around 20 frames per second.  This means that the true exposure (less than 1/20th of a second) is very short and only very brightest stars in the sky will be visible.  My recommendation is to point at the brightest star that you can see (Arcturus??), use manual techniques to get close to focus, then connect with BYE.  To make the star as bright as possible on the screen, either select the Maximum Sensitivity setting on the Settings dialog or change the LiveView exposure to 2 seconds (2") and crank up the ISO to its maximum value.  You should then be able to just barely see the star in the field.  If you think that the star should be there but you cannot see it, then you should try taking a short 1-2 second Snap picture.  That should show you where the star is (or isn't) in the field.

Link to comment
Share on other sites

If the 450D works and the 600D does not... and you are using it on the same computer with same cable and same version of BackyardEOS then it would appear the there might be something wrong with the actual USB connection on the 600D, this is just a guess though :(


Your best -test- would be to use your 600D with EOS Utility and see if you still have erratic connection issues.  If yes this would confirm the 600D being faulty, or something in the connection chain :(


Keep me posted on the EOS Utility test.



Link to comment
Share on other sites

It seems to me that your issue is caused by one of 2 things. 


1) an Internal issue with the 600D, like a faulty USB socket.

2) the USB cable that is used to connect the camera to the PC


The overwhelming cause of flaky communications is the USB cable.  It was not clear to me whether you tested the 600D with the same USB cable as the 450D, but I would try that.  I would also use as short a cable as possible. The USB 2.0 standard allows a maximum cable length of 5 meters.  However, not all cables will work at that length and some work at longer lengths.  Getting a good cabling solution seems to be a trial and error process for many people.


While it is unlikely that your issue is due to an issue with BYE, it also makes sense to test the camera with Canon's EOS Utility.  This would definitively eliminate BYE as a cause.


Rick B

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use