Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

What's the general consensus on USB hubs/ideal Windows OS?


ixobelle
 Share

Question

I'm having a very hard time keeping my D700 and Celestron 8SE both connected for more than a few "operations" (skew once or twice, take a sample photo). In an effort to simplify things, I broke out an old Dell Precision M4800 laptop I had, which has 4 physical USB ports, but I've worked in IT long enough to know that even "4 external facing ports" doesn't mean it's not using a hub system internally, it depends completely on the chipset. Device Manager clearly shows USB root hubs.

Ideally, I'd like to have everything on the mount (Handset, Focuser, Camera USB, and eventual Camera Serial USB for Bulb) popping into a 4 port hub, then a single cord going to the laptop, so I'd just like to ask for the record if this is a known "bad idea".

I'm running a brand new install of Windows 10 21H1, and still seem to have issues. Have tried swapping cables, not using a hub, testing with other software (Nikon's own Camera Control Pro 2 works fine), but it's really hit or miss as to wether it will work, and when it does see everything, I'm just holding my breath until it fails. 

The USB cable to the camera has been traded many times, and while there *is* a tiny bit of play, it's not a bad connection (again, worked in IT for 15+ years, I know a bad connection when I feel one, plus windows is not seeing the camera 'come and go' and Nikon's software works fine). Mini USB isn't exactly DVI-D with big screws on either side.

Ignoring the camera, even basic Telescope operations (while more consistent than camera) seem to fail. I had tried on this Precision running Windows 10, an older XPS 15 (9650) running Win11, and the newest XPS 15 model Dell sells (unsure of model number, but can dig if needed) on Win10.

I'm also happy to wipe and install Windows 7 (XP? whatever!) if it will help...?

 

Link to comment
Share on other sites

  • Answers 5
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

5 answers to this question

Recommended Posts

  • 0

I have a USB hub and a 12V power distribution system on my scope and run a single 12V power cable and a single USB hub off the mount. I don't have any issues, but I use either a Canon camera or a dedicated astro CCD camera.

The Nikon SDK is managing the connection between the PC and the camera and it is sensitive to momentary glitches. So BYN is not causing or contributing to your issue. Nikon manuals say to NOT use a hub to connect the camera to a PC, but the nature of astrophotography is that many users probably do.

I would not back rev the O/S. BYN and BYE work for lots of folks on Windows 8-11, so I would NOT suggest re-installing BYN.

I would suggest doing a factory reset on the camera to eliminate an errant camera setting. You might also consider whether there are any firmware updates to the camera. If you are using the latest BYN then you are also using the latest Nikon SDK as of when BYN was released. Sometimes Nikon makes breaking changes to their firmware that require the use of a newer version of the SDK than what may have been installed on the camera.

Communications is typically a big problem. It could be the PC connection, the cable, or the camera end. I would also disable or turn off Windows/hardware power management on the PC to ensure that it is not shutting anything down (like disk drive or USB hub) and only run the PC off of A/C power.

I would simplify your setup by using a short cable that is known to be good and connecting only the camera to the PC; no other astro hardware. If it still doesn't work reliably I would try a different port on the PC. Ports on opposite sides often use different internal hubs. If that doesn't work I would replace the cable. Finally I would try a different camera or a different PC. Basically you are changing one piece at a time to try to see what affects the operation.

If you are having a problem connecting ASCOM client applications like BYN to your mount, I would suggest contacting the author of the driver for assistance. This is because communication between driver and controller are managed by the driver.

I hope this helps.

Link to comment
Share on other sites

  • 0

Thanks for the thoughtful response. Digging deeper I am seeing even native ASCOM issues, so this is clearly not BYN's fault. I'll do a deep dive and report back with what finally solved it. Thanks again.

Link to comment
Share on other sites

  • 0

Posting back with some promising results. After googling around a bit, I saw mention that ASCOM and apps like these generally are very picky about moving the ports the device is initially seen on, and the cables themselves are very picky as well. I have a giant bin of cables out in the garage, and figured with the six or so USB mini cables I had, that a few would work, but I seem to have one really good one that works for both telescope and camera consistently, and a bunch of others that are pretty low grade. USB-Mini kind of came and went, so some of these are pretty old.

 

My findings, for anyone coming across this thread in the future:

 

Plugging one of these devices into a specific port then moving it may be causing problems. Go into Device Manager, and check View > Show Hidden Devices. Then open up Ports (COM & LPT) and you'll see some greyed out COM3, COM4 ports, etc. Do the same for Portable Devices, with the D700 (or your camera model). Right click and uninstall all of these (do not uninstall the driver itself in the subsequent dialog):

SCu84ji.png

 

...then plug the device in to a specific USB port and look for it to reappear. Now, with Hidden Devices shown, you should have only ONE of each device (your handset/telescope and camera). My handset reinstalled, but had the little yellow triangle next to it showing it installed but failed. Right click > Disable Device, then Right click > Enable Device to kick it once, and the triangle should be gone. You can go into the device and see what COM port it took, make note of it, and also what physical USB port you used. Try and keep this consistent. I haven't gone to a hub yet, will try that once I confirm everything is working without one, but this should still apply. You don't want "ghost copies" of the devices claiming COM ports, etc. If you need to change the COM port for whatever reason, do that here (Right click device, check properties):

G5yU2Ko.png

Use that same COM port in BYN:

rLX1o1Y.png

 

Once I cleaned up these orphaned devices, and nailed down a specific COM port (and used the One Good Cable), the telescope remained connected.

One more random thing I found is that I did not need to use ANOTHER usb cable for the focuser. Essentially, once you have the telescope talking to BYN, the focuser comes along for the ride, you don't need a separate cable (which was eating up another COM port in device manager). 

This cable is NOT needed!

NyzJu4c.jpg

 

I've ordered a few brand new cables off Amazon, and will try getting those in place, and then playing with a hub after that, and report back. 

 

Cheers.

Link to comment
Share on other sites

  • 0

Depending on the Celestron driver that you use, it may support both the mount and the focuser, as you discovered. Then as long as it is cabled correctly you will be able to use both devices through on port.

If you disconnect through the software before unplugging the USB cable, you may get the same COM port number regardless of which USB port you use.

In my case, I never unplug the USB cables from the hub that is on the mount and I always plug the cable from the hub into the same USB port on the PC, so I always get the same COM port numbers for my mount and focuser.

Thanks for letting us know what you learned.

Link to comment
Share on other sites

  • 0

The most significant issue with USB Hubs (especially in combination to Laptop Hosts) is POWER.  Laptop designers are notorious for skimping on power output to USB Ports (in the name of Battery Runtime stats), and rarely fully power the USB Ports to levels specified by the USB -Spec for even USB2 levels.

Powered Hubs are a MUST.  Ideally, one will find a 12V 4-port Hub with a 4-6Amp Power Input that one can adapt to whatever form of Power Rig is used by the rest of the AP Equipment (Mains, or better yet Field Battery).  Highly respected brands include Anker and Sabrent. (And even better, if you find one of the few models which DON'T sport Bright Blue LEDs!!)

Proper Power will cure a number of ills blamed on Cables and Connectors.

(I have one AP Imaging Rig with an Anker 7-Port 10Amp No-LED USB3 Hub (discontinued) fed by a 35Ah AGM Deep-cycle Battery through an Anderson Power Pole Bus using 14ga Silicone wiring.  Another AP Imaging Rig is built around a PegasusPower Advanced Intelligent Power Distribution / USB3 Hub device fed by a 36Ah LiPO4 Battery using the same wiring.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use