Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Canon 5D Connection to EOS


mark_r_hickman
 Share

Question

I installed EOS Backyard and the WIA drivers for the Canon 5D on a 32 bit version of Windows 10 based on guidance I found in a previous Backyard EOS support message. EOS Utility V3 does not recognize the camera (could be a version issue). Backyard EOS did recognize the camera and connected. I attempted to start capture, and received the following message.

13:20:22  BackyardEOS 3.2.2 Trial Edition
13:20:35  Attempting to connect camera...
13:20:35  Canon drivers 'Canon210\' initialized.
13:20:36  5D CONNECTED!
13:20:44  Imaging session started.
13:20:45  Imaging session cancelled
13:20:45  ERROR EDS_ERR_NOT_SUPPORTED : EDSDK.EdsSetPropertyData(cameraRef, SaveTo(11), 0, size(4), 2) 
13:20:46  Imaging session cancelled

I also note the Canon camera has a flashing BUSY sign and does not respond to input through any of its controls.

My question is:

How do I fix this error in Backyard EOS?

Also, is the camera supposed to be flashing BUSY and be nonresponsive to control use (which causes problems for using this camera for astrophotography.

Thanks for any help you can provide.

Regards,

Mark

P.S. I restarted the camera and reconnected it to Windows. Windows 10 was able to import all of the pictures on the camera to the PC (which is definitely forward motion). EOS Backyard and EOS Utility are still not working.

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

OK, I solved the problem. My Communication setting in the camera was set to PTP/Print not PC communication. Once I switched the setting, the BUSY message went away, the camera responded to controls, and EOS Backyard Start Capture worked without a flaw.

It's always something small and stupid...

I appreciate the suggestion astroman, and I will get that DCUSB shutter control system from Shoestring Astronomy on order.

Regards,

 

Mark

Link to comment
Share on other sites

  • 0

Were you trying to take a BULB exposure?

If so, then you need a second cable, in addition to the USB cable, to control the shutter for BULB exposures. This is indicated in the Supported Cameras table on this web site.

If you select a Tv exposure, you will not need the second cable, but for exposures longer than 30 seconds you need either a serial cable or a newer camera. If you already have a compatible shutter control cable, like the Shoestring Astronomy DSUSB cable, you may need to configure BYE to use it. Check the user guide for instructions.

Link to comment
Share on other sites

  • 0

Thanks for the suggestion. Is the camera BUSY message and nonresponsiveness to physical camera controls (the shutter and other controls don't work when the camera is connected to a PC) a Canon feature or a bug?

Thanks,

P.S. If the camera is perpetually BUSY when connected to a PC, I'm not clear how adding a serial cable shutter cable will allow me to take tethered pictures.

Mark

Quote

 

 

Link to comment
Share on other sites

  • 0

The log history provided in your original post does not provide enough information to know led up to the Busy indication. The full log file is available in the BackyardTEMP\Logs folder. The value of BackyardTEMP is defined in the Setup dialog.

When you provide a log file, attach it to a post here. Select a single log file that illustrates your issue and follow these instructions to send to the developers:

How-to submit log files for troubleshooting an issue. - How-to's - O'Telescope

Be sure to reference this thread to provide them with background and detail the steps necessary to re-create the issue.

Link to comment
Share on other sites

  • 0
2 hours ago, mark_r_hickman said:

OK, I solved the problem. My Communication setting in the camera was set to PTP/Print not PC communication. Once I switched the setting, the BUSY message went away, the camera responded to controls, and EOS Backyard Start Capture worked without a flaw.

It's always something small and stupid...

I appreciate the suggestion astroman, and I will get that DCUSB shutter control system from Shoestring Astronomy on order.

Regards,

 

Mark

Glad you got it to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use