Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Problem With Flats


biaglow
 Share

Question

I am using Backyard EOS 3.2.1 Premium.  My camera is a Canon EOS 70D.  The issue is that the Av mode does not appear to be communicating correctly with the camera.  If I set the number of exposures to anything other than 1, the first exposure seems to be correct, but the subsequent exposures are different.  They appear to be shorter times and do not have the same exposure as the first.  They are clearly not as bright.  This seems to be a bug in the program.  The file size of the raw images is too large for me to attach.  However, the file name is FLAT_1s_6400iso_20210314-00h08m13s326ms which appears to be indicating a 1s exposure, even though Av is selected.  The camera switch is set to M but I also tried setting the camera switch to Av mode but this did not help.  Any way I can troubleshoot this?

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

This issue is resolved. 

I set the telescope up for flats inside the garage since it is raining here.  But I wanted the exact same optical train and ambient temperature, controlling as many things as I can.

Bottom line is that it appears that my filter is causing the issue.  It is a narrow band triad filter from Radian.  Apparently, it is blocking most of the light from my flat light source.  The flats are really dark and the histograms are really attenuated.  If I remove the filter from the optical train, everything seems fine.  Images are bright with good histograms.  If I return the filter and I really boost the flat light intensity, everything seems fine again.

Apparently with the Canon 70D in Av mode, there seems to be a cutoff in the light level where the shutter time fluctuates.

The comments in this thread got me to think about this and helped solve the problem.

Thank you!

Link to comment
Share on other sites

  • 0

I am confused. Where is Av selected? 

If the shutter is set in BYE to AV-Flat, the camera's shooting mode must be set to Av, not M.

My test setup to try to duplicate what you are reporting is to use BYE 3.2.2 Premium with my T5i. I was unable to duplicate your situation where multiple flat images that were shot with a single line in the Capture Plan have different appearance/exposure duration.

I also see that when shooting an AV-Flat, with the camera in Av mode, the exposure in the file name is "1s", but the ExposureTime in the EXIF data is 0.3 seconds for all test images. That does not seem optimal, but may be the design behavior when Av mode is used.

Link to comment
Share on other sites

  • 0

Thank you for the reply. I am admittedly new to using this software, and I really like it.

To answer your question, the shutter was set in the capture plan center under "shutter."  A screenshot is attached.  I used Av-Flat mode with the camera set to Av.  I also used Av-Flat mode with the camera set to M and obtained the same result. 

It's been a few weeks since I have used my XSi, but it seems to me that when the XSi camera is connected, I get a message from Backyard EOS reminding me to set the camera dial to Av if I try to set it to M.  At any rate, I do not see that message now.

I am indoors right now with the camera set up on the same laptop I use outside, with the field flattener on the camera as a lens, to make it as similar as possible to actual operating conditions.  Look at the different exposures on the ribbon at the bottom.  They appear to be different.  The histograms are also different.  The difference is much more dramatic when I expose actual flats at the telescope.

Could this be a cable issue?  I actually own three cameras, an XTi, an XSi, and a 70D.  My USB cable is an IFC-400PCU that came with my Rebel XTi with a USB extension cable.  I looked through the three manulas, and both the XSi and the 70D manuals refer to cables IFC-200U or IFC-500U.

It is rainy and cloudy today.  Next time I am at the scope under actual conditions, I'll take a video for you.

I hope I am being clear.  Let me know if there are questions.

Andy

ScreenShot003.jpg

Link to comment
Share on other sites

  • 0

Your 70D must allow you to take Av exposures while in M mode.

When taking an Av image, the camera adjusts the exposure based on the amount of light hitting the sensor.

What if you look at the EXIF data for each of the images, what is the range of exposures? Do they look as expected if you switch from Av-Flat to Manual mode, enter the exposure from an image with the desired histogram into the capture plan and shoot your flats that way.? Do they all look the same then?

Especially if you shoot flats with an artificial light source, it is common to shoot them in Manual mode (on the camera), Flat as the Type, and a fixed Shutter setting that gives you the desired histogram.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use