Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Bye Doen't Recognize Camera Or Serial Cable



I've been trying to get BYE 3.0.3 to run on my ThinkPad T60 using a Canon Rebel XS. I have a serial cable from HAP astrocables. I thought I had everything working and then I began to get odd results. The camera would disconnect with a message from BYE that I had to have a serial cable connected to use bulb. Other times, when I tried to make a short exposure, the progress wheel would go endlessly and ignore my attempts to abort. Well, I had the serial cable connected through a serial adapter and the com port set to where device manager said the cable was connected. I tried plugging the serial cable into other USB ports (each time Windows would assign it a new com port) with no luck. When I unplug the serial cable, the camera seems to work. I'll attach the last couple of log files. I'm wondering if I could have somehow corrupted BYE.


What's going on? Should I reinstall BYE,and, if so, how? I thought the serial cable was a relatively simple affair; how can I tell if it is working properly?


Thanks for your help.



Max Shelhorse






Link to comment
Share on other sites

  • Answers 6
  • Created
  • Last Reply

6 answers to this question

Recommended Posts

The issue is not BYE, it's your cable/connections/drivers.


Forget about the serial cable for now because if you get disconnected then the issue is your regular USB cable and or connection.  If BYE looses connection then I'am 110% positive EOS Utility would too.


How long is your USB cable?

How old is your USB cable?

Do you use a USB hub?  What brand?  Is it a powered hub?

Do you have any other USB devices connected to the hub while this is happening.


You should re-introduce the serial cable in the mix only and only when you have 100% certainty that your regular USB cable is not at fault because it seems to me like you are not sure what the root cause is.


Keep us posted,

Link to comment
Share on other sites

I started out using a hub, but my most recent attempts were without it. The USB cable came with the camera and has not been used until recently. It is about 6 feet long. I've had the hub for quite a few years and don't remember the brand; it came from Micro Center. The USB adapter is a Trendnet, also from Micro Center. As I mentioned in my first note, I wouldn't be surprised if I managed to corrupt some files in BYE. If you know of some way I could check that, I'd try it.


I attached the recent log files so that you might see if I've done something wrong. Odds are I did something that caused this. In the past, when I've had software begin to behave strangely, reinstalling it seems to straighten things out. Might that help in this instance?


Thanks again for your help.



Max Shelhorse

Link to comment
Share on other sites

As you are running BYE v3.0.3, and V3.1.1 has just now been released (and the v3.0.x to v3.1.x Upgrade is FREE), it wouldn't hurt you to pursue the Upgrade.  And it WILL install an entirely New set of BYE Files in a New Directory - addressing your concern that you'e "Messed Up some BYE Files" AND getting you onto the Latest and Greatest BYE...


But, as Guylain said, from your OP description its most likely that the USB-RS-232 Converter is having issues - either Electronically or it's Driver (not part of any BYE Package) has gotten Messed Up...

Link to comment
Share on other sites

I have found that BYE seems to work well if I don't plug in the USB-Serial adapter. I'm limited to 30 second exposures until I can rectify this situation. I've ordered an 1-port RS232 Expresscard and I hope that fixes everything. I'm excited about using BackyardEOS and plan to photograph Comet Lovejoy tomorrow evening. Thanks for all your help. I'll let you know if the Expresscard fixes the problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use