Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
Adlezana07

New Canon T8i

Question

16:44:54  Licensed to Adlezana07
16:44:55  BackyardEOS 3.1.18 Trial Edition
16:45:40  Attempting to connect camera...
16:45:41  Canon drivers 'Canon\' initialized.
16:45:41  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T8i
16:45:41  DEVICEINFO NUMBER IS 3470492101.
16:45:41  YOUR *REAL* MODEL NUMBER IS 4294967294(FFFFFFFE)
16:45:41  YOUR camera is not currently supported by the Canon SDK available at the time of this software release.
16:45:41  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Does somebody know why I´m not been able to connect my camera to BYE Trial Version (3.1.18)?

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0
19 minutes ago, Adlezana07 said:

16:44:54  Licensed to Adlezana07
16:44:55  BackyardEOS 3.1.18 Trial Edition
16:45:40  Attempting to connect camera...
16:45:41  Canon drivers 'Canon\' initialized.
16:45:41  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T8i
16:45:41  DEVICEINFO NUMBER IS 3470492101.
16:45:41  YOUR *REAL* MODEL NUMBER IS 4294967294(FFFFFFFE)
16:45:41  YOUR camera is not currently supported by the Canon SDK available at the time of this software release.
16:45:41  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Does somebody know why I´m not been able to connect my camera to BYE Trial Version (3.1.18)?

Yes, I do know why... it's because your camera is a newer model and the SDK was not available at the time of the 3.1.18 release.

Please, try 3.2.0 pre-release from the download pre-release section and send me those numbers again.

Regards.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the quick answer. 

I tried what you did but I got the same results with the 3.2.0 version...

18:19:02  Licensed to Adlezana07
18:19:03  BackyardEOS 3.2.0 RC5
18:24:01  Attempting to connect camera...
18:24:01  Canon drivers 'Canon\' initialized.
18:24:01  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T8i
18:24:01  DEVICEINFO NUMBER IS 2971957774.
18:24:01  YOUR *REAL* MODEL NUMBER IS 2147484725(80000435)
18:24:01  YOUR camera is not currently supported by the Canon SDK available at the time of this software release.
18:24:01  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Does this mean I won´t be able to use BYEOS with my new camera? 😞

Share this post


Link to post
Share on other sites
  • 0

It's not the same result.

The number 80000435 tells me that the current SDK supports it.  Give me a few days and I'll upload another RC.

That number was FFFFFFFF in your previous post.

Share this post


Link to post
Share on other sites
  • 0

Please download 3.2.0 RC5 again and give it another try.

I checked the server logs and you were the one that downloaded it so I made a change and kept the same version number.

It should connect.

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, admin said:

Please download 3.2.0 RC5 again and give it another try.

I checked the server logs and you were the one that downloaded it so I made a change and kept the same version number.

It should connect.

Did it and it did connect. Thanks for the support. Although, I think the program is not working fully properly; when I try to go to Frame and Focus, the Camera sends an error (71) and it gets disconnected from BYE. 

Share this post


Link to post
Share on other sites
  • 0

:( Looks like the this model suffers from the same issue as the 250D with live view.  I was not able to fix it blindly without a physical camera to test.  

I can't purchase every model for testing, It would ruin my very quickly.  Sometimes I get a brave user willing to lend me his/her camera for a few days to test and make that particular model work.  Looks like the 250D and T8i are 2 models that falls in that category.

:(

 

Share this post


Link to post
Share on other sites
  • 0

☹️ That’s why having the 30 days trial is an excellent thing you have for this program. I live in Mexico otherwise I will let you work with my camera. I think I have nothing else to do but wait until you have the opportunity of working with this specific model before buying the full version of the software. I’m not gonna lie, that makes me feel sad because I was expecting to go out tonight and try to take my first astropics withy brand new camera using your SW. 

Share this post


Link to post
Share on other sites
  • 0

Guylain has already said, above, that he is unable to personally test every new model of camera with BYE. He is largely relying on the Canon EOS SDK to hide the differences between models, so I'll turn it around. Since you are the owner of a T8i, have you had the opportunity to test the imaging capability of the T8i with BYE? Does it correctly create RAW, TIF, and JPG images from your camera? Is BYE able to set the camera's ISO and lens' aperture? Does it control the camera correctly to shoot Tv and Bulb exposures? Does BYE fully function with the T8i, except for LiveView?

All of the suggested testing can be done indoors during the day with a lens attached to the camera.

Share this post


Link to post
Share on other sites
  • 0

Hi Astroman133, 

I just did several imaging tests with my T8i and BYE.

  • Preview function: OK
  • Capturing individual and multiple Bulb and TV exposures using the Capture Plan Center: OK
  • Creating RAW and JPGs images: OK
  • Creating TIFF images: NO OK (These don’t get downloaded in my PC. I double checked in Setting and the functionality is activated)
  • Creating EXIF text files: OK
  • Saving pics in PC and/or camera: OK
  • Setting ISO and lens aperture: OK
  • Camera settings in BYE Camera Information Center screen: OK
  • Capturing AV exposures: NO OK (BYE stops working and Abort function doesn’t work. BYE needs to be fully restarted)
  • Same with Program Exposures
  • Histogram Center: OK
  • Abort function: OK but explained before
  • Loop function: OK with Bulb and TV exposures

Additional to this, the already commented issue with the T8i. Every time that I click Frame & Focus or Planetary, the camera gets disconnected from BYE and shows the ERROR 70 in the screen. I need to remove the battery of the camera to make it work again. Turn it off is not enough.

Hope this helps you to Having a better understanding of the compatibility issues with the T8i. By the way, I’m not sure if it’s even possible, but if you want to work with my computer and camera remotely, we can try to do it. I’m more than happy to assist with whatever I can.

Share this post


Link to post
Share on other sites
  • 0

Thank you for this detail report.

  • Preview function: OK
  • Capturing individual and multiple Bulb and TV exposures using the Capture Plan Center: OK
  • Creating RAW and JPGs images: OK
  • Creating TIFF images: NO OK (These don’t get downloaded in my PC. I double checked in Setting and the functionality is activated)

This is to be expected.  BYE uses dcraw to convert from raw to tiff and your camera was not released when the last version of dcraw was compiled.

  • Creating EXIF text files: OK
  • Saving pics in PC and/or camera: OK
  • Setting ISO and lens aperture: OK
  • Camera settings in BYE Camera Information Center screen: OK
  • Capturing AV exposures: NO OK (BYE stops working and Abort function doesn’t work. BYE needs to be fully restarted)

Did your turn the camera dial to AV or left it to M?

  • Same with Program Exposures
  • Histogram Center: OK
  • Abort function: OK but explained before
  • Loop function: OK with Bulb and TV exposures

Share this post


Link to post
Share on other sites
  • 0

Try turning the dial to AV/Program manually respectively.  Only the higher end models allow changing the dial mode programmatically.  All other models you need to turn it manually.

Share this post


Link to post
Share on other sites
  • 0

Thanks for all the updates. 
 

Have you considered to work with this new camera through a remote connection to my computer? Is it even possible? Or you need the camera physically on your hands?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use