Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
PLEASE READ ==> If you get a StructureMap or EdsInitializeSDK() error please RE-INSTALL before posting in the forum <==
  • 0
PaulWhitton

Licence Key not Working on TRIAL

Question

Could you help with a registration issue please.

I’ve been testing BYE with my Canon 5Ds and its wifi adapter with some success. I have however, been struggling as BYE has had trouble connecting to the Camera reliably.

I’ve found the issue to be with me not realising that I need Canon’s EOS utility to be running ( but not connected ) on my PC.

The EOS utility was disabled by me as I thought it shouldn’t be loaded at startup as I assumed BYE would take full control of the Camera.

 I now have the EOS utility in startup on Win 10 but set to ‘do not launch EOS utility automatically when the camera is connected’ This seems to have solved my issue.

 Having played around quite a while trying to find what the issue was I now find that when I launch BYE it says the licence is INVALID.

PS: In my 30 years in the Computer industry I have never come across a TRIAL period with software having a licence key revoked !!!

Perhaps your company is sensitive to licencing issues with your software.

Please assist ( I am in the 30 day period of testing )

It seems strange that I couldn't email a support dept to ask about the licence issue.

Having to resort to POSTING on a forum seems weird.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

O'Telescope is a 2-person shop where they also have day jobs. Hence they rely on experienced users (the community) to help provide support for common issues.

So I understand that you are having difficulty connecting BYE to your 5Ds via WiFi. And that when you are able to connect, that the camera does not reliably stay connected. Is that it?

BYE uses the Canon SDK to manage the camera.The SDK does not provide the capability to connect via WiFi. For this reason use of WiFi is an unsupported configuration.

The EOS Utility also uses the SDK, but Canon has built into the EOS Utility the ability to complete the pairing process before using the SDK. They have not published that the details of the pairing process so that 3rd party developers can implement that missing functionality. This means that you have two choices...Disable WiFi in the camera and connect via USB or use the EOS Utility to complete the pairing but disconnect and allow BYE to connect. Some people have gotten this to work but I suspect that most have given up on WiFi. If you must have WiFi, I would suggest that you troll the archives here for how others have solved this issue. This has been discussed many times on this forum.

Reasons not to use WiFi are the following:

1) Use of WiFi for instrument control is not allowed at large star parties because it is a hog of WiFi channels.

2) Even a momentary loss of the WiFi connection can cause the Canon SDK to lock up which in turn can cause BYE to lock up because a synchronous call to the SDK never returns.

3) Even if it works reliably enough to use, it will be slower than a wired USB connection.

30-day trial keys are not revoked without cause which would have been communicated to you. Trial licenses do however require an internet connection. You can thank license cheaters for forcing the developers to implement this behavior which is designed solely to check with a server to verify that the current date is still in the 30-day trial period. This is not a problem with a purchased, permanent license.

If you are running BYE in a virtual machine, this has been a problem for some users if they have re-created the VM. The new VM will not have your license key stored and when you validate the key it will be registered on the validation server as a new activation. There is some limit on the number of activations per license. This is an attempt to prevent license sharing, but should be sufficient for a normal user.

I hope this helps. If you still have licensing questions, please wait for Guylain to reply. He does check the forums at least several times a day.

Thanks,

Share this post


Link to post
Share on other sites
  • 0

While it should go without saying:  DO NOT Post even a portion of your License Key in a Message on the Forum (nor anywhere else).

Browsing the Forum, you'll see that any such action is Very Heavily Frowned Upon and immediately leads to License Revocation and possibly worse...

Not that you've done so.  But as your issue is License Key related, the warning could be useful...

Share this post


Link to post
Share on other sites
  • 0

The forum is the only free support system.

Your trial key has not been revoked, it still shows as active on the server.  Perhaps it would help to know the exact error message you get, saying it is invalid is not sufficient to diagnose the root cause.

You can't email support because 1:1 email support is not efficient and does nothing to support the community. I make no excuse for the free medium used to offer support.

EOS Utility does not have to run, in fact it does not even need to be installed. I suspect this is because you are testing the wifi connection... which is not supported by the way... but some have been able to make it work.

Regards,

Share this post


Link to post
Share on other sites
  • 0

Thank you 'Community' for a comprehensive response to my issue.

I have my Camera tracking the stars 'outside' on my Backyard!!! However, here in Ireland its absolutely freezing outside, so I have my camera working on Wifi connected to my wireless router.

I sit in my office, in a warm environment on my Windows 10 PC. This PC works perfectly with BYE on Wifi - I realise the speed issue over wifi. I have an ethernet over mains Wifi extender outside next to the camera, 5 feet away to get a reliable signal.

BYE works reliably but I think my issue was that whilst testing, focus, image capture etc, I hit ABORT a number of times and it wouldn't stop so I terminated BYE (ie: Task Manager - end process)

When I launch BYE 3.1 I get the following message:

------------------------------------

Licence fault error!

(s:INACTIVE)- The key provided has expired, been deactivated or has not been activated yet.

Please contact us.

OK

-------------------------------------

So my testing of BYE  ( which I must say, based on my initial testing is a great piece of software)  has stopped.

Could someone sort the licence out of let me know how to continue the trial.

Regards

Paul Whitton

 

 

Share this post


Link to post
Share on other sites
  • 0

Next step

I uninstalled BYE and reinstalled the same.

Still I get the same error. PS: No VM, simple clean Windows 10 64bit Pro PC.

The error appears with no camera connected, as it checks the licence and immediately stops with the error above before getting near looking for a camera.

Obviously the Internet is working as I'm on your support forum as I try BYE.

Share this post


Link to post
Share on other sites
  • 0

Trial keys also have a limit on the number of times it can be activated on top of the 30 days, though that only happened a few times in 10 years and more prone on VM. 

I have just archived your current trial key. Please go ahead and add it again in your cart and proceed to checkout for a second 30-day trial key.

Let me know if you have any issues with the second key.

Regards,

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use