Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Validation Issue(s)


BackyardBarry
 Share

Question

I cannot validate a re-install of Premium..It was purchased March-2017..The key entered correctly but I assume the user name used in 2017 my have been changed as I dont remember....The past purchase does not show the purchase only a download of a trial ....I sent contact message to the "contact" provided with my  name, key and proof of purchase...Automated message says use this forum as it is monitored..for obvious reasons, I should not...So it appears I am in  loop here...I had joined this Website the last install on a different computer..Not that long ago...Suggestions..?

I am already on the latest version..

 

Barry

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
2 minutes ago, astroman133 said:

Barry,

Be patient. Only the admins can deal with licensing issues. It appears that you used a different account (username) when you purchased your BYE license. You must use that username as the identifier when validating your license. The admins have helped others in the past, with the same issue.

    OK...Thanks astroman...

Link to comment
Share on other sites

  • 0
7 hours ago, BackyardBarry said:

I cannot validate a re-install of Premium..It was purchased March-2017..The key entered correctly but I assume the user name used in 2017 my have been changed as I dont remember....The past purchase does not show the purchase only a download of a trial ....I sent contact message to the "contact" provided with my  name, key and proof of purchase...Automated message says use this forum as it is monitored..for obvious reasons, I should not...So it appears I am in  loop here...I had joined this Website the last install on a different computer..Not that long ago...Suggestions..?

I am already on the latest version..

 

Barry

Hi Barry,

First thank you for not posting your key on the forum.

I can guarantee with 100% certainty that if you do not see your purchase key under "My Purchases -> Orders" then you have not logged in with the account you used to purchase... that I'm 100% sure of since all keys purchased after 2015 are stored on line.

If you remember the email you used to purchase try logging in with that and see if your key is in "My Purchases -> Orders".

As a last ditch effort, and if you still have your key stored on your computer, send it to me at support@otelescope.com and I'll see if I can retrieve your account.

Regards,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use