Jump to content

Canada's top-tier Telescopes & Accessories
  • 0
Sign in to follow this  
richrichardw

Support for Canon T100/3000D/4000D

Question

Hi, I have a Canon EOS T100 (also known as 3000D or 4000D). Right now it does not seem to work with BackyardEOS (I am getting the error "Generic model 153 assumed!"). Since Wikipedia says that this camera is very similar to the 1300D, will you consider adding support for it? Thanks in advance!

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

There is no such thing as similar when it comes to communicating with cameras... they all have their kwirks.

Try 3.1.17.RC3 and let me know what is displayed on the information area.  That may help me with a few things.  I did download the latest Canon SDK 2 weeks ago so I may be able to do something... but I need to know what you get with 3.1.17.RC3 first.

Share this post


Link to post
Share on other sites
  • 0

Backyard EOS 3.1.17.RC3 was made available in September. It includes version 3.8 of the EOS SDK. This is the first version of the SDK that supports the T100. This means that Guylain is very close to supporting it.

He will need you to download 3.2.17.RC3 from the Pre-release area and try to connect to your camera from BYE. It will fail but in the process will provide some numbers that he can use to allow BYE to connect with your camera. I am sure that he will elaborate when he reads your post.

 

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, admin said:

There is no such thing as similar when it comes to communicating with cameras... they all have their kwirks.

Try 3.1.17.RC3 and let me know what is displayed on the information area.  That may help me with a few things.  I did download the latest Canon SDK 2 weeks ago so I may be able to do something... but I need to know what you get with 3.1.17.RC3 first.

Hi Guylain, this is what I see with 3.1.17.RC3:

08:42:38  Licensed to richrichardw
08:47:26  Attempting to connect camera...
08:47:26  Canon drivers 'Canon215\' initialized.
08:47:27  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T100
08:47:27  DEVICEINFO NUMBER IS 3470492101.
08:47:27  YOUR *REAL* MODEL NUMBER IS 4294967294(FFFFFFFE)
08:47:27  Generic model 153 assumed!

Best wishes,

Richard

 

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, astroman133 said:

Your camera is a newly supported in the latest version of the SDK. You should choose the Canon drivers instead of Canon215 which uses version 2.15 of the SDK and is for older cameras.

 

Correct.  You need to select the latest (default) Canon drivers.  You have selected Canon215 and this wlll never work with new models!

Try again with the correct drivers and give me those numbers again, these are exactly what I need to go any further :)

Share this post


Link to post
Share on other sites
  • 0
On 2/6/2019 at 3:30 PM, admin said:

Correct.  You need to select the latest (default) Canon drivers.  You have selected Canon215 and this wlll never work with new models!

Try again with the correct drivers and give me those numbers again, these are exactly what I need to go any further :)

Hi, this is the message using the latest Canon driver. Thanks!

16:59:54  Licensed to richrichardw
17:00:06  Attempting to connect camera...
17:00:06  Canon drivers 'Canon\' initialized.
17:00:06  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T100
17:00:06  DEVICEINFO NUMBER IS 2971957785.
17:00:06  YOUR *REAL* MODEL NUMBER IS 2147484706(80000422)
17:00:06  YOUR camera is not currently supported by the Canon SDK available at the time of this software release.
17:00:06  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Share this post


Link to post
Share on other sites
  • 0
52 minutes ago, richrichardw said:

Hi, this is the message using the latest Canon driver. Thanks!

16:59:54  Licensed to richrichardw
17:00:06  Attempting to connect camera...
17:00:06  Canon drivers 'Canon\' initialized.
17:00:06  DEVICEINFO DESCRIPTION IS Canon EOS Rebel T100
17:00:06  DEVICEINFO NUMBER IS 2971957785.
17:00:06  YOUR *REAL* MODEL NUMBER IS 2147484706(80000422)
17:00:06  YOUR camera is not currently supported by the Canon SDK available at the time of this software release.
17:00:06  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Perfect, that is what I need.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use