Jump to content

Canada's top-tier Telescopes & Accessories
  • 0
Sign in to follow this  
Elvie1

Bulb Function Stopped Working

Question

Hello - Have been using BYN for a number of months. Installed on 2 laptops.

Recently disconnected / reconnected my DSUB and now message: "Your camera requires a configured serial cable for BULB or Mirror Lock." is appearing.

BYN is working properly on my older laptop - it no longer works on my new one. I also use SGP (signal Generator Pro) on my new laptop and it controls the Bulb function properly.

So I believe have ruled out any hardware / USB / camera problems.

Since this was working correctly I thought I would deinstall / reinstall BYN. Windows 10 says it has done this, however reinstalling keeps any previous registration info and  BYN settings so I know the deinstall is not truly successful.

My preference is to get BYN working, else to know how to do a full and fresh BYN install.

Any help would be appreciated.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Nope, you have not ruled out camera!

SGP uses a serial cable for bulb, right?  Not the same thing as BYN uses the regular USB cable.

The message is descriptive.  What cable did you select in BYN?  Also, make sure mirror lock is not set in the camera.  

A fresh install won't help, this is a camera setting that has to be set properly.

Keep us posted.

Share this post


Link to post
Share on other sites
  • 0

I assume that you mean Sequence Generator Pro (SGP)?

Also, I assume that you mean DSUSB not DSUB?

The BYN license is stored separately from the program and un-installing the program does not remove the license. This is probably by design. I would not recommend re-installing BYN to try to solve this issue, unless you are upgrading to a new version of the software. If the software installation runs to completion then BYN is successfully installed. Doing it again is unlikely to fix your issue.

Are you using the same version of BYN on both PCs?

Are you using the same version of the Nikon SDK (the driver that is selected at connect time?) on both PC's?

Are you using the same Cable Support option on both PC's?

Does the DSUSB test program work on the PC where BYN does not connect?

Are you trying to use Mirror Lock? If so, then I would recommend setting it to 0...I do not believe that it works.

 

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, admin said:

Nope, you have not ruled out camera!

SGP uses a serial cable for bulb, right?  Not the same thing as BYN uses the regular USB cable.

The message is descriptive.  What cable did you select in BYN?  Also, make sure mirror lock is not set in the camera.  

A fresh install won't help, this is a camera setting (edit: or BYN setting) that has to be set properly.

Keep us posted.

 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the input. I'll try to respond to your suggestions.

I believe both Sequence Generator Pro and BYN use the same cabling. When this was working I would simply switch apps - no cable change. SGP also mentions Shoestring requirement.

Where do I select a cable in BYN - have not done this for either install?

Mirror lock set to 0 - have never modified.

Same BYN version both laptops: 2.09 Edition::1499

Select D7000 - same version for both. Have tried both.

What is cable support option? If force serial under advanced settings - it is off in both installs.

DSUSBCheck is functioning. Can Assert / Open and Deassert / Close.

I have looked closely at both laptop installations and they appear to be identically configured. I can switch the USB between laptops and have BYN success on one one but failure on the other so I don't understand how this is a camera setting. 

Further suggestions? Again thanks.

 

Share this post


Link to post
Share on other sites
  • 0

OK, so both SGP and DSUSBCheck indicate that the hardware is configured and functioning correctly. This indicates the likelihood that the issue is caused by a BYN setting.

An incorrectly configured Cable support setting could cause the message: "Your camera requires a configured serial cable for BULB or Mirror Lock." to appear.

Cable support is accessed in the Capture Plan Center on the same row of controls as the Mirror Lock selection. I would expect that the selected option should be DSUSB.

Open the User Guide and search for DSUSB.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use