Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

SkyX pro won't connect on Eagle



Trying to get SkyX pro and BYN to connect on my new Primaluce Eagle setup.  SkyX and BYN work perfectly on Eagle independently.  Followed all recommended setup procedures on both sides, including enabling TCP Server in BYN settings.  Have successfully connected the two previously on my desktop (pre-Eagle).  Nikon is D5600 in cooled Primaluce package.

When I check the enable TCP button, I get a message "Changing TCP will take effect on next startup".  I then apply and save and the setting sticks when I reopen settings.  The setting is lost when I close and reopen BYN.

The Eagle runs Windows 10 Enterprise 2015 LTSB.  The error message I get from SkyX is error = 215.

Software Bisque or Primaluce haven't been able to come up with a fix.  All software is completely up to date.

Any hot ideas?



Link to comment
Share on other sites

  • Answers 4
  • Created
  • Last Reply

4 answers to this question

Recommended Posts

Saying that "the software is completely up to date" means one thing today. but may mean something different in 12 months. It is always better to say what versions of software you are using.

I do not understand your "Eagle setup". but I have seen others report that in certain circumstances that "settings may be lost" when BYE or BYN is restarted. This is almost always on Windows 10 systems and is due to Windows changing the file permissions on some directories that prevents BYN from saving changes to configuration files. The workaround is to remove BYE/BYN and re-install it to a different folder from the previous install.

Software Bisque is famous (or infamous) for those cryptic numeric error codes that only mean something to the developer. If after re-installing BYN, you still get an error from TSX, you will need to contact them to resolve the error.

So you are using BYN to control your camera. What are you using TSX for? What devices is it connecting  to?

Link to comment
Share on other sites

17 minutes ago, mincer said:

When I check the enable TCP button, I get a message "Changing TCP will take effect on next startup".  I then apply and save and the setting sticks when I reopen settings.  The setting is lost when I close and reopen BYN.


Looks like the classic Windows update messed up your security profiles

Reinstall BYN in a separate folder and see if this makes a difference.

Link to comment
Share on other sites

You got it.  Uninstalling BYN and reinstalling in new folder solved the problem!  Connections are now perfect and BYN remembers settings. Thanks!!!

For astroman:  The "Eagle setup" is the new Primalucelabs Eagle unit which is basically a compact and purpose-designedWindows 10 computer which you mount on the scope side of your setup.  In my case, it allows me to load all of the software on the Eagle and control it all via Microsoft Remote Access via an Ethernet connection from my desktop in my office a few hundred feet away.  The main need to connect TSX to BYN is to use the TSX focus tools, including temperature training, and for autoguiding.  It's also a bit simpler to use the TSX view when tuning the GOTO sync each session (no permanent pier/observatory yet - negotiating with wife).  The setup I'm working on is a small wide-field "test bed" for the Eagle with the goal being to be able to move the Eagle up to and between my larger scope/mount and the smaller wide-field scope/mount with minimum downtime and a common software control framework (one learning curve).  Components controlled via the Eagle include the mounts, Optec focusers, cameras, autoguiders, dew heaters, and for the larger setup, the filter wheel.  TSX and BYN have worked together to to allow TSX to easily connect to BYN as a camera, with BYN still in control of exposure times, file configurations, etc.. The only software I need to handle all of this is TSX and BYN.  The Eagle has worked perfectly so far, with the only glitch the connection issue between TSX and BYN which is now solved.

For the record, my "current" TSX version is 10.5.0, the BYN is 2.0.9., and the Windows 10 is Enterprise 2015 LTSB.  All software is current in that all have been checked and cleared for updates.

OK, hope this all helps.  I'll report back in on results.  Thanks again!!


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use