Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Camera connect to BYN fails...after LifePixel modification


sbradley07
 Share

Question

I'm having a strange problem connecting my D5300 to BYN that I cannot figure out.  I have been using BYN without any major issues for a couple of months.  I recently had my camera "HA modified" by LifePixel.  Since getting it back from them, I can no longer connect to BYN.  Windows 7 recognizes the device when connected to my laptop, but BYN fails to connect (below is the error I see in the log.)  I am not connecting thru a USB hub, and I've tried both USB ports on my laptop.  I also uninstalled/reinstalled BYN and tried multiple versions, and the problem persists.

I am reaching out to LifePixel customer support, but the reason I am posting this here is because I am able to connect to the camera using Astro Photography Tool.  I did notice APT hang a couple of times when testing some exposures, but since Nikon support is relatively new in APT, I'm not sure I can pin that on the camera mod.

Excerpt from log:

2017-11-10 01:22:58,431 [Main] DEBUG - ButtonPlus_MouseClick(btnConnect = 'Connect')
2017-11-10 01:22:58,508 [Main] INFO  - -----------------------------------
2017-11-10 01:22:58,508 [Main] INFO  - Application state changed: 'Connecting'
2017-11-10 01:23:00,480 [Main] DEBUG - ButtonPlus_MouseClick(btnCam2 = 'For most models generaly manufactured in 2015 or before without recent firmware update.')
2017-11-10 01:23:03,053 [ReadWeatherCenter(Normal)] DEBUG - No weather provider configured.
2017-11-10 01:23:08,095 [Main] DEBUG - ButtonPlus_MouseClick(buttonPlus29 = 'D5300')
2017-11-10 01:23:08,113 [Main] INFO  - Attempting to connect camera...
2017-11-10 01:23:08,114 [Main] INFO  - Camera action fired: 'MaestroChoose'
2017-11-10 01:23:08,124 [Main] DEBUG - Nikon drivers 'Type0011_D5300/C:\Program Files (x86)\BackyardNIKONv2.0\Nikon2015\Type0011_D5300\Type0011.md3' is loading...
2017-11-10 01:23:08,172 [Main] INFO  - Nikon drivers 'Type0011_D5300/C:\Program Files (x86)\BackyardNIKONv2.0\Nikon2015\Type0011_D5300\Type0011.md3' initialized.
2017-11-10 01:23:08,178 [Main] INFO  - Nikon2015/D5300 drivers initialized.
2017-11-10 01:23:15,685 [NikonScheduler worker thread] INFO  - NIKON SDK ERROR: [kNkMAIDResult_CameraNotFound] (kNkMAIDCommand_Open, 1, kNkMAIDDataType_ObjectPtr, 252103292)
2017-11-10 01:23:15,687 [NikonScheduler worker thread] ERROR - [kNkMAIDResult_CameraNotFound] (kNkMAIDCommand_Open, 1, kNkMAIDDataType_ObjectPtr, 252103292)
2017-11-10 01:23:15,687 [NikonScheduler worker thread] ERROR -    at BinaryRivers.Camera.Nikon.Wrapper.NikonObject.CallEntryPoint(IntPtr pObject, eNkMAIDCommand ulCommand, UInt32 ulParam, eNkMAIDDataType ulDataType, Int32 data, IntPtr pfnComplete, IntPtr refComplete)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonObject.Open()
   at BinaryRivers.Camera.Nikon.Wrapper.NikonBase.InitializeObject(NikonObject obj)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonManager.HandleAddChild(UInt32 data)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonManager.HandleEvent(NikonObject obj, eNkMAIDEvent currentEvent, UInt32 data)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonBase._object_Event(NikonObject sender, IntPtr refClient, eNkMAIDEvent ulEvent, UInt32 data)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonObject.EventProc(IntPtr refClient, eNkMAIDEvent ulEvent, UInt32 data)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonObject.CallEntryPoint(IntPtr pObject, eNkMAIDCommand ulCommand, UInt32 ulParam, eNkMAIDDataType ulDataType, Int32 data, IntPtr pfnComplete, IntPtr refComplete)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonObject.CallEntryPoint(eNkMAIDCommand ulCommand, UInt32 ulParam, eNkMAIDDataType ulDataType, Int32 data, IntPtr pfnComplete, IntPtr refComplete)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonManager.Async()
2017-11-10 01:23:15,688 [Main] INFO  - Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi Guylain, I just noticed your post.  I just tried the other drivers and it worked!  I tried the other drivers last night and it didn't work, but I can't say for sure that I tried both drivers with both versions (0.7 & 0.9) of BYN.  I have 0.7 installed now and it works with the newer drivers.  I'll test again with 0.9.  Maybe LifePixel updated the firmware when they did the mod, but I think that's unlikely.  In any case, just getting it to connect in this last test is HUGE progress.  Thank you both for the help!

Link to comment
Share on other sites

  • 0

Sorry about that.  I have tested with 2.0.7 and 2.0.9 and get the same results.  I just checked the download page and it looks like 2.0.5 and 2.0.6 have been updated recently, so I should probably give those a try too.  I can't remember if the Nikon SDK was a separate install or if it installs with BYN.  Is there a way to un/re-install just the SDK?

I attached a full log file.

logfile-[20171110-00h37m48s698]-[1236]-2017-11-10.txt

Link to comment
Share on other sites

  • 0

I would not expect that there would be anything to gain by trying old versions 2.0.5 or 2.0.6.

There is no separate install for the SDK. It is installed/updated as part of the BYN install.

You should follow Guylain's suggestion.

In your original post you said that Windows 7 recognizes the camera. How do you know? Do you see the camera listed in the Windows Device Manager?

Link to comment
Share on other sites

  • 0

The 1.02 firmware update for the D5300 was released around August 2017, so if you bought your camera before then I would say that it is likely that the firmware was modified when LifePixel modified the camera. They will be able to tell you for sure. 

The fact that the firmware was updated is also likely why you would need to use the newer driver in order for BYN to connect.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use