Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

BYE 3.1.13 with 7D Mk II

Ron Hillstromb



BYE 3.1.13, Surface Pro 3 with Core I7, 7D Mk II using USB cable supplied with the camera..  I have turned off all that I can think of in BYE, Background worker, EXIF read and write even the Stickstation to hopefully not add another check while executing the plan.

  I am having troubles with my 7D Mk II using a plan.  When it gets to the longer exposures it stops following the plan.  e.g. plan is for 1sec, 2 sec, 4 sec, 2 X 6 sec then back up through the shorter exposures.  It does not repeat the same  every time but it will take 1 sec then 3 of 2 sec 1 of 6 sec then back up through the shorter exposures.  The next time it may take 4 X 4 sec and continue to shorter exposures at 2 sec then 1 sec.  Never the same  time after time.

  I even added a 1 second pause between all exposures over 1 sec in the plan to give the system some breathing room but I had the same problem.

  I am using a copy of Jerry Lodriguess plan as on his site starting after C2 until C3.

  I know that the 7D Mk II is problematic with the SDK and time is getting short for any fixes.

  My 7D executes as the plan directs with no problem just about 10 seconds longer.

  Attached are two logs and my plan as it was executing.






Link to comment
Share on other sites

  • Answers 7
  • Created
  • Last Reply

7 answers to this question

Recommended Posts

Hi Ron,

The 7D Mk II with 3.1.13 is as fully supported by the SDK as any other cameras.

You issue is card save speed.  I'm pretty sure about that.  Do a test, save to pc instead of card.  Does it work?  I think it will.  As a second test add a 2 to 4 second pause between exposures (EDIT: and save to card only), does it work?  I think it will.  These tests should confirm that your card is not fast enough for the image file size of the 7D Mk II.


Link to comment
Share on other sites


Are you saving your image to the memory card, or to the PC?

And do I understand that the 7D works fine, but the 7D Mk II does not work with the same capture plan?" Which SDK's are you using?

If you are following other threads, it appears that the Canon SDK does not behave the same as the Canon 215 SDK.

Link to comment
Share on other sites

Hello Rick

  I tried both Canon and Canon 215 just because of the post in the past few days and no different results.

  That is correct the 7D follows the plan,  The 7D Mk II follows until it gets, usually, down to 1 second.  How ever on at least one time it jumped from 1/4 to 1 second.  It seems to fill in and come out with the number of exposures in the plan but it doesn't change the values when it gets to the longer exposures beyond 1 second.  Sometimes it would take 2 second exposures for 2 seconds, 4 seconds both 6 seconds then go back to 4 seconds and follow the plan from there.  It just isn't consistent. one time it will only mess up one or two exposure time and the next time it will mess up 4 or 5.  I made several runs and I don't remember two results being the same.

  I was hoping that putting a pause of 1 second would give it time to think and put the right shutter speed in but it did not do that.


  I know that the SDK interface for the  7D Mk II hasn't been smooth.  Also when I connect I do get a warning This warning in the window blow the connect button "unable to set image quality,  current settings assumed"  When I was getting this message verbage I tried one more time.  This time It followed the plan up to completing the second 6 second exposure then took 4 exposures 4 seconds long jumped to 1/4 second and completed the plan as written.  I can follow what is happening in the Camera Information Window and it reflects what the camera is doing and not what is supposed to be sent to it.  And again it isn't what happened last time where it happened in the plan.



Link to comment
Share on other sites

Hi Guylain


I will try those suggestions.

  I am using  San Disk Extreme Pro 160mb/s CF cards and san Disk Extreme Pro 95mb/s SD cards.  I will try a different set and see if that speeds things up.  I have been saving to card in the camera up to now.


  Will Reply in the morning.



Link to comment
Share on other sites

Hi Guylain

  Saving to pc did keep the plan intact with everything as entered in the plan.  5 min 44 secs arghhh!  ! do understand that it was to make sure the plan was executed as written.

  I put a 2 second pause in all lines from .5  before the longest exposure to the 1 sec exposures after my longest exposure.  That executed as it is written.  Bye 3.1.14 RC1 erased about 10 seconds off the time it took because I had to enter 1 sec pause for the next line which was put in all the remaining lines.  That seems to be corrected now.for the next 11 entries.  Now my total time for execution is just under 2 mins (1 min 58 secs).  I expect that to become longer by several seconds when I run the plan  in the practice session .  Table top has been with the lens cap on.  I expect the additional data in the photo frames will make larger files to be transferred.

  I tried several different setups in the camera.  Nothing was able to use the plan with 0 pause.  Not a problem because I have extra seconds of totality in the plan as tested now.

  Strangely, now it works with a 1 second pause but I will go with 2 seconds because that didn't work every time, actually any time, before.

  Thanks for making "a silk purse from a pigs ear", in this case a long exposure purpose built program into a rapid fire solar capture program.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use