Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Go to solution Solved by astroman133,

Question

Hi,

I'm connecting BYN Version 2.0.4 to a Nikon D610, and am having a few problems.  I am using a 15' cable, but have used two other shorter cables with the same results.

The camera has been upgraded to the latest firmware version 1.009.  Camera AND Lens set to Manual Focus.  Camera is on Manual, and Sutter release is on S (Single)

 

When I try and connect using the Nikon Bar as opposed to the Nikon 2015 bar:

1.  It connects with my Microsoft Surface

2.  It does NOT connect with my Lenovo Ideapad (it WILL connect here with the Nikon 2015 Bar!)

 

Also on both computers The focus arrows are missing!  They were there at one time, but now are gone!

 

Help!  Going crazy.  Trying to get ready for the eclipse and getting panicked!

Link to post
Share on other sites
  • Answers 10
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

Popular Posts

I am sure that the issue matters to Guylain. It is a matter of priority, in advance of the eclipse. Since your issue has a workaround, it would be a lower priority than an issue where a feature is bro

I am not a Nikon user, so I not sure about which Nikon SDK version to use for your camera. Your camera was released in 2013 and if it is still supported by Nikon I would expect that any verison of the

Which instructions say to turn AF off? This is from the User Guide: Turn the Auto Focus OFF on the camera body and lens if you are using photo lens. You may have to turn it back to AF if you

10 answers to this question

Recommended Posts

  • 0
  • Solution

Which instructions say to turn AF off?

This is from the User Guide:

Turn the Auto Focus OFF on the camera body and lens if you are using photo lens.
You may have to turn it back to AF if you wish to use the focus Lens Drive in Frame & Focus Mode.

Those instructions seem to be contradictory but what they mean is that in order to prevent the camera from trying to autofocus when taking a picture the lens needs to be set to Manual Focus, but in order to drive the focusing from BYN with LiveView, it needs to be in Auto Focus.

What I would suggest is to start with the lens in AF mode, adjust the focus with the arrows in BYN, tape down the lens so that the focus cannot change and then put it into Manual Focus mode.

It seems like the Lenovo is missing a driver (part of Windows not part of BYN). Do you see the camera in the Windows Device Manager once it is connected and powered on? If not, there is nothing BYN can do.

Link to post
Share on other sites
  • 0

I am not a Nikon user, so I not sure about which Nikon SDK version to use for your camera. Your camera was released in 2013 and if it is still supported by Nikon I would expect that any verison of the SDK that was released since the camera was released should support it.

15' is about the maximum length for a USB cable. I would test with a shorter cable until you have a good idea of how BYN behaves and to eliminate the long cable as the cause of your issue.

You should download BYN 2.0.5. It is free. However, I don't know if it will fix your connection issue.

The reason why the focus arrows are missing or disabled could be because the lens is in Manual Focus mode. Setting it to Auto Focus may be necessary in order for BYN and the camera to drive the lens for focusing.

 

Link to post
Share on other sites
  • 0

Actually just upgraded to 2.0.5 with the same results. As I mentioned I have tried significantly shorter cables with no change in results.

Re Autofocus vs manual you are absolutely correct! Putting it in A/F solved the problem of the missing arrows!

BTW the Instructions sat turn Autofocus OFF!!

One problem solved, one to go!

Thanks!

 

Link to post
Share on other sites
  • 0
1 hour ago, eagha50 said:

 

When I try and connect using the Nikon Bar as opposed to the Nikon 2015 bar:

1.  It connects with my Microsoft Surface

2.  It does NOT connect with my Lenovo Ideapad (it WILL connect here with the Nikon 2015 Bar!)

 

Unless I'm missing something... what is the connection issue?  It connects on both computer, just with different SDK selection in BYN.  

 

 

Link to post
Share on other sites
  • 0

Astroman 133,  Thanks for your response!

Interestingly MY instructions do NOT include the second line about turning Autofocus back ON! That line appears to be missing from the PDF file that came with my software, so thanks for that clarification.

Admin: I assumed that the LATEST SDK would work with the LATEST BYN upgrade. It doesn't. I thought you should know.

If it doesn't matter to you, I guess it doesn't matter to me.

Regards.

Link to post
Share on other sites
  • 0

In general:  Choice of SDK really DOES matter.

These SDK's are produced by the Camera Manufacturers, and usually apply to only the Current Models and a few of the Older Recent Models.  In the Case of NIKON, where they source their Sensors from different Vendors (Nikon, Toshiba, Sony), these SDKs may also be Source-Specific.  (Canon has always sourced their Sensors Inhouse-Only, so their SDKs usually cover a greater range of Models.)

Link to post
Share on other sites
  • 0
8 hours ago, eagha50 said:

Astroman 133,  Thanks for your response!

Interestingly MY instructions do NOT include the second line about turning Autofocus back ON! That line appears to be missing from the PDF file that came with my software, so thanks for that clarification.

Admin: I assumed that the LATEST SDK would work with the LATEST BYN upgrade. It doesn't. I thought you should know.

If it doesn't matter to you, I guess it doesn't matter to me.

Regards.

I am sure that the issue matters to Guylain. It is a matter of priority, in advance of the eclipse. Since your issue has a workaround, it would be a lower priority than an issue where a feature is broken with no workaround.

Link to post
Share on other sites
  • 0
2 hours ago, eagha50 said:

No disagreement there!  I'm sure he's swamped! It was just the tone of the comment I found surprising.

Oh, and you'd be surprised at how many orders I'm getting daily for solar filter and solar glasses from US customers.  Apparently no US dealers has them anymore.

What I don't get is I'm still buying them from my US dealer supplier, they are shipped to Canada, then I ship them back to the US customers who buys them.  If I can still buy some so should the other US dealers.  They are missing on a huge, yet time-limited, market/opportunity.

Thanks again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use