Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

D500 connection


OrionAcht
 Share

Question

Last week we resolved the connection issues with my D810A, but I also have the same connection issue with the D500. Here is what I have done:

1. Tried BYN version 2.0.5, with the original Nikon D500 drivers - does not connect

2. Tried same with the latest D500 drivers downloaded from the Nikon SDK - same, no connection

OS is Windows 7. It is my understanding that there are people out there able to use BYN with the D500. How did you get it to work? I have attached my log file. Somebody please help. I am trying to get ready for the eclipse, and I need to be able to control both the D810A and D500.

Thank you.

logfile-[20170802-17h54m07s169]-[5808]-2017-08-02.txt

Link to comment
Share on other sites

  • Answers 6
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

6 answers to this question

Recommended Posts

  • 0

According to the Camera Support Guide for BYN, the D500 is fully supported.

The log file shows that the BYN installation is missing the SDK for the D500. Here is the message:

2017-08-02 17:54:23,736 [Main] DEBUG - Nikon drivers 'Type0020_D500/C:\Program Files (x86)\BackyardNIKONv2.0\Nikon\Type0020_D500\Type0020.md3' is loading...
2017-08-02 17:54:23,752 [Main] ERROR - Error loading Nikon driver file : 'Type0020_D500/C:\Program Files (x86)\BackyardNIKONv2.0\Nikon\Type0020_D500\Type0020.md3'
2017-08-02 17:54:23,752 [Main] ERROR - LoadLibrary failed to load MD3 file: C:\Program Files (x86)\BackyardNIKONv2.0\Nikon\Type0020_D500\Type0020.md3. Download the MD3 file for your device on Nikons SDK website: https://sdk.nikonimaging.com/apply/
2017-08-02 17:54:23,752 [Main] ERROR -    at BinaryRivers.Camera.Nikon.Wrapper.NikonMd3..ctor(String md3File, String md3EntryPoint)
   at BinaryRivers.Camera.Nikon.Wrapper.NikonManager..ctor(String md3File, String md3EntryPoint, SynchronizationContext context)
   at BinaryRivers.Camera.Nikon.NikonCameraManager.LoadManagers(String dir)
2017-08-02 17:54:31,271 [Main] INFO  - Camera Not Found!  Make sure it's connected to the PC and turned ON :)

Guylain may have a different suggestion, but you may be able to download the missing file per the error message. Or you could try installing BYN to a different, new folder to ensure that it was not a partially failed.

Link to comment
Share on other sites

  • 0

I have installed version 2.0.2 on another computer, and it works fine. Here is the log file for that with "desktop" in the file name. Next I uninstalled the current version from my laptop, installed version 2.0.2 on it, and it does not work. The log file for that has "laptop" in the file name.

Is it possible that the previously installed version leaves some hidden file or registry entry that is causing the issue, or is there something missing on the laptop that is present on the desktop? Both machines are running Windows 7.

logfile-[20170803-06h18m52s810]-[4668]-2017-08-03-Desktop.txt

logfile-[20170803-06h27m51s856]-[4288]-laptop.txt

Link to comment
Share on other sites

  • 0

BYE/BYN does not use the Windows Registry.

When you removed the current version from your laptop and installed 2.0.2, did you install it in the suggested location or did you select a new location? When you uninstall a version, not all files are deleted. When you uninstall a version to try to eliminate a problem you should either manually remove the remaining files or re-install BYN to a different directory.

According to the error in the log the file C:\Program Files (x86)\BackyardNIKONv2.0\Nikon\Type0020_D500\Type0020.md3 is will not load.

This type of error usually means that 1) the named file is missing; 2) some prerequisite file is missing or corrupted; 3) the named file is corrupted.

You can help narrow down which of these is causing the problem.

On the laptop look at the folder C:\Program Files (x86)\BackyardNIKONv2.0\Nikon\Type0020_D500. Does Type0020.md3 exist in that folder? What is its size? Is that the same size as on the desktop PC? These simple checks can help eliminate 1) and 3) above as culprits. You could also copy the file Type0020.md3 from the desktop to the laptop, replacing the current md3 file on the laptop.

If none of this solves your issue then it is likely that #2) above is causing the problem. This could be fixed by installing low-level drivers from the CD which came with the camera.

 

Link to comment
Share on other sites

  • 0

No, BYN/BYE do not use registry entries.  In fact you can copy the install directory on a usb drive and run the application from there.

If the camera is connecting on one computer and not the other then it means a Windows/Nikon driver is missing.

This is not a BYN issue/sdk file missing during the install because the same install on one computer works and not the other... which means something is different on one computer/Windows/drivers.  I'm not sure what to recommend at this point since this appears to be outside what BYN is installing :(

However, you may be missing a Microsoft C++ redistributable file.  Please install these 4 files.

https://www.dropbox.com/sh/fvpyily0qux5xuy/AAB_lZV0MQzXH8ZRnOfWxuBVa?dl=0

Let me know if that works,

Regards,

 

 

Link to comment
Share on other sites

  • 0
22 minutes ago, astroman133 said:

 

This type of error usually means that 1) the named file is missing; 2) some prerequisite file is missing or corrupted; 3) the named file is corrupted.

 

These are c++ files.  My guess is that the computer is missing the c++ redistributable file and as a result they are not being loaded.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use