Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

Connection problem


bob
 Share

Question

I am just getting back into hobby after a brief hiatus.

The problem I'm having is that my canon Xsi(450D) will not connect.

It was worked OK with my older pc

I have a newer pc now so that may be the problem.

I am now running W8.1 64bit Seems odd that my old Xti will connect though

Thanks for any suggestions, bob

Link to comment
Share on other sites

  • Answers 15
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

15 answers to this question

Recommended Posts

  • 0

Thanks for replying guys

When I try connect, 3 choices come up.

I have tried each one of them

I also have a modified canon 40D that used to connect but won't now.

I'm sure it is some little thing that I am doing wrong

regards, bob

 

Link to comment
Share on other sites

  • 0

Bob,

There is not much that you can do wrong except to select the incorrect SDK/driver.

These types of connection issues have been discussed in numerous posts on this forum.

1) wrong SDK selected
2) faulty camera
3) faulty USB cable
4) USB cable too long
5) user only using DSUSB shutter cable when the regular USB cable is also required
6) missing low-level driver
7) EOS Utility is running in the background and automatically connects with the camera (this prevents BYE from connecting)

For the XTi you must select the Canon210 SDK. For the Xsi and 40D you should select the Canon215 SDK.

All of the cameras require a low-level driver. This driver should be installed as part of Windows 8.1 and BYE expects that this driver is already installed and functioning. The driver will be loaded when Windows Plug and Play senses the camera as a new device.  You can test that this driver is installed and working by checking the Windows Device Manager after plugging the camera into the PC and turning it on. If you do not see the camera in the list of devices then Windows did not recognize the camera or was unable to load the low-level driver. This is either due to a faulty camera, faulty USB cable, or missing device driver. If you do not see the camera in the devices list then there is no way that BYE can connect with the camera. You can try a different cable or try your camera/cable combination on a different computer. If the camera is displayed in the devices list then I would suggest trying to connect the Canon EOS Utility application with the camera. If the EOS Utility is able to connect then BYE will connect (as long as the EOS Utility is not already connected).

Link to comment
Share on other sites

  • 0

eos utilities is there.but only recognizes Xti.

It doesn't make any sense to me that only one will open out of three

when they where all working at one time.

I really appreciate your time & don't want to take up anymore so I am going to go through Rick's

list of suggestions one at a time and see what happens.

I really have doubts but these darn cameras are just too expensive.

Thank You guys, bob

 

Link to comment
Share on other sites

  • 0

If the version of the EOS Utilitiy that you are running was installed from the CD that came with the XTi, then that explains why the XSi and 40D are not recognized, even if the low-level drivers are correctly installed. The reason is because the XSi and 40D are newer than the EOS Utility and the version of the SDK that it uses.

Whenever Canon releases a new camera they must update the Canon EOS SDK to support that camera model. They release the updated SDK and EOS Utility on the CD that comes with the camera. The 40D was released in 2007 and the XSi (450D) was released in 2008. If you install the EOS Utility and SDK that came with the XSi, you may get it to connect with all three cameras, as long as the low-level drivers are all present and installed when the cameras are connected and powered on.

Link to comment
Share on other sites

  • 0

Thanks for the suggestion Rick. Found the old disk for the 40D but it accomplished nothing.

Went into device manager and nothing there either.

Tried all the SDK's

How can I find if the eos utility is running in the background

I have tried connecting to my wifes pc and only  Xti  will open there

Think its time to throw in the towel and look for another camera

Thanks for all the help, bob

 

 

 

 

Link to comment
Share on other sites

  • 0

Trying "all the SDKs" is the wrong way to go. I recommend that you follow my suggestions as to which SDK to choose for which camera.

If the camera does not show up in the Device Manager list then neither BYE nor the EOS Utility will be able to connect with the camera.

The Task Manager will show you the active processes, including the EOS Utility, if it is running.

It sounds like your Windows 8 system does not have the drivers for either the XSi or the 40D. That seems strange because I had thought that the low-level driver that you need are part of Windows. You can download the equivalent of the CD that came with the camera from the www.usa.canon.com web site. You just have to type in the camera model (either "EOS 40D" or "EOS Rebel XSi") to see a download link for "EOS Digital Solution Disk Software 29.1A for Windows (For users who cannot use the bundled CD)".

Link to comment
Share on other sites

  • 0

Rick, I did as you told me I just wrote it wrong with SDK choice you said for each camera.

Camera does not show in device manager

As I said', I loaded the original disk that came with the 40D camera.but did not help

I will try the canon site for 40D & 450D for downloads

Will try in the morning as I have been at this problem all day

Hope you guys are getting some good weather where you are. I won't even mention what we have been getting for the last month, regards, bob

Link to comment
Share on other sites

  • 0

We are into our summer rainy season. No astronomy around here until late September.

There is no sense trying to connect BYE and your camera if Windows is not recognizing the camera and loading the low-level driver (visible in the Windows Device Manager).

So if Windows is not recognizing one or more cameras then the problem is likely either a faulty camera, a faulty cable, faulty USB hub in the PC or faulty Windows installation.

It will help if a friend has a PC, cable and Canon camera that are known to be good then you just need to swap parts around to determine what is faulty.

If the friend's cable and camera work on his/her PC then try them on your PC. If his/her camera and cable do not work with your PC then the problem is your PC. The retailer where you purchased the PC or PC repair shop may be able to help. Take your gear to them and show them what your are trying to do.

Link to comment
Share on other sites

  • 0

The Low-Level Canon Drivers contained on a "Canon CD" Image does not compass the entire historical list of DSLR Models.  Also, the Installer Package used in more recent years only installs Drivers for the Models that it Detects.

So...  You will need to ensure that you install the Drivers for each of the Cameras that you wish to Test/Use, and do so with that Camera attached via USB and Turned-On at time of Install (so that it can be detected).

Perhaps you have already done this, but the Thread above seems to that you successfully installed the Low-Level Drivers for your XTi only.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use