Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

5D Mark 1 will not connect.



I tried to connect a 5D mark one to BYEOS, and it doesnt connect. I am running 32 bit vista, I have the dsub box I got from Shoestring. They have a small utility to check to see if the DSUB box is working. I ran the utility and it is communicating with my laptop. When I choose the correct model in your software, I get that sound from the laptop (Like a lightning bolt?). any thoughts?

Link to comment
Share on other sites

  • Answers 20
  • Created
  • Last Reply

20 answers to this question

Recommended Posts

The 5D should connect if you are using a short, functional USB cable, the camera is turned on, and the kernel mode driver (plug and play) driver for your O/S (32-bit Vista) is installed. In BYE you also must select the Canon210 SDK during connection.


Of course, you will not have LiveView, the sensor temperature is not available, and you must use a second parallel cable for shutter control when shooting BULB exposures.

Link to comment
Share on other sites

OK, Its connected now, But when I try to snap an exposure, it bombs. Here is the log file.


17:50:21  Licensed to joehaber1
17:50:28  Attempting to connect camera...
17:50:28  Canon drivers 'Canon210\' initialized.
17:50:29  5D CONNECTED!
17:50:42  Imaging session started.
17:50:43  Imaging session cancelled
17:50:43  ERROR EDS_ERR_NOT_SUPPORTED : EDSDK.EdsSetPropertyData(cameraRef, SaveTo(11), 0, size(4), 2)
17:50:43  Imaging session cancelled
17:51:19  Copy to clipboard


Any more Ideas?


Thank you for your quick replies.

Link to comment
Share on other sites

As Rick said, your issue is not that it does not connect, it is where you are saving images.


17:50:43  ERROR EDS_ERR_NOT_SUPPORTED : EDSDK.EdsSetPropertyData(cameraRef, SaveTo(11), 0, size(4), 2)


Use save to PC only, it should work.

Link to comment
Share on other sites

I switch the camera to manual, and bulb in the program, still have the same problem. Took the lens off...no difference. Tried a canon nifty 50 lens, still the same problem. I thought it might be a setting in the camera, so I reset all the settings, still the problem exists. My camera has the latest firmware too. when I go to "My Computer" I see the CF card in the camera as a drive. I have an interlovmeter I had been using so I know the port on the camera is ok. I am totally lost on this one, I want to pack up everything and send it to you. LOL I love your program Im using the heck out of it. Just not with the 5D. Bummer

Link to comment
Share on other sites

I believe that your cache is corrupted. The Shutter dropdown does not contain all the appropriate settings and neither does the ISO dropdown. That is why you cannot change the ISO.


I would suggest starting BYE without connecting to your camera. Then go into Settings; then Advanced Settings and click on Delete Cache Data. Exit BYE and relaunch it. See if you have all the correct entries in those dropdowns after connecting to the camera.

Link to comment
Share on other sites

Hi Joe, 


Got the log files, thank you.


I don't think it will ever work with your camera.  For some odd reason your camera is not reporting any Tv/Av values and 3 other important properties are reporting Unknown.


2017-01-27 19:46:43,204 [Main] INFO  - CameraPropertyChangedArgs fired: SaveTo               = 'Unknown'
2017-01-27 19:46:43,204 [Main] INFO  - CameraPropertyChangedArgs fired: Tv                   = ''
2017-01-27 19:46:43,219 [Main] INFO  - CameraPropertyChangedArgs fired: Av                   = ''
2017-01-27 19:46:43,251 [Main] INFO  - CameraPropertyChangedArgs fired: Iso                  = 'Unknown'
2017-01-27 19:46:43,297 [Main] INFO  - CameraPropertyChangedArgs fired: AeMode               = 'Unknown'
Is there a setting on the 5D to take pictures without a card?  If yes try that.
My only suggestion at this time would be to perform a camera factory reset hoping a setting in the camera is causing this to occur.
I'm honestly stump.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use