Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Success, then a problem.



I successfully used BYE to take 10 images of Orion's belt and sword last night.


This morning I tried to reconnect my camera and I'm getting "USB has malfunctioned and the device is not recognized". I've tried going to the device manager panel and updating all the USB drivers, as well as deleting the Universal Serial Bus Controllers and letting the system reinstall them on start-up.


HOWEVER, the system will NOT let me delete some of them, and the manufacturer's support software does not give me any help or recognize any problems.


Any suggestions??


I love the features of BYE especially the frame and focus feature which has always been my problem in the past.



Link to comment
Share on other sites

  • Answers 11
  • Created
  • Last Reply

11 answers to this question

Recommended Posts

Well - I just tried my SHORT 12" USB cable from Canon and LOW and BEHOLD - BYE connects and controls the camera just fine!! It simply doesn't like my 15' USB cable I bought on Amazon!! Even though it worked initially!! How'd have guessed!! Now I just need to return this cable and find a LONG ONE (over 10 feet) that will work!

Link to comment
Share on other sites



Windows Update should not remove applications. Did you re-install Windows from scratch? Probably not recommended, as you found out.


Do you have the CD that came with the camera? If so it may install the correct driver. If so then the likely culprit was that Windows Update installed patches to Windows 10 and clobbered the correct driver.


Your issue is purely a Windows problem and there is nothing that BYE can do about it.

Link to comment
Share on other sites

Well I just did an update of Windows 10 on my computer. Which means I lost all my programs, but the real problem is that Windows STILL DOES NOT RECOGNIZE my CAMERA!!


Wow, talk about a steak of bad luck.  I feel for you :(

Link to comment
Share on other sites

Oh man I've spent the last 2 days and no luck still. Any solutions suggested by Windows 10 support has not helped, nor has the computer manufacture (HP). I tried loading Canons EOS utility but all to no avail. Guess my next step is to take it to a computer repair place locally and see if they can figure it out.

Link to comment
Share on other sites

No idea, sorry :(


However, you are on the right track with trying EOS Utility.  You need to make this work with EOS Utility first and foremost. 


Did you try doing a full camera reset to factory settings?  This may resolve the issue.



Link to comment
Share on other sites



I am glad that you figured out what was going on.


You never mentioned the long cable and it never occurred to me that this could be your issue.


The USB 2.0 standard gives a max length of 5 meters (16.5 feet) but I am not surprised that an inexpensive cable from Amazon does not meet that standard.


A high quality USB 2.0 active extension cable should do what you need.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use