Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

5x Liveview button not working with Canon 1200D



I have been having problem getting the 5x button to do anything during liveview with my Canon 1200D. Clicking on that button does not do anything. The same button worked previously when I was using a Rebel SL1. This is very frustrating as I cannot zoom in enough to use my B-mask for focusing. Is it a bug or is it a limitation with the camera?


I found that I could sometimes (or most times?) activate the 5x function by physically pressing the zoom button on the camera body when live view is operating. But this necessitate a short trip to the camera itself from my warm room.



Link to comment
Share on other sites

  • Answers 5
  • Created
  • Last Reply

5 answers to this question

Recommended Posts

I tried to duplicate your issue with BYE 3.1.8 and my T5i (700D). I tried with both the Canon215 and Canon SDKs. The 5X Zoom button on the Frame & Focus panel worked every time.


It would help if you provided more information, such as:


What version of BYE are you using? If not 3.1.8, you should upgrade and try to duplicate your issue.

Which SDK (Canon or Canon215) are you selecting when you connect?

Does it work differently when you bench test it with a lens on the camera rather than connected to a telescope, but still using BYE?

How does it behave when the camera is not tethered to a PC and you are operating it solely with the hardware buttons on the camera?


The fact that nobody else has reported this issue and that apparently the zoom button on the camera is not 100% effective makes the camera suspect.

Link to comment
Share on other sites

Thank you for the reply.

I did a dry run of BYEOS trying to capture the problem on a fresh log file, but alas I could not reproduce the problem any more?!

The only difference is that with the dry run I used a camera lens as opposed to a T-ring to a telescope.

The 5x button seems to be working during the dry run, at least with the camera lens.

The only thing I noticed is that there is a significant lag between clicking on the button and the screen actually changing.

So may be it was just lagging but actually working - and may be I was too impatient and clicked the 5x button one too many times.

Anyway I have included two log files - one from today (Dec 1 here in NZ) in which the 5x button seems to be working (but slow) and an older log in which the 5x button seems to be not working at all.






Link to comment
Share on other sites

The lag is normal and intentional.  This is because on some model 5x zoom is only possible a few seconds after live view has been initiated so if you click 5x zoom within 3 to 5 seconds of the mirror flipping up it will lag but if you click 5x a solid 5 second after the mirror was flipped up it should almost instant.


I'll try to look and the log files later today.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use