Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
  • 0

Can't connect my D5300 to BYN




I've researched this and did learn to turn on "Ask for drivers" or similar in the Settings/Advance.

But, see log:

11:33:39  Licensed to r.rolle@proton.me
11:33:40  BackyardNIKON 2.1.3 Trial Edition
11:33:55  Attempting to connect camera...
11:33:55  Nikon/D5300 drivers initialized.
11:34:03  Camera Not Found!  Make sure it's connected to the PC and turned ON :)
11:34:36  Attempting to connect camera...
11:34:37  Nikon2015/D5300 drivers initialized.
11:34:44  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

The firmware is C 1.03 (L 2.000).

I'm using a short 2' cable that even sports a ferrite bead thing. Tried a longer cable but bought this short one. Either cable works with video apps on an Android phone or even qDslrDashboard in Windows.  Camera in Manual and turned on.

Windows Device Manager shows the D5300 under Universal Serial Bus with driver C:\Windows\System32\Drivers\winusb.sys so I'm guessing the initialized D5300 specific drivers are removed after the camera fails to connect.

Thanks for any help.



Link to comment
Share on other sites

  • Answers 13
  • Created
  • Last Reply

Top Posters For This Question

13 answers to this question

Recommended Posts

  • 0

I did use the Nikon driver just before Nikon2015 and ever since in tests. No change.

11:33:55  Nikon/D5300 drivers initialized.
11:34:03  Camera Not Found!  Make sure it's connected to the PC and turned ON

How does this work? My driver shown in Device Manager is a winusb.sys driver and does say my D5300 is connected and working.  This is a USB driver. Does BYN install and initialize a second driver to "speak" to this USB driver? Or, is BYN communicating with the Windows USB driver specifically for each camera model, calling this "Nikon/D5300 drivers".

For those with working camera connections to BYN, what drive do you see in Device Manager, something different from my winusb.sys?  

In the meantime, next clear night, I'll simply use qDslrDashboard that works fine with my default winusb.sys driver - focus assistance. Oh, and with qDslrDashboard connected to my D5300, I thought I would give BYN a try - nope.  




Link to comment
Share on other sites

  • 0

BYN uses the Nikon SDK to talk to the camera, through the low level driver that is part of Windows. You can see from your log fragment that the D5300 driver from the Nikon SDK was initialized.

I am not a Nikon owner, so I cannot tell you with other Nikon owners see in the Device Manager.

I believe that qslrDashboard does not use the Nikon SDK.

Finally I will say that only one application can be connected to the camera, so if qslrDashboard is connected to the camera, BYN will be unable to connect and may display the "camera not found" error that you are seeing.

Link to comment
Share on other sites

  • 0

Thanks. Not being a Windows user for over a decade,  I tried BYN with qDslrDashboard once just to see if qDslrDashboard " seeded", whatever, the connection for BYN. Nada.

APT can't connect either so I'm not blaming BYN.

Against the recommendations presented by BYN after the camera doesn't connect, I tried a HUB connected to the Windows PC USB-C hoping more power would make a difference. No difference.

The D5300 battery shows full but the battery has been used a few times. I'll try AFTER a full charge. 

The D5300 battery has to be removed to be charged; there is no camera connection to AC.

Beside buying another cable or locating another PC, I don't know what else to try. 

I'll have my son bring his Nikon D7* next time he visits. Unused, full frame.  (Hope it works and he wants to loan it.)

Link to comment
Share on other sites

  • 0

If qslrDashboard is still connected to the camera, neither BYN nor APT will be able to connect. At this point if qslrDashboard can connect and control the camera then the cable must be working. I would make sure that qslrDashboard is disconnected and completely shut down with no orphan qslrDashboard processes visible in the Windows Task Manager. I might even unplug the USB cable from the PC, wait 30 seconds or so, and reconnect it.

I would use a short, known good, cable along with a well-charged battery and follow Nikon's guidelines to NOT go through a USB hub at least until you have proven that you can reliably connect BYN to the camera.

One user, per the archives of this forum, tried to connect his D5300 to a netbook class computer. It reliably failed until he upgraded to a more powerful machine. If you have a regular 14" or larger laptop running Windows 10 or 11 make sure that the USB ports are set to always provide power (not shutdown to save power). The computer should be plugged into an A/C outlet to provide continuous power.

A few other D5300 users have had connection issues that mysteriously resolved themselves, so if all else fails I would reboot the computer and try connecting BYN without running qslrDashboard first.

A full log file from the BackyardTEMP\Logs folder may be more revealing than the abbreviated log history that you posted. The O'Telescope admins would prefer that you not post multiple log files here. You could delete all the Logs and then try one time to connect BYN to your camera then immediately shut it down. Look at the log file and if it is not too large, attach it to a post to this forum. Otherwise I would wait until they ask for a log file and send it to their support email address.

This is more for the developers than you, but it could be that the Nikon SDK needs some prerequisite software, like a C++ Run-time Library, that your PC is missing. Since I am not a Nikon user, I am unable to troubleshoot that issue, but it could cause both BYN and APT, as well as any other software that uses the Nikon SDK, to fail in the same way.

I hope this helps.


Link to comment
Share on other sites

  • 0

The C++ run-time library seems properly installed, otherwise the Nikon/D5300 drivers would not initialize, and since it does we can rule this out as a possible cause.

Is your SD card full of images? Several years ago, the SDK would index all images on the SD card *before* passing control to the camera to establish a connection... and fewer images on the SD card would speed it this process considerable. This said, try with an empty SD card.

Link to comment
Share on other sites

  • 0

Thanks everyone.

I checked for any processes q, dslr, dashboard and could not find any evidence of qDslrDashboard background processes.  Browsed processes also. I also noticed Sharpcap doesn't connect to a web type camera if qDslrDashboard has the camera but as soon as I close qDslrDashboard Sharpcap connected to the camera.

The camera is fully charged. There were only a few images stored and I deleted them.

I deleted the BackyardTEMP log folder before trying again.

Connected the camera. Device Manager reports the device NIKON DSC D5300 is working properly. The winusb.sys driver version is 6.1.7600.16385 as I think I have mentioned.  I mention this driver version because I read that one camera control app had trouble using Nikon SDK after the user had used Zadig to install a winusb.sys driver. I believe I ran Zadig.  I have not been able to confirm if the above driver is current. It's dated 6/6/2012 which seems old.  Device Manager says it's current when I try to update it.  There are no drivers to install under Windows Update / Options/....

So.... after the above....

20:45:03  Licensed to r.rolle@proton.me
20:45:03  BackyardNIKON 2.1.3 Trial Edition
20:45:12  Attempting to connect camera...
20:45:13  Nikon/D5300 drivers initialized.
20:45:20  Camera Not Found!  Make sure it's connected to the PC and turned ON :)

The single log file is attached.

My mini PC, running headless, is attached to the telescope mount. I'm VNC'ing from a laptop:

Processor    AMD Ryzen 5 5560U with Radeon Graphics, 2301 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date    American Megatrends International, LLC. FP655U508, 3/31/2023
OS Name    Microsoft Windows 11 Pro
Version    10.0.22621 Build 22621


Link to comment
Share on other sites

  • 0

Senior moment above.

I had the web camera (Revolution Imager) connected to the Windows Camera app, Cheese, Photobooth, whatever it's called, NOT qDslrDashboard, of course. Sharpcap wouldn't connect until I closed the Windows camera app.  

Also, I can't remember anymore if qDslrDashboard asked me to use Zadig to load the usb driver. I do believe it was the first camera control app I tried with my new PC after using it on an Android phone.  I've been away from Windows for years and already I'm tinkering with non-Windows supported system maintenance programs. Crazy. Wouldn't dare with Mac. Wild West. 

So, did I install a hacked winusb.sys that conflicts with the Nikon SDK as suggested at this link:


If so, I'm sorry I've wasted everyone's time.  

Link to comment
Share on other sites

  • 0

Yes, I've done that and Windows (searching the PC only, not online anymore since Windows 10 I read) reports I have the latest and greatest driver. 

Hopefully, that's not the issue.

Well, if I ever see the stars again in the NE I have a PC-at-the-scope setup I can use.  I'll try BYN again in a few months as something always changes in Tech Land.  

I really appreciate being able to test a full version of BYN, not crippled in some way.  

Might as well close this ticket.

Thanks to all.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use