Jump to content

Canada's top-tier Telescopes & Accessories
Be as specific as possible when reporting issues and *ALWAYS* include the full version number of the application you are using and your exact *CAMERA MODEL*
NEVER POST YOUR KEY IN ANY PUBLIC FORUM, INCLUDING THE O'TELESCOPE SUPPORT FORUM ::: IF YOU DO YOUR KEY WILL BE DEACTIVATED WITHOUT NOTICE!
  • 0

kNkMAIDResult_ValueOutOfBounds - D600


shoffy

Question

I am getting a kNkMAIDResult_ValueOutOfBounds (kNkMAIDCommand_CapStart, 33560, kNkMAIDDataType_GenericPtr, 485221828) error message randomly while trying to capture under the Imaging tab.

 

My experience is similar to the person posting here on SourceForge:

http://sourceforge.net/p/nikoncswrapper/discussion/general/thread/643b382d/

 

 

I have a D7100, it used to work good, but today suddenly start throw kNkMAIDResult_ValueOutOfBounds exception when I call NikonDevice.Capture() method.

 

I searched and found this error only related to preview image or try to update some value; Capture method should not bring a kNkMAIDResult_ValueOutOfBounds exception.

 

And it occurs randomly, after I turn off/on camera and try again, it may happen after a few acquisitions (less than 10).

 

Any thoughts?

Link to comment
Share on other sites

  • Answers 16
  • Created
  • Last Reply

16 answers to this question

Recommended Posts

I feel like a fool.  A lucky fool but a fool nonetheless.

 

It's a clear night here and I've had great success with BYN.  The error hasn't occurred once *knock wood*.  

 

I'm making note of the USB port and cable I'm using.  Everything is going great.

Link to comment
Share on other sites

Other Nikon users have reported the same error (kNkMAIDResult_ValueOutOfBounds). You should find their posts by searching the forum for the error name.  They were able to work around the issue by changing the camera setting to 12-bit mode, or by removing the lens.

 

I do not see any resolution.  Guylain asked for more information and the threads went dormant.

Link to comment
Share on other sites

Thank you for the note to search the forum Rick.  I tried to search, though not very hard, without success.  I will try 12-bit mode.  I'm not sure I understand your note about removing the lens because the lens, in this case, is my telescope with a field flattener.

 

The log files can be found here:

https://drive.google.com/file/d/0BxFAJgtuBCDSeUdybmF2blhrTmM/view?usp=sharing

Link to comment
Share on other sites

Thank you Yves.  I had noticed something similar recently but neglected to mention it.  (shame on me)  All was well until there was about 20% battery remaining.

 

I'm using an A/C adapter now and haven't had the issue since.

Link to comment
Share on other sites

Thank you Rick for your advice and Guy for looking into the logs. I will try the 12-bit setting and see how that goes.  I will also try shooting only JPGs (no RAW).

 

My gut tells me the issue is related to my NexRemote, NexHub, BackyardNikon, Stellarium, and AstroTortilla software setup.

 

I encountered the OutofBounds error before when only using BYN.  Now that I'm using multiple programs the issue is more frequent.  I'm not a developer but it feels as if a function is trying to execute before all of the cleanup from the previous function is complete.  

 

*shrugs*  Or I'm just making things up.

 

To be continued...

Link to comment
Share on other sites

After some experimentation, I found I receive the error only when the shutter is set to BULB.  

 

For example, if I set the shutter to BULB and duration to 1.  I receive the outofbounds error.  If I set the shutter to 1, which disables the ability to add duration, I do not receive the outofbounds error and the capture plan executes as expected.  It would appear that this is the way to go if I want exposures that are 30 seconds are shorter.

 

If this holds, the issue will only arise if I want an exposure greater than 30 seconds or when AstroTortilla uses BYN to capture an image.

Link to comment
Share on other sites

Ummm, can the D600 really do BULB over USB?

 

I have it set to yes in BYN but if the camera can not then I need to unset this capability in BYN and force the use of a serial cable.

 

Would you happen to have a serial cable?  If yes go to Settings -> Advance Settings and set FORCE USE SERIAL CABLE.  Then, in the capture plan, select your serial cable (or COM port).

 

Keep me posted please.  The error seems to happen when the BULB end command is sent, not when BULB start is sent.

 

Regards,

Link to comment
Share on other sites

I'm not sure if the D600 can but if my experience is any indication I'd guess "no."

 

I will attempt BULB with a serial cable and let you know. Thank you for the tip. Your point about the BULB end command makes sense.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...

Important Information

This site uses cookies to offer your a better browsing experience. You can adjust your cookie settings. By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies, our Privacy Policy, and our Terms of Use